gifts2017

Просмотр текстовых файлов на сервере

Опубликовал Виктор Клевцов (taiba) в раздел Администрирование - Сервисные утилиты

Обработка позволяет просматривать текстовые файлы в каталоге временных файлов на компьютере сервера 1с. Требуется серверный общий модуль.

Эта простая обработка позволяет просмотреть текстовые файлы в каталоге временных файлов на том компьютере, где работает сервер 1С. Например, если запускаются скрипты, пишущие туда протоколы. Можно фильтровать по маске. Файл можно просмотреть (Enter или двойной клин на строке), и удалить - кнопка на панели.

Для работы обработки нужен общий модуль РаботаСФайламиНаСервере, в свойствах которого указана работа на сервере и не указана работа на клиенте.

Свойства модуля 

В нем должны быть 3 функции, прописанные в модуле объекта в обработке:

Функция ПолучитьСписокФайлов(СортироватьПоДате=Ложь, МаскаФайлов = "*.txt") Экспорт
Перем тзФайлы, НайденныеФайлы, НайденныйФайл, НС;
	
	тзФайлы = Новый ТаблицаЗначений;
	тзФайлы.Колонки.Добавить("ДатаФайла");
	тзФайлы.Колонки.Добавить("ИмяФайла");
	
	НайденныеФайлы = НайтиФайлы(КаталогВременныхФайлов(), МаскаФайлов);
	Для Каждого НайденныйФайл из НайденныеФайлы Цикл
		НС = тзФайлы.Добавить();
		НС.ДатаФайла = НайденныйФайл.ПолучитьВремяИзменения();
		НС.ИмяФайла  = НайденныйФайл.ПолноеИмя;
	КонецЦикла;
	Если СортироватьПоДате Тогда
		тзФайлы.Сортировать("ДатаФайла")
	КонецЕсли;
	
	Возврат тзФайлы;
КонецФункции

Функция УдалитьФайл(ИмяФайла) Экспорт
	Попытка
		УдалитьФайлы(ИмяФайла);
		Возврат Истина
	Исключение
		Возврат Ложь
	КонецПопытки;
КонецФункции

Функция ПолучитьТекст(ИмяФайла) Экспорт
Перем Текст;
	
	Текст = Новый ТекстовыйДокумент;
	Текст.ТолькоПросмотр = Истина;
	Текст.Прочитать(ИмяФайла);
	
	Возврат Текст.ПолучитьТекст();
КонецФункции

 

Скачать файлы

Наименование Файл Версия Размер
Обработка в архиве 3
.zip 8,87Kb
16.08.13
3
.zip 8,87Kb Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.