gifts2017

Альтернативная печать чеков для термопринтеров. Хозяйке на заметку.

Опубликовал david (dav405) в раздел Программирование - Практика программирования

Простой способ побороть медленную печать коротких документов на термопринтерах при кривых драйверах.

Пару лет назад возникла проблема - термопринтер печатал чеки с задержкой до одной секунды. С учетом нервничающей очереди, это абсолютно недопустимая роскошь. Устроившее всех решение основано на том, что матричные и термопринтеры настраиваются и управляются так называемыми эскейп-последовательностями, т.е. потоком получаемых данных. То есть, я просто записываю чек  ф промежуточный файл (включая управляющие коды и команду обрезки чека), а затем копирую этот файл на порт принтера.

/* Конкретную модель принтера уже не помню, по-моему какой-то CITIZEN, просто вчера жаловался коллега на аналогичную проблему, так что решил вот написать заметку о том. что не обязательно мучаться и искать дрова, если можно "написать" их самому */

 Вот пример процедуры печати:

//******************************************************************************
// Печать(Докум)
//
// Параметры:
//  Нет
//
// Возвращаемое значение:
//  Нет
//
// Описание:
//
Процедура Печать(Докум, Устройство=1, КолвоКопий=2)
 Перем НачПовт, КонПовт;
 Текст=СоздатьОбъект("Текст"); 
 Текст.КодоваяСтраница(1); 
 Текст.ДобавитьСтроку(симв(27)+"@"); //
 номердок=число(докум.номердок);  
 датадок=строка(докум.датадок);
 стр="";
 Текст.ДобавитьСтроку(СТр);
 Текст.ДобавитьСтроку(СТр);
 Стр=ФиксШаблон("Чек [номердок] от [датадок] ");
 Текст.ДобавитьСтроку(СТр);
 //Текст.ДобавитьСтроку("                Чек                  ");           
 Текст.ДобавитьСтроку(" №           Наименование                  ");    
 Текст.ДобавитьСтроку("  Код        количество     цена       сумма");
 Если Докум.Скидка.Выбран()=1 Тогда
  Врстр="Общ";     
  процент=Докум.Скидка.Процент*0.01;
 иначе
  Врстр="Сумма";
  процент=0;
 КонецЕсли;
 СчетчикЦикла = 0;
 // выводим табличную часть
 Н = 0;
 Докум.ВыбратьСтроки();
 ИтогоСкидка=0;
 Пока Докум.ПолучитьСтроку() = 1 Цикл
  Н = Н + 1;
  скидка=Окр(Докум.Цена*Докум.Количество*процент,2,0);
  ИтогоСкидка=ИтогоСкидка+скидка;
  Печкол=Докум.Количество;
  ПечНаим=СокрЛП(Докум.Номенклатура.Наименование);
  Печкод= СокрЛП(Докум.Номенклатура.Код);
  ПечЦена=Докум.Цена;
  ПечСумма=Докум.Сумма;
  Если Окр(Печкол)=Печкол тогда
   Печкол=Окр(Печкол);
  конецесли;          
  Стр=ФиксШаблон("[Н ] [ПечНаим                                 ] ");
  Текст.ДобавитьСтроку(СТр);
  Стр=ФиксШаблон("[ Печкод ]   [Печкол]    [ПечЦена]   [ПечСумма] ");
  Текст.ДобавитьСтроку(СТр);
 КонецЦикла;
 СуммаИтог = Докум.Итог("Сумма");
 Стр=ФиксШаблон(" Итого: [     СуммаИтог           ] руб.");
 Текст.ДобавитьСтроку(СТр);                           
 Стр=ФиксШаблон(" Итого скидка: [ ИтогоСкидка ] р.    ");
 Текст.ДобавитьСтроку(СТр);                           
 Стр="";
 Текст.ДобавитьСтроку(СТр);                           
 Текст.ДобавитьСтроку(симв(29)+симв(86)+симв(66)+симв(1));//Обрезать чек!!!
 ИмяФ=КаталогИб()+"Врем";
 Текст.Записать(имяФ);
 ФС.КопироватьФайл(ИмяФ+".txt","com1",1)  ; 
 ФС.КопироватьФайл(ИмяФ+".txt","com1",1)  ; 
КонецПроцедуры // Печать()

Сами ESC-последовательности для конкретной модели ВСЕГДА имеются в документации на сайте производителя, обычно по-английски, но кого это остановит? 

 

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Tiger77 (Tiger77) 03.05.09 14:38
Есть же компонента ExtPrint, нафиг ж так мучиться ?
2. david (dav405) 03.05.09 14:53
Ключевое слово - "скорость".
(1) Про компоненту не знал, можно (было бы) потестить скорость, весьма
сомневаюсь, что не тормозит на те же 0.5-1 секунду.

(1) А как в ней чеки обрезать? Штрих-коды печатать?
3. Игорь Белышев (biv75) 03.05.09 16:06
Очень полезные знания, при работе из под виндов с матричным принтером лучше варианта не найти, сам постоянно использую, зная ESC команды можно и шрифтами управлять и межстрочными интервалами.. да всё можно делать и скорость конечно тут не маловажный фактор.
4. Сhe Burashka (CheBurator) 03.05.09 18:56
5. Алексей (ACE$) 01.07.10 11:44
(0) а зачем 2 раза копировать в порт?
(4) На проклабе
6. david (dav405) 03.07.10 11:16
(5) Дык две копии чека, однако. Это из электротехнического магазину. Второй оставляли складским при отпуске товаров. //Каменный век :).
7. Алексей (ACE$) 04.07.10 21:51
вообще, сугубо полезную идею кинули ;) безо всяких ВК почти на любом принтере! Я сие приспособил для печати предварительных чеков в кафе под УТ
8. yurok kozorez (kozorez) 24.06.13 04:04
Еще бы кто сказал как просто послать Симв(0) ? для многих команд очень нужно. И зачем писать в файл когда можно сразу в порт принтера?
Попытка 
    Драйвер=СоздатьОбъект("MSCOMMLib.MSComm.1"); 
Исключение 
    Предупреждение("Не могу создать объект");    
    Возврат; 
КонецПопытки; 
Драйвер.Settings ="115200,N,8,1";

Драйвер.CommPort =2;
//сообщить("драйвер "+ драйвер+"  порт "+Драйвер.CommPort+"  настройки "+ Драйвер.Settings);
Попытка   
    Драйвер.PortOpen=1; 
Исключение  
    Предупреждение("Не могу открыть порт");    
    Возврат; 
КонецПопытки; 
Если Драйвер.PortOpen=0 Тогда 
    Предупреждение("Не открыт порт");    
    Возврат; 
КонецЕсли;  
Драйвер.Output=(Симв(27)+"@"); // инициализация 
Драйвер.Output=(Симв(27)+"!"Симв(0));// выбрать шрифт1  
Драйвер.Output=
AnsiToOem("12345678901234567890123456789012345678901234567890123456789­0")+Симв(13)+Симв(10));  
Драйвер.Output=(Симв(27)+"!"+Симв(1)); // выбрать шрифт 2
Драйвер.Output=(AnsiToOem("12345678901234567890123456789012345678901234567890123456789­0")+Симв(13)+Симв(10)); 
Драйвер.Output=(Симв(27)+"!"+Симв(2)); // выбрать шрифт0
Драйвер.Output=(AnsiToOem("12345678901234567890123456789012345678901234567890123456789­0")+Симв(13)+Симв(10));
Драйвер.Output=(Симв(12)+Симв(13)+Симв(10));
Драйвер.Output=(AnsiToOem("1234567890")+Симв(13)+Симв(10)); 
Драйвер.Output=(Симв(27)+Симв(77)); //  
Драйвер.Output=(AnsiToOem("1234567890")+Симв(13)+Симв(10)); 
Драйвер.Output=(Симв(27)+Симв(71)); // 
Драйвер.Output=(AnsiToOem("1234567890")+Симв(13)+Симв(10)); 
Драйвер.Output=(Симв(27)+"a"+Симв(2)); // прижать вправо  
Драйвер.Output=(AnsiToOem("0987654321абвгдеёжзийклмнопрстуфхцчшщъьэюя")+Симв(13)+Симв(10));   
Драйвер.Output=(Симв(27)+"!"+Симв(1)); // выбрать шрифт 2  
Драйвер.Output=(AnsiToOem("   "));
Драйвер.Output=(Симв(27)+"a"+Симв(1)); // центр
Драйвер.Output=(AnsiToOem("0987654321абвгдеёжзийклмнопрстуфхцчшщъьэюя")+Симв(13)+Симв(10));
//Драйвер.Output=Симв(12); //конец страницы
Драйвер.Output=AnsiToOem(Симв(27)+"d"+Симв(2)); // прогнать две строчки 
Драйвер.Output=AnsiToOem(Симв(27)+"i"); // обрезка 

Драйвер.PortOpen=0; 
Драйвер=0;
...Показать Скрыть
9. yurok kozorez (kozorez) 24.06.13 04:05
Шрифт 1 не выбирается потому что Симв(0) в семерке не работает
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа