Отправка сообщений пользователям 1С

Опубликовал V P (Vovus) в раздел Администрирование - Системное

Отправка сообщений активным пользователям! Обработка крайне проста, и не нужно вносить изменения в конфигурацию.

Отправка сообщений активным пользователям! Обработка крайне проста, и не нужно вносить изменения в конфигурацию.

Суть работы обработки заключается в:

1. получение списка активных пользователей,

2. отметить пользователя или пользователей, для которых будем отправлять сообщение,

3. дальше создается текстовое сообщение, названием которого будет имя получателя.

4. Дальше есть кнопка получить сообщение, над которой находится окно самого сообщения входящего.

Для корректной работы обработки в модуле формы нужно прописать каталог, в котором будут сохраняться файлы сообщений.

 

Процедура ОтправитьНажатие(Элемент)
    
    Для Каждого СтрП из ИтогСписокСоединений Цикл
        
        Если СтрП.ОтправитьСообщение = Истина Тогда
            
            ТексДок = Новый ТекстовыйДокумент;
            
            ТексДок.ДобавитьСтроку(СтрП.Пользователь);
            ТексДок.ДобавитьСтроку(ТекстСообщения);
            
            ТексДок.Записать("ПутьКаталога"+СтрП.Пользователь+".txt");
        КонецЕсли;    
    КонецЦикла;
    
    ТекстСообщения = Неопределено;
    
КонецПроцедуры

Процедура ПолучитьНажатие(Элемент)
    
     ТекстСообщенияВходящее = Неопределено;

     Путь = "ПутьКаталога"+ПараметрыСеанса.ТекущийПользователь.Наименование+".txt";
    
     Файл = Новый Файл(Путь);
    
     Если Файл.Существует() Тогда
    
         Текс = Новый ТекстовыйДокумент;
         Текс.Прочитать(Путь);
         Письмо = Текс.ПолучитьТекст();
        
         Если Письмо = Неопределено Тогда
             ТекстСообщенияВходящее = "Нових повідомлень нема!";
         Иначе
             ТекстСообщенияВходящее = Письмо;
             УдалитьФайлы("ПутьКаталога"+ПараметрыСеанса.ТекущийПользователь.Наименование+".txt");
         КонецЕсли;
     Иначе
     ТекстСообщенияВходящее = "Нових повідомлень нема!";    
    КонецЕсли;    
        
КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
Сообщение пользователям 1С
.epf 11,47Kb
27.08.13
123
.epf 1,02 11,47Kb 123 Скачать

См. также

PowerTools от 1 000
Комментарии
1. Сергей Марченко (MarSeN) 856 22.08.13 18:09 Сейчас в теме
По неопытности не знаю, как правильно сделать, чтобы обработка сама забирала документы, поэтому сделана кнопка .

Особо не вчитывался в проблему но, возможно, стоит посмотреть в сторону метода "ПодключитьОбработчикОжидания"
Этим способом http://infostart.ru/public/179185/ можно вообще чтоб формы не было видно и появлялась только когда есть сообщение
2. V P (Vovus) 3 22.08.13 18:53 Сейчас в теме
(1) MarSeN, Можете на почту обработку скинуть? bot1c@outlook.com
3. Сергей Марченко (MarSeN) 856 22.08.13 19:41 Сейчас в теме
4. V P (Vovus) 3 23.08.13 11:05 Сейчас в теме
5. Сергей Евстигнеев (grey_yes) 12 23.08.13 17:45 Сейчас в теме
ФИГНЯ какая-то....
...писать "ТексДок.Записать("D:\Instal\Work1C\Сообщения\"+СтрП.Пользователь+".txt");"
что за жесткая привязка пути?!!!!!!

и у получателя должна быть запущена та же обработка
и он должен постоянно тыкать - а не послал ли мне меня кто-нить....

мне даже "минус" поставить жалко... не то что плюсануть
6. V P (Vovus) 3 23.08.13 18:12 Сейчас в теме
(5) grey_yes, Если знаете как сделать чтоб не нажимал пользователь на кнопку буду благодарен за подсказку А привязку к пути можно убрать с модуля и сделать панель настроек но пока так!
7. Сергей Марченко (MarSeN) 856 25.08.13 22:27 Сейчас в теме
(6) Vovus,
Обработка, которую я скинул, демонстрирует как подключить "глобальный обработчик" без видимой формы.
Используй этот метод у себя. повесь на процедуру обработчика проверку на новое сообщение. если оно есть то выполни ЭтаФорма.Открыть() или Открыть() и твоя форма обработки чудесным образом откроется.
Когда пользователь прочтет сообщение можно послать команду "Закрыть()". Форма скроется из виду но будет продолжать висеть невидимой для пользователя. Конечно если ты не остановишь обработчик ожидания.

Успехов
8. V P (Vovus) 3 27.08.13 10:42 Сейчас в теме
9. Марина Чирина (chmv) 28.08.13 09:33 Сейчас в теме
10. Аркадий Кучер (Abadonna) 3661 12.10.13 08:40 Сейчас в теме
(0) Пользователи в ГРУ работают или ФСБ? Замазаны как особо секретные на картинке?
Имена компов тоже, видимо, особо секретные...
11. Elena Yeriomina (ves.Parnas) 16.10.13 09:26 Сейчас в теме
а Ч.Д. если у пользователя открыто 5 баз, а сообщение приходит в то окно, которое у него не активно?
12. smir (smir) 51 16.10.13 10:28 Сейчас в теме
Не до конца понятно из описания, как это работает.
13. V P (Vovus) 3 17.10.13 12:03 Сейчас в теме
14. V P (Vovus) 3 17.10.13 12:06 Сейчас в теме
(11) ves.Parnas, Пока вопрос всплывающего окна не решен
15. V P (Vovus) 3 17.10.13 12:06 Сейчас в теме
16. Артем Артеменко (dock) 18 25.01.14 06:41 Сейчас в теме
Нда... ценность обработки пока не высока...
Ведь что бы пользователь увидел сообщение, ему нужно явно нажать на какую-то кнопку.

(15) Vovus, Не совсем понятны действия пользователя.
Алгоритм работы:

Администратор/программист:
1. Запустить внешнюю обработку.
2. Выбрать пользователя/пользователей из списка активных. Список пользователей формируется при запуске обработки.
3. Ввести текст сообщения в окно редактирования.
4. Нажать кнопку "Отправить".
Пользователь:
1. Запустить внешнюю обработку.
2. Нажать кнопку "Получить сообщение".

Если ошибся - поправьте меня.
17. V P (Vovus) 3 29.01.14 16:51 Сейчас в теме
(16) dock, Если Вам интересно есть новая версия в которой нужно наживать только отправить все остальное делается в автоматическом режиме!
18. Ильдар Бурнашев (roadman) 05.02.14 09:21 Сейчас в теме
Насколько я помню, в каких-то стандартных конфигурациях ведь есть рассылка сообщение пользователям...
19. Ильдар Бурнашев (roadman) 05.02.14 09:22 Сейчас в теме
Если кто-то помнит, напомните - в каких?
20. Артем Артеменко (dock) 18 07.02.14 11:30 Сейчас в теме
(17) Vovus, Ссылка ?
Зачем интриговать человека... лучше сразу ссылку давать на новую версию ;)
21. V P (Vovus) 3 07.02.14 11:51 Сейчас в теме
(20) dock, Нигде не выложена обработка напишите почту и вышлю Вам
22. евг волк (ben19791010) 06.03.15 10:39 Сейчас в теме
(21) Vovus, киньте мне если не сложно для тонкоклиента на УФ файловая база
23. Екатерина Малюгина (andadra) 07.07.16 15:04 Сейчас в теме
Здравствуйте!andadra@yandex.ru.Скиньте на УФ пожалуйста
24. V P (Vovus) 3 10.07.16 17:02 Сейчас в теме
(23) andadra, На УФ нет пока, если нужно могу сделать пишите на bot1c@outlook.com!
25. Антон Дмитриев (Voblhned) 21 26.12.16 10:36 Сейчас в теме
(24) думаю, что на 8.2 уже давно не актуально, было бы круто на 8.3 УФ увидеть такую реализацию.
26. V P (Vovus) 3 26.12.16 15:35 Сейчас в теме
Я думаю в скором сделаю и на УФ