gifts2017

Небольшая доработка УТ 10.3 для отправки почты с помощью Outlook.

Опубликовал Александр Забалуев (zabaluev) в раздел Обмен - Обмен с другими системами

Небольшая доработка УТ 10.3 для отправки почты с помощью Outlook.

В УТ встроена удобная функция отправки табличных форм документов. Но работает она только со встроенным почтовым клиентом. Но ни всем он подходит. Небольшая доработка общего модуля "УправлениеОтчетами" исправляет эту проблему.

Необходимо исправить процедуру "ОтправитьДокументПоЭлектроннойПочте". Добавленный код выделен комментариями.

Процедура ОтправитьДокументПоЭлектроннойПочте(Документ, ИмяФайлаВложения = "") Экспорт

    Если НЕ Константы.ИспользованиеВстроенногоПочтовогоКлиента.Получить() Тогда
        //ОбщегоНазначения.СообщитьОбОшибке("Отправлять документы по электронной почте можно только из встроенного почтового клиента.
        //  |В настоящее время в настройках параметров учета установлено использование основного почтового клиента операционной системы.");
        // Предупреждение("Операция не выполнена");
        // Возврат;
        //КонецЕсли;

        //*************Начало изменений
        Outlook=Новый COMОбъект("Outlook.Application");
        ТипФайла="XLS";
        Письмо=Outlook.CreateItem(0);
        Письмо.Subject=ИмяФайлаВложения;
        Письмо.Body=ИмяФайлаВложения;
        ФайлаВложения=КаталогВременныхФайлов()+СтрЗаменить(ИмяФайлаВложения, ".", " ")+"."+ТипФайла;
        Документ.Записать(ФайлаВложения,ТипФайла);
        Письмо.Attachments.Add(ФайлаВложения);
        Попытка
            Письмо.Display();
        Исключение
        КонецПопытки; 
  
    Иначе 
        //*************Конец изменений
        ФормаОтправкиДокумента = ПолучитьОбщуюФорму("НастройкаОтправкиОтчета");
        ФормаОтправкиДокумента.Отчет            = Документ;
        ФормаОтправкиДокумента.ИмяФайлаВложения = СтрЗаменить(ИмяФайлаВложения, ".", " ");
        ФормаОтправкиДокумента.ТемаСообщения    = ИмяФайлаВложения;
        ФормаОтправкиДокумента.ОткрытьМодально();
    КонецЕсли;
КонецПроцедуры

Использовался код обработки http://infostart.ru/projects/2680/

Скачать файлы

Наименование Файл Версия Размер
Процедура ОтправитьДокументПоЭлектроннойПочте.txt 142
.1241892489 1,27Kb
27.06.15
142
.1241892489 1,27Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. artem666 Bogomaz (artem666) 09.05.09 23:14
Если отправлять через Аутлук вечно спрашивает подтверждение...
2. Александр Забалуев (zabaluev) 09.05.09 23:41
В данном случае создается только письмо и прицепляется вложение. Уже в Outlook задаем получателя и отправляем.
3. Влад Кайзер (Torin) 13.05.09 13:34
" Документ.Записать(ФайлаВложения,ТипФайла);
Письмо.Attachments.Add(ФайлаВложения);"

А откуда взялась переменная "Документ"?
4. Александр Забалуев (zabaluev) 13.05.09 17:30
Процедура ОтправитьДокументПоЭлектроннойПочте(Документ, <<==
5. vas5780 19.09.11 07:02
Всё работает, проверено. спасиб
6. Андрей Говорун (GovoruN3562) 01.03.12 13:47
Как раз сейчас занимаюсь реализацие подобной задачки. Чтоб Outlook не выдавал предупреждений - есть внешняя компонента, которая обходит защиту Outlooka. А как посылать письма через другие почтовые клиенты? The Bat! например. странно, что в настройка параметра учёта. на вкладке электронная почта. можно указать использование стронних почтовых клиентов. Но из описанного выше модуля явно видно, что 1с явно отрубает эту возможность. по идее, должно работать так: отследить через реестр почтовый клиент по умолчанию, и отправить письмо через него. Вот только отследить не получается(Outlook всегда прописан по умолчанию), и как отправить через другие клиенты - пока не понятно. The Bat! неплохо отрабатывает "mailto:", а в Outlook передать его не получается. Может кто что подскажет по этому поводу?
7. Александр Забалуев (zabaluev) 01.03.12 15:52
"Бат" отлично понимает командную стоку, вот пример отправки письма:
"C:\Program Files\The Bat!\thebat.exe" /MAILTO=sklad@mail.ru;S=OBMEN_MAYK;NOLOGO;MINIMIZE;SEND;ATTACH=\\SERVER\1C_Bases\MAYK\CP\D30.zip
8. Rus GA (TeploHouse) 19.04.13 10:13
Ребят, для себя настраиваю 1с.
подскажите по пунктам как это организовать?
1С:Предприятие 8.2 (8.2.17.157); Управление торговлей версия 10.3

Заранее благодарю.