Печать адреса на почтовом конверте

Опубликовал Sergey (seven77782) в раздел Печать - Универсальные печатные формы

Обработка для печати на российских почтовых конвертах адреса по справочнику контрагентов. Можно печатать по выбору юридический или почтовый адрес контрагента.

Обработка для печати на российских почтовых конвертах адреса по справочнику контрагентов. Можно печатать по выбору юридический или почтовый адрес контрагента. 

Параметры страницы достаточно настроить один раз, программа их запомнит.

Скачать файлы

Наименование Файл Версия Размер
-
.1243419728 33,00Kb
25.09.09
387
.1243419728 33,00Kb 387 Скачать

См. также

Комментарии
1. Юлия Сергеева (Kleoniy) 03.06.09 08:13 Сейчас в теме
2. Александр Булейко (big60) 31 03.06.09 10:41 Сейчас в теме
Нашёл одну "вавку": если после индекса стоит запятая без пробела, она печатается после индекса. Я не стал мудрить, а просто отвёл для индекса 6 знаков:
НашИндекс = Лев(Константа.ПочтовыйАдресОрганизации,6);
...
Индекс = Лев(Адрес1,6);
А в общем спасибо. Вроде бы мелочь, а втечение года не доходили руки. Удружил.
3. Александр Булейко (big60) 31 03.06.09 10:47 Сейчас в теме
И ещё одна мелочь. Иногда адрес переносится не очень красиво. Я придумал такое: в адресе (в справочнике) ставлю какой-либо маркер, наприемер, два знака процента, а перед печатью меняю этот маркер на символ перевода строки
АдресФирмы = СтрЗаменить(Адрес1, "%%", РазделительСтрок);
Правда, этот маркер желательно бы сделать незаметным для других печатных форм. Надо подумать
4. Алла (АллаБух) 24.07.09 11:13 Сейчас в теме
5. kovalevv (kovalevv) 29.07.09 23:17 Сейчас в теме
да было бы не плохо для 8.1 иметь такое давно мечтаю, а еще неплохо добавить пакетную печать массы документов
6. Настя Макарова (nastyaMNs) 15.09.09 02:41 Сейчас в теме
Прикольно сделай. но я добавила функцию обработки индекса.


Функция глИндекс(Знач Строка) Экспорт

ЧислоТ="0123456789";
XZ=0;
t=0;
k=0;
l=0;
Строка=СокрЛП(Строка);
Пока Найти(Строка," ")>0 Цикл
Строка=СтрЗаменить(Строка," "," ");
КонецЦикла;
Строка=СтрЗаменить(Строка," ",РазделительСтрок);
Рез=сокрЛП((СтрПолучитьСтроку(Строка,1)));

Для Х=0 По СтрДлина(Рез) Цикл
k=Лев(Рез,Х);
t=k;
l=l+1;
if l<7 then
Для i=0 По СтрДлина(ЧислоТ) Цикл
if k = "" + i +"" then
XZ=1;
endif;
КонецЦикла;
endif;
КонецЦикла;

if XZ=1 then
Возврат СокрЛП(Лев(Рез,6));
endif;
КонецФункции
7. анка (анфиска) 29.09.09 11:29 Сейчас в теме
Криво печатается адрес отправителя, выглядит это так :( :

ООО "Ромашка"

обл,,Долгопрудный г,,Первая ул,10,,
,141707,Московская

да и запятая лишняя в индексе получателя, а так идея ничего, хорошая, только вот поправить бы. Я сама не умею, я бухгалтер. 8)
8. Артем Чугаев (ChugaevArtem) 284 08.10.09 13:16 Сейчас в теме
Спс! Все равно переделаю под себя... Добавлю возможность ввода вручную! =) Бухгалтерия просит... отправлять будут от "левого" имени! А так малодчик! Однозначно + за работу! Так держать! :!:
9. radomicheva 25.11.09 15:23 Сейчас в теме
Спасибо за обработку давно искала такую
Оставьте свое сообщение