gifts2017

Восстановление номеров документов

Опубликовал Рауф (rauf) в раздел Обработки - Обработка документов

Внешняя обработка для восстановления номеров документов. Работает с текстовыми и числовыми номерами, поддерживает нумераторы, префиксы, выбор периода.

Внешняя обработка для восстановления номеров документов. Работает с текстовыми и числовыми номерами, поддерживает нумераторы, префиксы, выбор периода.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1244089539 49,00Kb
06.10.14
216
.1244089539 49,00Kb 216 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Епрст (Ёпрст) 04.06.09 08:51
>>>"Окно внешней компоненты " ...
Гы... ВК - это савсем из другой оперы..
2. Епрст (Ёпрст) 04.06.09 08:56
И еще, причем тут Восстановление , если это обычные Перенумератор?

И чем он лучше UCDocRen.ert с диска ИТС ?
3. Алексей Кирюшин (int18h) 04.06.09 09:33
(0) (Бухгалтерия 7.7) Выдает ошибку Если Доки.Фирма <> ВыбФирма Тогда
{D:\DOCNUMBERS.ERT(154)}: Поле агрегатного объекта не обнаружено (Фирма)
Необходимо поправить интерфейс таким образом чтоб в Бухгалтерии не отображалось поле "Фирма" либо еще както...
4. Сидоров (kassir22) 10.06.09 16:01
В программе ошибочка. То есть совсем не работает.
1)В цикле нужно строчку
Дубли.НомерДок = "$" + Строка(Инд);
Ниже на 2 строки ставить
2) Длину Инд уменьшить на 1

Если Доки.НомерДок <> СтрНом Тогда
Если Дубли.НайтиПоНомеру(СтрНом, Доки.ДатаДок) = 1 Тогда
Дубли.НомерДок = "$" + Строка(Инд);
НеЗаписан = 1;
Пока НеЗаписан = 1 Цикл
НеЗаписан = 0;
Попытка
Дубли.Записать();
Исключение
НеЗаписан = 1;
Инд = Инд - 1;
Если Инд = 0 Тогда
Предупреждение("Нет места для размещения временных номеров!");
Возврат;
КонецЕсли;
КонецПопытки;
КонецЦикла;
Инд = Инд - 1;
Если Инд = 0 Тогда
Инд = МаксИнд;
КонецЕсли;
КонецЕсли;
Доки.НомерДок = СтрНом;
Доки.Записать();
КонецЕсли;
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа