Часы в 1С

Опубликовал Виталий Криволапов (Vit aka proger) в раздел Программирование - Работа с интерфейсом

Пользователям понадобились часы при работе в терминальном доступе.

Обработка наипростейшая, но, может, кому пригодится :)

Скачать файлы

Наименование Файл Версия Размер
Часики
.1244437007 5,54Kb
25.09.09
337
.1244437007 5,54Kb 337 Бесплатно

См. также

Комментарии
1. Serj (Serj1C) 460 08.06.09 11:50 Сейчас в теме
2. qwerty123qwerty (Vit aka proger) 08.06.09 15:01 Сейчас в теме
Да и мне не сложно и пользователи довольны :)
3. artem666 Bogomaz (artem666) 27 08.06.09 20:03 Сейчас в теме
несмотря на обрботку думаб используется ОбработкаОжидания
4. Igоr Sаulеviсh (gutentag) 249 09.06.09 10:43 Сейчас в теме
5. Айрат (Craig) 177 10.06.09 07:24 Сейчас в теме
Качать обработку и открывать через конфигуратор Лень, может сразу выставишь код сдесь?!
6. vase4kin! (vase4kin!) 10.06.09 12:48 Сейчас в теме
здесь, здание, здоровье..
эту обработку не скачивал. так же в свое время просили вывести время в терминале. у меня простецкие часы выглядят так:

Процедура ПриОткрытии()
ОбновитьВремя();
КонецПроцедуры

Процедура ОбновитьВремя() Экспорт
ЭлементыФормы.ТекВремя.Заголовок= Формат(ТекущаяДата(),"ДЛФ=В");
КонецПроцедуры

ПодключитьОбработчикОжидания("ОбновитьВремя",3);
7. Павел Олейников (OPM) 18 10.06.09 13:36 Сейчас в теме
я предпочел флешку вставить в окно с часами.
8. dushelov (Душелов) 10.06.09 13:46 Сейчас в теме
9. Виталий Криволапов (Vit aka proger) 101 11.06.09 10:33 Сейчас в теме
(5)
на самом деле моим первым решением была рекомендация купить будильник :)
реализация обработки такая-же как у (6):

Процедура ОбновитьВремя()
ТаблоЧасов = Формат(ТекущаяДата(),"ДЛФ=T");
КонецПроцедуры

ПодключитьОбработчикОжидания("ОбновитьВремя", 1)
где ТаблоЧасов - надпись в форме
10. Сергей Генералов (serg1c) 20 12.06.09 14:20 Сейчас в теме
А никто не думал о том, чтобы выводить информацию в статусбар?
Например сумму текущих продаж?
В 7-ке была длл-ка, которая в 8-ке не работает.
А классная штука была...
11. dushelov (Душелов) 12.06.09 15:11 Сейчас в теме
12. Игорь (uropek) 20.09.11 21:31 Сейчас в теме
жалко, что на уровне платформы это не реализовано