gifts2017

УФ. Информационные сообщения пользователям при "Записать и закрыть" или "Провести и закрыть".

Опубликовал Михаил Шумский (iRounder) в раздел Программирование - Практика программирования

Как показать пользователю некритические информационные сообщения если он нажал "Записать и закрыть" или "Провести и закрыть".

Бывают ситуации когда необходимо сообщить пользователю информацию, не вызванную исключительной ситуацией, т.е. ошибкой.

И все бы хорошо, если бы пользователь не нажимал кнопки "Записать и закрыть" или "Провести и закрыть". В этом случае, если сообщение вызвано исключительной ситуацией, то оно отобразится и форма не закроется. Но в случае, если сообщение информационное, т.е. запись или проведение завершились удачно, то сообщение на доли секунды выведется в окно сообщений формы и закроется вместе с ней. Плохо.

Искал по форумам решение, но так и не нашел того, что мне бы подошло. Обработчик ожидания не хочу для этого использовать. Решение с перенаправлением сообщения в окно приложения путем активации поочередно окон в моей версии платформы работать корректно не захотело.

В итоге реализовал так (для записи элемента справочника, для документов реализация будет подобной же):

1. В форме элемента создал реквизит МассивСообщений типа СписокЗначений для хранения перехваченных с сервера сообщений пользователю.

2. Процедура ПослеЗаписиНаСервере()

&НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)
    МассивСообщений.Очистить();

//Получаем сообщения, предназначающиеся пользователю, но пока не показанные ему, и удаляем их из фиксированного массива (системного), где они хранятся

//Получить сообщения можем лишь на сервере. Как только перейдем на клиент сообщения будут считаться показанными.

    ФиксМассивСообщений = ПолучитьСообщенияПользователю(Истина);

//Записываем сообщения в список значений (реквизит формы МассивСообщений)
    Для Сч = 0 По ФиксМассивСообщений.Количество() - 1 Цикл
        МассивСообщений.Добавить(ФиксМассивСообщений.Получить(Сч));
    КонецЦикла;
КонецПроцедуры

 

3. Процедура ПослеЗаписи()

&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)

//Если сообщения есть, то инициируем их показ пользователю
    Если МассивСообщений.Количество() > 0 Тогда
        ПоказатьСообщенияПользователю();
        МассивСообщений.Очистить();
    КонецЕсли;
КонецПроцедуры

 

4. Создал процедуру ПоказатьСообщенияПользователю()

&НаКлиенте
Процедура ПоказатьСообщенияПользователю()
    Для Каждого Сообщение Из МассивСообщений Цикл

//Сообщения показываем в виде предупреждений, т.к. пока пользователь не нажмет "Ок" форма не закроется. Т.е. только так мы достигаем цели,

//чтобы пользователь увидел сообщения перед закрытием формы
        Предупреждение("" + Сообщение.Значение.Текст);
    КонецЦикла;
КонецПроцедуры

 

 

Все вышеописанные процедуры описаны в модуле формы.

См. также

Подписаться Добавить вознаграждение

Комментарии

1. MagIvan (RailMen) 12.10.13 00:46
Довольно популярная задачка.

Есть несколько мыслей вслух:
1) реквизит формы МассивСообщений типа СписокЗначений лучше назвать СписокСообщений.
2) показывать столько Предупреждений, сколько и сообщений не совсем правильно. Представим, что сообщений 10 - тогда пользователь вынужден будет 10 раз закрывать окошки.
2. Михаил Шумский (iRounder) 12.10.13 17:02
Да вариантов реализации может быть масса, например создание реквизита формы не интерактивно, а программно. Каждый под себя допилит :)
У меня максимум 2 сообщения - поэтому мне удобнее показывать по очереди.
Публиковал не как идеальное решение - а как идею :)
3. Никита Грызлов (nixel) 16.10.13 17:10
Я для этих целей использую более простой на мой взгляд вариант - показ СообщенияПользователю в основном окне.

Привожу полный код тестовой обработки.
&НаКлиенте
Процедура ПоказатьСообщение(Команда)
	
	СообщениеОсновноеОкно 	= Новый СообщениеПользователю;
	СообщениеДругоеОкно 	= Новый СообщениеПользователю;
	
	// получает открытые окна приложения
	ОкнаКлиента = ПолучитьОкна();
	
	Если ОкнаКлиента = Неопределено Тогда
		
		// если приложение запущено в обычном режиме
		СообщениеОсновноеОкно.Текст = "Сообщение отображается в окне Служебных сообщений.";
		СообщениеОсновноеОкно.Сообщить();
		
	Иначе
		                      
		// найдём основное окно приложения (хотя оно с индексом [0])
		Для Каждого ОкноКлиента Из ОкнаКлиента Цикл
			Если ОкноКлиента.Основное Тогда
				ОсновноеОкно = ОкноКлиента;
				Прервать;
			КонецЕсли; 
		КонецЦикла;
		
		
		// найдём нужное нам окно (не основное) по 
		// 	заголовку 	ОкноКлиента.Заголовок
		// 	ссылке 		ОкноКлиента.ПолучитьНавигационнуюСсылку()
		//	содержимому ОкноКлиента.ПолучитьСодержимое()
		Для Каждого ОкноКлиента Из ОкнаКлиента Цикл
			Если НЕ ОкноКлиента.Основное И 
				 СтрЧислоВхождений(ОкноКлиента.Заголовок, "Заголовок искомого окна") > 0 Тогда
				ДругоеОкно = ОкноКлиента;
				Прервать;
			КонецЕсли; 
		КонецЦикла;

		СообщениеОсновноеОкно.ПутьКДанным = ОсновноеОкно.ПолучитьНавигационнуюСсылку();
		
		// получить УИ можно только у неосновного окна   
		СообщениеДругоеОкно.ИдентификаторНазначения = ДругоеОкно.ПолучитьСодержимое().УникальныйИдентификатор;
		СообщениеДругоеОкно.Поле = "Поле_привязки_сообщения";
		
		СообщениеОсновноеОкно.Текст = "Сообщение отображается в окне " + ОсновноеОкно.Заголовок + ".";
		СообщениеДругоеОкно.Текст 	= "Сообщение отображается в окне " + ДругоеОкно.Заголовок + ".";
		
		
		СообщениеДругоеОкно.Сообщить();
		
		// финт для отображения в основном окне
		ОсновноеОкно.Активизировать();
		СообщениеОсновноеОкно.Сообщить();
		ЭтаФорма.Окно.Активизировать();
		
	КонецЕсли; 

КонецПроцедуры
...Показать Скрыть


Кода много. Но основная фишка вот здесь -
СообщениеОсновноеОкно.ПутьКДанным = ОсновноеОкно.ПолучитьНавигационнуюСсылку();

ОсновноеОкно.Активизировать();
СообщениеОсновноеОкно.Сообщить();
ЭтаФорма.Окно.Активизировать();
4. Михаил Шумский (iRounder) 16.10.13 20:16
Я пытался сделать так же. Только нужно было когда пользователь нажмет просто "Записать" или "Провести", то сообщения показывать в форме элемента/документа, а если "Записать и закрыть" или "Провести и закрыть", то в главном окне. Однако на моей версии платформы не взлетело - в любых случая показывало в главном окне. Меня это не устраивало.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа