Структура подчинености. Правильное отображение.

Опубликовал Владимир Пушин (vladnet) в раздел Программирование - Практика программирования

Как же правильно отобразить иерархию с помощью дерева? Чтобы было понятно? Ведь в структуре подчиненности могут быть циклы.
Мой ответ - никак! Так что же делать? Ответ прост - нужно отображать не ДЕРЕВОМ, а ГРАФОМ!
Как же в 1с отобразить графом? Стандартно никак, но можно ведь немного извернутся, и все получится.

Новая версия - увеличена скорость! Сейчас стрелки в нужном направлении.

Добавлена версия под 8.2.

Обработка может быть использована как пример того как формировать программно Графическую схему.

Работает на стандартных конфигурациях.

Данная обработка активно используется в конфигурация для Учета оборудования в отделе ИТ

Для работы с графической схемой рекомендуется:

   http://infostart.ru/public/144273/ 

   http://infostart.ru/public/20371/ 

Тэги: Графическая схема, Структура подчиненности, Дерево подчиненности.

Скачать файлы

Наименование Файл Версия Размер
СтруктураПодчиненности82.epf
.epf 17,68Kb
15.08.12
550
.epf 17,68Kb 550 Скачать
СтруктураПодчиненности.epf
.epf 16,40Kb
15.08.12
755
.epf 16,40Kb 755 Бесплатно

См. также

Добавить вознаграждение
Комментарии
1. mosAdm (mosAdm) 131 11.06.09 15:30 Сейчас в теме
Замерил производительность 14 секунд (второй запуск обработки) и менее секунды типовая. Мдассссссссссссс запустил третий раз и не подумав флаги поставил (искать мол в шапке таб частях) . Конфу закрывал через диспетчер
2. Владимир Пушин (vladnet) 223 11.06.09 16:54 Сейчас в теме
Добавлял эти флажки специально для типовых решений. Там очень большой граф может получиться, так как есть некоторые типы документов наподобие расчета НДС, которые содержат в табличной части, документы реализаций.

А вот насчет производительности не понятно, я мерил у меня формируется очень быстро.

Да а зачем через диспетчер закрывали, неужто ctrl+break не помог? В коде прерывание пользователя прописано.
3. Владимир Пушин (vladnet) 223 11.06.09 16:55 Сейчас в теме
(1) Когда получилось 14 секунд, сколько документов вывелось в отчет?
4. Сергей (Che) Коцюра (CheBurator) 3367 11.06.09 18:25 Сейчас в теме
неестественно снизу вверх
5. artem666 Bogomaz (artem666) 27 11.06.09 19:20 Сейчас в теме
по мне так, типовая вполне нормальная, при виде такого графа юзер просто очумеет...
6. mosAdm (mosAdm) 131 11.06.09 19:40 Сейчас в теме
(3) совсем не много 5 или 7, база УПП. ctrl+break не помог.
7. Владимир Пушин (vladnet) 223 11.06.09 21:59 Сейчас в теме
(4) Зато:
1. Отсортированы по дате
2. Стрелка показывает - начало где была ссылка, конец - на какой документ ссылка
И это естественно.

(5) Кому как, мне вот так больше нравится ) По типовой я чего то часто не допру, что там и на что ссылается.

(6) Посмотреть бы что она делает в отладчике, честно скажу на УПП не проверял, только на УТ и бухгалтерии.
8. Александр Глотов (_Xelon_) 5 18.06.09 14:08 Сейчас в теме
На УПП выдал сообщение об ошибке:

{Форма.Форма(137)}: Ошибка при вызове метода контекста (Выполнить): Ошибка выполнения запроса "Построенный запрос к СУБД использует слишком много таблиц. Допустимо не более 256.
Microsoft OLE DB Provider for SQL Server: Too many table names in the query. The maximum allowable is 256.
HRESULT=80040E14, HRESULT=80040E14, SQLSrvr: Error state=1, Severity=F, native=102, line=2215
SQLSrvr: Error state=1, Severity=F, native=106, line=1858
"
лТзПодчиненные=лЗапрос.Выполнить().Выгрузить();
по причине:
Ошибка выполнения запроса "Построенный запрос к СУБД использует слишком много таблиц. Допустимо не более 256.
Microsoft OLE DB Provider for SQL Server: Too many table names in the query. The maximum allowable is 256.
HRESULT=80040E14, HRESULT=80040E14, SQLSrvr: Error state=1, Severity=F, native=102, line=2215
SQLSrvr: Error state=1, Severity=F, native=106, line=1858
"
по причине:
Построенный запрос к СУБД использует слишком много таблиц. Допустимо не более 256.
Microsoft OLE DB Provider for SQL Server: Too many table names in the query. The maximum allowable is 256.
HRESULT=80040E14, HRESULT=80040E14, SQLSrvr: Error state=1, Severity=F, native=102, line=2215
SQLSrvr: Error state=1, Severity=F, native=106, line=1858

9. Владимир Пушин (vladnet) 223 19.06.09 09:25 Сейчас в теме
(8) Там запрос то простой очень:

"ВЫБРАТЬ
| &Ссылка КАК Документ,
| СвязанныеДокументы.Ссылка КАК ДокументСвязанный
|ИЗ
| КритерийОтбора."+лИмя+"(&Ссылка) КАК СвязанныеДокументы";

Видимо 1с его хитро разворачивает, исправил код на вот этот:

лМассивСвязанныхДокументов=КритерииОтбора[лИмя].Найти(пДокСсылка);

Теперь должно работать.
10. Александр Глотов (_Xelon_) 5 19.06.09 09:42 Сейчас в теме
(9) Теперь работает. Спасибо.
11. oleksandr.homyak (logarifm) 19.06.09 22:47 Сейчас в теме
Труд вложил... По мне ужастно не удобное отображение, типовый механизм и быстрее и удобнее! +1 за труды -1 за изобретение велосипеда = 0
12. Владимир Пушин (vladnet) 223 19.06.09 23:31 Сейчас в теме
(11) Кому что. А разбор графической схемы делался не для этой обработки.

Вот только объясните чем же типовая удобнее схема?
13. Владимир Пушин (vladnet) 223 19.06.09 23:32 Сейчас в теме
(11) Если и быстрее то не существенно.
14. Алексей Коробов (WiseSnake) 1721 16.08.09 01:48 Сейчас в теме
Спасибо за работу! Обработка интересна скорее с точки зрения разбора графической схемы.
Но вот Ваш код мне разрывает мозг... )))) без обид ;).
Сразу видно что не первый день кодите, но какая же... нехороший человек научил Вас код так набивать? Может быть все таки придерживаться правил и уважать братьев по цеху?
dpanibratec; +1 Ответить 3
15. Игорь Исхаков (Ish_2) 957 16.08.09 03:47 Сейчас в теме
(14) Ну .. Заинтриговал .Я уж ожидал что-нибудь совсем экзотическое.
Не поленился -скачал.
А тут всего лишь нет комментариев и выделения пустыми строками.
"Если" и "цикл" пишутся в одну строку.
Такую причуду я встречал не раз и не у последних программистов.
Очевидно ,им важнее своё удобство , а не что подумает кто-то.
У некоторых эта причуда проходит , у некоторых нет.

Автору : исправьте ошибку при пустом реквизите ДокументСсылка нажатие кнопки "Обновить" вызывает ошибку .


16. Владимир Пушин (vladnet) 223 16.08.09 08:45 Сейчас в теме
(14) (15) Ну чужой код он всегда плохо читается. Этот стиль принят в нашей команде.

Почему он такой:

Принят максимально линейный код. Т.е.

Если пЭлемент.ТекущийЭлемент=Неопределено Тогда Возврат; КонецЕсли;

И дальше код идет на той же строке без отступа, внимательнее посмотрите, в коде очень мало уровней вложенности. Понятно что если писать так, то нет смысла переносить "возврат" на следующую строку.

Что же по комментариям - я считаю что код должен комментировать себя, у уважаемой фирмы 1с я практически не встречал полезных комментариев, хотя впереди каждой процедуры пишут какую то хрень, которая и так понятна из кода.

Так же в коде соблюдается наш принцип - 1 процедура занимает не более 1 экрана. Что позволяет даже при сложном и компактном коде все таки понять чем же она занимается.

Код сложный, но сложен он тем что 1 строкой он делает гораздо больше чем делает 1 строкой код из типовых конфигураций 1с.

Ошибку поправлю.
17. Владимир Пушин (vladnet) 223 16.08.09 08:48 Сейчас в теме
(14) А да первые кто учил меня писать именно так были они: http://kint.ru/

Именно там я понял что ориентироватся на код типовых конфигураций 1с глупо.
18. Артур Аюханов (artbear) 847 16.08.09 09:11 Сейчас в теме
Нормальный, довольно качественно оформленный код.
Кучу мелких и понятнейших методов - это здорово, я сам так пишу.
Единственная претензия все-таки к однострочному
Если Условие Тогда Возврат Результат; КонецЕсли

ИМХО в данном случае все-таки важно, чтобы четко было видно, что выполняется граничное условие и какая выполняется обработка для этого случая, развернутый вариант все-таки поудобнее читать и сопровождать.
19. noprogrammer (noprogrammer) 16.08.09 10:35 Сейчас в теме
(18) >> Единственная претензия все-таки к однострочному
Если Условие Тогда Возврат Результат; КонецЕсли

На самом деле это очень удобно (имхо), к тому же уменьшает размер процедуры, что позволяет видеть на экране всю процедуру. (все конечно имхо, но когда к такому привыкаешь отказаться от подобного стиля уже невозможно)
20. Игорь Исхаков (Ish_2) 957 16.08.09 12:28 Сейчас в теме
(17) Понятно. Первый язык у специалистов "Кинта" был не 1с .
Термин "причуда" был употреблен с позиции 1с-ника , пишущего для других
1с-ников и ориентирующегося , естественно, на стиль типовых конфигураций 1с.
Префиксы "м","л","п" - определяющие характер переменных, процедур и функций - следует однозначно поддержать . В типовых конфигурациях разбираться в больших процедурах неудобно без этих префиксов тяжело.
21. Сергей (Che) Коцюра (CheBurator) 3367 16.08.09 12:58 Сейчас в теме
соглашения по стилю именования в 1С вообщем-то давно опубликованы...
RomanUzmov; w-divin; +2 Ответить 1
23. Владимир Пушин (vladnet) 223 16.08.09 21:28 Сейчас в теме
(21) Зачем они мне, у меня свои есть:

http://tunesoft.ru/content/view/15/32/

Их и придерживаюсь, хотя может их уже обновить надо )
24. Алексей Коробов (WiseSnake) 1721 16.08.09 21:37 Сейчас в теме
Я много кода перелопатил за свою жизнь от разных программистов и с разным стилем и на разных языках программирования.... и к слову сказать код от 1С намного читабелен, чем Ваш.

1. Для меня длинные строки не удобны для чтения, так как у меня не только код на экране...
2. Код без пробелов и разделителей сливается в одну кашицу... и хоть она и влезает на 1 страницу, но е
vital1c; dpanibratec; +2 Ответить 1
25. Алексей Коробов (WiseSnake) 1721 16.08.09 21:45 Сейчас в теме
й это читабельности не прибавляет...
3. Иногда если бы не было комментариев к строкам в 1С я бы потратил на разбор кода не 1 час а 4 часа...
4. Проведите эксперимент... откройте свой код который писали год назад и ни открывали не разу... интересно насколько он Вам покажеться читабельным

Кстати маленький нюанс для создания уникальных имен для временных файлов можно использовать функцию ПолучитьИмяВременногоФайла(<Расширение>)

P.S. Это все ИМХО если Вашей команде так удобно то не вопрос, я просто высказал личное мнение...
26. Игорь Исхаков (Ish_2) 957 16.08.09 21:57 Сейчас в теме
Такое именование переменных в двумя префиксами рекомендуется в
некоторых СУБД (FOXPRO), причем рекомендуется давно (задолго до появления 1с 77). У 1с тут ,как обычно, свой подход , не "субэдэшный" .
У меня твердое убеждение , что разработчики еще языка 77 ходили в майках с надписью "Бэйсик forever !" .
27. Владимир Пушин (vladnet) 223 16.08.09 22:01 Сейчас в теме
(24) (25)
Ну все же наверное нужно сказать что не весь код более читабельный, некоторые особо перловые процедуры от 1с занимают несколько десятков страниц, это конечно вырожденный случай. Но мне явно проще когда всю или почти всю процедуру я вижу.

1. Да к этому стилю надо привыкать. Тут есть плюсы и минусы. Я привык к нему за полгода.
2. Согласен. Иногда кстати я выделяю переводом строки особенно важные блоки. Но так как делает программеры в 1с - а они выделяют разделителями все, в этом смысла я не вижу. По сути не выделять ничего разделителями или выделять разделителями все, одно и тоже, только в первом случае процедура умещается на экран а во втором случае надо листать.
3. ИМХО 70 % комментариев там ни о чем. По моему мнению комментарии нужны только тогда когда имена процедур и переменных не смогут сказать о том что происходит в коде, но комментариев нужно избегать.
4. У меня с этим полный порядок. Я пишу со своей строгой логикой, конфигурация http://tunesoft.ru/ полностью поддерживается мной, если бы мне код в ней казался бы нечитабельным (а там его кстати очень много), то я просто не смог бы развивать эту конфгурацию.

Кстати да )
28. Владимир Пушин (vladnet) 223 16.08.09 22:02 Сейчас в теме
А вообще по стилю я считаю в общем так: любой стиль которого придерживаются лучше его отсутствия )
29. Игорь Исхаков (Ish_2) 957 16.08.09 22:07 Сейчас в теме
(25) Теперь спор , на мой взгляд, смысла не имеет.
Но стиль оформления программы - не выдумка автора, а стиль , проверенный в других языках , чуть более распространенных в мире , чем 1с.
Вот что нужно учитывать , критикуя автора темы.
30. Алексей Коробов (WiseSnake) 1721 16.08.09 22:41 Сейчас в теме
(28) Вот тут не могу не согласится...
(29) Каких языках? я видимо не встречался с этими языками,хотя они более распространены чем 1С.... И в каком из языков поощряется отсутствие комментариев, я вообще не знаю...

Есть определенные стандарты для 1С о чем говорилось в (22) всем известные и большинством используемые, их тоже не дураки придумывали

Если каждый будет выдумывать свой стандарт или переносить с других языков, то это сродни диалектам одного языка. По этому часто западный украинец не понимает восточного. Вот что нужно учитывать критикуя критику ;)
31. Игорь Исхаков (Ish_2) 957 16.08.09 23:18 Сейчас в теме
(30) Хочется покритиковать критику критики.
Речь шла про FOXPRO , Субд чуть более распространённую чем 1с.
Имелось ввиду только именование переменных с двумя префиксами.
Одностроковый же стиль для написания операторов выбора и цикла
я встречал также в Паскале .
Паскаль тоже распространен чуть более чем 1с.

Что касается отсутствия комментариев - то это плохо в любом языке, что бы ни писал автор темы.
32. Алексей Коробов (WiseSnake) 1721 17.08.09 02:37 Сейчас в теме
(31) Хочется не критиковать, а найти истину, а в споре она как известно рождается

> Имелось ввиду только именование переменных с двумя префиксами.

1C вообще то, по моему, рекомендует наиболее полно писать наименование переменных (то есть не тз..., а ТаблицаЗначений...) другое дело кому то лень писать так (а кто то не считает нужным, потому что вроде и так понятно)...

> Одностроковый же стиль для написания операторов выбора и цикла
я встречал также в Паскале

Ну я встречал одностроковый стиль для написания операторов выбора и цикла и в 1С ;)... но код на паскале который я видел (признаюсь видел я его не много), что то не запомнился мне этой особенностью....

P.S. Скорей бы вымер уже FOXPRO, а то я уже устал с ним бороться.... ИМХО...
33. Владимир Пушин (vladnet) 223 17.08.09 09:38 Сейчас в теме
(31) Комментарии у меня есть, только очень мало. В этой обработке почему то совсем нет, но это скорее исключение. Если посмотреть на названия идентификаторов, то можно заметить что они очень длинные.

(32) Вымрет то он может и вымрет, а вот стиль останется, я например никогда и не писал на фоксе (лабы в универе не в счет)

34. Игорь Исхаков (Ish_2) 957 17.08.09 09:44 Сейчас в теме
(33) Рекомендация именовать переменные с двумя префиксами впервые мне встретилась лет 10 назад в литературе по FOXPRO. Но подозреваю , что такой стиль возник еще раньше и в других средах разработки.
35. Артур Аюханов (artbear) 847 17.08.09 12:06 Сейчас в теме
1. Главный принцип хорошего кода - легкость его чтения, а значит, и сопровождения и т.д.
В связи с этим принципом можно придумывать себе стиль с одним, двумя префиксами и т.д.
2. Поэтому лично я редко пишу комменты, лучше юзать правильные имена методов и переменных, не бояться править код, чаще использовать тестирование.
36. Ivon (Ivon) 578 18.08.09 09:57 Сейчас в теме
В целом из примера мало что понятно. Необходимо разбираться долго. Для применения необходимо понимание основ работы с графом. На текущий момент материалов по построению своих схем с помощью кода не нашел. Если уважаемый автор сделает статью, в которой опишет основы (с подробными примерами кодов) работы с графом - это будет просто незаменимый материал.
37. Владимир Пушин (vladnet) 223 18.08.09 10:14 Сейчас в теме
38. Владимир Пушин (vladnet) 223 18.08.09 10:26 Сейчас в теме
(36) Да кстати инструмент может рисовать графы но по сути это просто инструмент для отрисовки квадратиков и линий, которые привязаны к этим квадратам.
39. Игорь Исхаков (Ish_2) 957 18.08.09 10:37 Сейчас в теме
(36) Поддерживаю . Если , конечно, это не нарушает коммерческих планов автора темы.
40. Владимир Пушин (vladnet) 223 18.08.09 11:13 Сейчас в теме
(39) Пишите что подробнее расписать, я дополню статью: http://www.infostart.ru/blogs/1113/
41. Игорь Исхаков (Ish_2) 957 18.08.09 11:42 Сейчас в теме
(40) В одной хорошо иллюстрированной статье с примерами кода рассмотреть методы работы с графической схемой и основы работы с графом.
42. Павел Егоров (SatanClaws) 105 08.09.09 14:33 Сейчас в теме
На мой взгляд, существенно не хватает примерно следующего:

Перем АктивныйЭлемент;

//...

Процедура ПолеГрафическойСхемыПриАктивизации(Элемент)
УстановитьЦвет(АктивныйЭлемент, ЦветаСтиля.ЦветРамки);
АктивныйЭлемент = Элемент.ТекущийЭлемент;
УстановитьЦвет(АктивныйЭлемент, WebЦвета.Черный);
КонецПроцедуры

Процедура УстановитьЦвет(Элемент, Цвет)
Если ТипЗнч(Элемент) = Тип("ЭлементГрафическойСхемыДекоративнаяЛиния") Тогда
Элемент.ЦветЛинии = Цвет;
ИначеЕсли ТипЗнч(Элемент) = Тип("ЭлементГрафическойСхемыДействие") Тогда
Элемент.ЦветРамки = Цвет;
КонецЕсли;
КонецПроцедуры

Так же ТолькоПросмотр графической схемы, на мой взгляд, по умолчанию должен = Истина, и завязать его на кнопку с пометкой.
43. Павел Егоров (SatanClaws) 105 08.09.09 14:42 Сейчас в теме
ЗЫ Общее исполнение, впечатляет, но весьма своебразно...
44. Владимир Пушин (vladnet) 223 08.09.09 15:41 Сейчас в теме
(42) А для чего это надо и так ведь видно что выбрано в текущий момент?

(43) Что именно своеобразно?
45. Павел Егоров (SatanClaws) 105 08.09.09 15:44 Сейчас в теме
(44) Это важно, в первую очередь, для стрелок.
Ибо когда граф получился на 3 страницы - офигенно весело сролиться вверх-вниз, пытаясь не потерять линию. :)
46. Вадим Ляхин (lvadim) 21 02.10.09 11:06 Сейчас в теме
Спасибо автору за пример работы с графической схемой.

С точки зрения кодирования на мой взгляд лучше было выделить некоторые блоки и называть ф-ции примерно так:

ВыводКвадратВывести
ВыводЛинияВывести
ВыводФигурыСоединить

ЗаписьКвадратСохранить
ЗаписьКвадратСохранитьСоСвзяанными

тогда в тексте было бы проще ориентироваться и дорабатывать
47. Ksandr2010 (aochkasov) 12.04.11 13:22 Сейчас в теме
Было бы великолепно получить описание всех процедур и функция используемых в обработке.
Вот сейчас пытаюсь подогнать под свою конфигурацию. Толку мало
48. Александр Орефков (orefkov) 1433 27.04.11 13:18 Сейчас в теме
Кстати, однострочный цикл (и условие) в 1С выполняются быстрее, чем тот же цикл, записанный в несколько строк.
49. Дмитрий Елисеев (w-divin) 27.04.11 13:26 Сейчас в теме
(33) (35) (27)п.3
Собсно по поводу комментов к процедурам/функциям... есть у 1С-негоф ИМХО очень замечательная вещь - описание параметров, независимо от того понятны они или нет:
// Проверяет наличие требуемых данных в источнике и Формирует таблицу значений
//
// Параметры
//  Источник  – ТаблицаЗначений или ТабличнаяЧасть или КоллекцияСтрокДереваЗначений с исходными данными
//
//  Реквизиты – структура – Структура реквизитов. 
//             Ключ     - Наименование колонки в источнике
//             Значение - Наименование колонки в получаемой ТЗ, если значение опущено - приравнивается ключу.
//  ПолучитьНомерСтрокиДокумента - булево
//                                 Используется только при выгрузке из табличной части документа.
//                                 В формируемой таблице создает новую колонку "НомерСтрокиДокумента"
//                                 и заполняет её реальными номерами строк
//
//  КоллекцияКолонокДереваЗначений - только для коллекции строк дерева значений.
//
// Возвращаемое значение:
//  Таблица значений или Неопределено (если не хватает реквизитов)
//
Функция СформироватьТаблицуЗначений(Источник,Реквизиты=Неопределено,ПолучитьНомерСтрокиДокумента = ложь,ФормироватьОтстутствующиеКолонки=Ложь,КоллекцияКолонокДереваЗначений=Неопределено) экспорт
...Показать Скрыть

Имея такие комменты перед процедурой/функцией намного легче писать вызовы... не надо лопатить код (хоть он и умещается на 1 странице). Ну и естественно ежели оно тебе не надо - в свернутом виде занимает 1 строку...
50. Дмитрий Елисеев (w-divin) 27.04.11 14:00 Сейчас в теме
(6) (7) по производительности - полный аут (((
Замер:
Результат:
База - переделанная УТ, файловая, размер 7,5Гб

Для сравнения тоже с типовым механизмом:
Замер:
Результат:

По направлению стрелок - ну совсем непонятно...
По логике ИЗ заказа сделана РН - следовательно:
Заказ --> РН, а у Вас наоборот (((
51. Дмитрий Елисеев (w-divin) 27.04.11 16:06 Сейчас в теме
+(50) (7) - учитывая графический результат и направления стрелок - представленный продукт правильнее было бы назвать "Граф ссылок на объект", а никак не "Структура подчиненности"
52. Владимир Пушин (vladnet) 223 27.04.11 17:46 Сейчас в теме
w-divin пишет:
Собсно по поводу комментов к процедурам/функциям... есть у 1С-негоф ИМХО очень замечательная вещь - описание параметров, независимо от того понятны они или нет:

Да бывают комментарии и полезные, в любом правиле есть исключения.

Стрелки переделаю. По поводу скорости посмотрю, переделаю.
53. Владимир Пушин (vladnet) 223 27.04.11 18:08 Сейчас в теме
Все новая версия готова. Скорость - такая же как и в стандарте, направление стрелок правильное.
54. PVS73 03.05.11 12:00 Сейчас в теме
для 8.2 не планируете адаптацию?
55. Владимир Пушин (vladnet) 223 03.05.11 14:45 Сейчас в теме
А что адаптировать то, откройте в конфигураторе под 8.2, согласитесь с конвертацией!
56. Владимир Пушин (vladnet) 223 03.05.11 14:49 Сейчас в теме
Хотя для самых ленив выложил версию под 8.2.
57. PVS73 03.05.11 16:18 Сейчас в теме
У меня УПП 1.3, сконвертированная версия выдаёт цветные прямоугольники без надписей. Из всей информации виден только ответственный
58. Владимир Пушин (vladnet) 223 04.05.11 12:06 Сейчас в теме
(57) К сожалению такая проблема есть. Возникает на старых релизах платформы. Так что попробуйте ее обновить.
59. Константин Казейн (84kg) 17.05.11 10:40 Сейчас в теме
Некоторые документы открывает быстро в граф виде ,а некоторые документы тупо зависает 1С и висит себе пару минут и отваливается
60. Владимир Пушин (vladnet) 223 17.05.11 14:24 Сейчас в теме
(59) Какая конфигурация, какие документы?
Как отрабатывает стандартная структура подчиненности?
61. Константин Казейн (84kg) 17.05.11 16:54 Сейчас в теме
ут8.1 10.3 стандартная быстро формирует а граф тормозит на поступление товаров и услуг сори с кпк тяжело писать))на светофоре
62. Тоня Тоня (antonina84) 19.05.11 14:52 Сейчас в теме
63. Дмитрий Д. (ddk78ddk) 10.06.11 12:00 Сейчас в теме
Благодарю. Сомневаюсь, что юзерам понадобится граф именно для этой цели но "Обработка может быть использована как пример того как формировать программно Графическую схему." - как раз очень гуд
64. gks 31.08.11 13:09 Сейчас в теме
Бывают дубли линий. Не разбирался. Просто в процедуре мОбновитьОтчет() перед вызовом мПостроитьСхемуПоСвязям() добавил вызов процедуры:
Процедура УдалитьПовторяющиесяСтроки()
УжеВТЧ = Новый Соответствие;
КолвоСтрокТЧ = СвязьДокументов.Количество();
Для ОбратныйИндекс = 1 По КолвоСтрокТЧ Цикл
СтрокаТЧ = СвязьДокументов[КолвоСтрокТЧ - ОбратныйИндекс];
Если УжеВТЧ[СтрокаТЧ.Документ] = СтрокаТЧ.ДокументСвязанный Тогда
СвязьДокументов.Удалить(КолвоСтрокТЧ - ОбратныйИндекс);
Иначе
УжеВТЧ[СтрокаТЧ.Документ] = СтрокаТЧ.ДокументСвязанный;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Иногда граф получается слишком большим. Неплохо бы добавить возможность исключения документов. Самый простой вид фильтра, например, если смотрим связи документа ПоступлениеТоваровУслуг, добавить флажок "кроме других документов ПоступлениеТоваровУслуг". Можно, конечно, реализовать процедурой, аналогичной вышеприведенной, можно и немного покопаться для увеличения быстродействия.
65. Андрей Иванов (Aydrey) 18.10.11 22:10 Сейчас в теме
66. Трактор Трактор (Трактор) 1109 24.10.11 15:38 Сейчас в теме
"Управление торговлей и взаимоотношениями с клиентами (CRM)", редакция 1.0 (1.0.2.2)
Обработка не хотела работать с задачами и бизнес процессами. Сказал чтобы пропускала их. Начала строить дерево, но ничего не построила. Работала примерно два часа и упала :-(
Жаль. Попробовать не удалось. Идея хорошая.
67. Владимир Шатохин (vovkakursk) 24.10.11 19:31 Сейчас в теме
68. Владимир Пушин (vladnet) 223 26.10.11 09:48 Сейчас в теме
(66) Посмотрю чуть попозже, скоро кстати перепишу на управляемые формы если получится.
69. Dali Dali (Dali) 07.11.11 11:22 Сейчас в теме
Скачавшие или автор, закиньте пожалуйста на мыло dali@front.ru, рейтинга не хватает.
Спасибо.
70. Владимир Пушин (vladnet) 223 08.11.11 10:38 Сейчас в теме
71. Дандронтий Крузенштерн (dandrontiy) 21.12.11 15:31 Сейчас в теме
При запуске выдает ошибку. (версия 8.1) конфа не типовая.

{Форма.Форма(122,25)}: Переменная не определена (ОбщегоНазначения)
лСтруктураПутьКДанным=<<?>>ОбщегоНазначения.РазобратьПутьКОбъектуМетаданных(лЭлементСостава.ПолноеИмя());
72. Владимир Пушин (vladnet) 223 21.12.11 16:25 Сейчас в теме
Нужно будет функцию из модуля вставить, вот эту:


Функция РазобратьПутьКОбъектуМетаданных(ПутьКДанным,мКэшПраваДоступаКМетаданным,МетаданныеДокументы) Экспорт
Структура = Новый Структура;
СоответствиеИмен = Новый Массив();
СоответствиеИмен.Добавить("ТипОбъекта");
СоответствиеИмен.Добавить("ВидОбъекта");
СоответствиеИмен.Добавить("ПутьКДанным");
СоответствиеИмен.Добавить("ИмяТаблЧасти");
СоответствиеИмен.Добавить("ИмяРеквизита");

Для индекс = 1 по 3 Цикл

Точка = Найти(ПутьКДанным, ".");
ТекущееЗначение = Лев(ПутьКДанным, Точка-1);
Структура.Вставить(СоответствиеИмен[индекс-1], ТекущееЗначение);
ПутьКДанным = Сред(ПутьКДанным, Точка+1);

КонецЦикла;

ПутьКДанным = СтрЗаменить(ПутьКДанным, "Реквизит.", "");

Если Структура.ПутьКДанным = "ТабличнаяЧасть" Тогда

Для индекс = 4 по 5 Цикл

Точка = Найти(ПутьКДанным, ".");
Если Точка = 0 Тогда
ТекущееЗначение = ПутьКДанным;
Иначе
ТекущееЗначение = Лев(ПутьКДанным, Точка-1);
КонецЕсли;

Структура.Вставить(СоответствиеИмен[индекс-1], ТекущееЗначение);
ПутьКДанным = Сред(ПутьКДанным, Точка+1);

КонецЦикла;

Иначе

Структура.Вставить(СоответствиеИмен[3], "");
Структура.Вставить(СоответствиеИмен[4], ПутьКДанным);

КонецЕсли;

Возврат Структура;

КонецФункции // РазобратьПутьКОбъектуМетаданных()

Чуть позже сам вставлю ее в обработку. Надо бы отвязываться от стандарта. Да в конфигурации все равно должен быть критерий отбора для перебора подчиненных документов, с именами: СвязанныеДокументы или СтруктураПодчиненности
74. ylyas v (ylyas) 25 17.01.12 16:11 Сейчас в теме
ошибка вываливается при формировании запроса в функции
мПолучитьМассивДокументовПоКритериюОтбора()
когда лТекстЗапроса = "".
нужно проверять текст запроса перед его выполнением.
75. Игорь Фелькер (Brawler) 276 21.01.12 15:36 Сейчас в теме
Довольно хорошая разработка на первый взгляд ИМХО, правда под себя все же пришлось капельку доработать.
Убрал возможность редактировать схему, убил ссылку внизу окна, добавив на ее место панель с кнопкой закрыть, немного по перемещал выравнивающие линии, потом переименовал реквизит "ДокументСсылка" в "СсылкаНаОбъект" и добавил в модуле обработки следующую процедурку:

Функция Печать() Экспорт
	
	ПолучитьФорму("Форма").Открыть();

	Возврат Неопределено;
	
КонецФункции // Печать
...Показать Скрыть


Получилась таки еще и внешняя печатная форма. Вот только думаю приклепать или нет авторегистрацию ко всем документам конфигурации как это делается в альтернативном решении http://infostart.ru/public/103500/
76. Michael Smith (opiumdx) 27.01.12 10:32 Сейчас в теме
Спасибо интересная разработка, скачаю, посмотрю, может пригодится.
78. Oleg Moskvichev (m_aster) 67 29.03.12 09:49 Сейчас в теме
79. Oleg Moskvichev (m_aster) 67 29.03.12 09:54 Сейчас в теме
Не работает в типовой БП 2.0 8.2:
{Форма.ФормаО.Форма(328)}: Ошибка при вызове метода контекста (ЗначениеИзФайла)
лНастройкиТипы = ЗначениеИзФайла(КаталогВременныхФайлов() + "СтруктураПодчиненностиНастройкиТипы");
по причине:
Ошибка преобразования
80. Владимир Пушин (vladnet) 223 29.03.12 19:27 Сейчас в теме
(79) Не ясно откуда вы взяли эту ошибку. В обработке нет формы с таким названием, и нет такой строки.
81. Владимир (vladir) 105 15.06.12 10:26 Сейчас в теме
Интересная обработка. Спасибо.
82. Александр Лапшин (zfilin) 1804 22.08.12 11:04 Сейчас в теме
Столько всего про код написано, что скачал специально посмотреть код. =)
Мне, как фанату Макконела, код во многом нравится. Небольшие цельные методы, самодокументируемые имена, все класс.
Сбивают с толку префиксы. Вот эти "п-л-м". Где-то я, вроде, читал что об эти префиксы много копий поломали в свое время и решили не использовать во многих случаях в других языках. Ну, то не вспомню уже где.
И еще не хватает более общей структуры. Не зря же есть рекомендованная "структура модуля". Можно было бы как-то выделить блоками - это вспомогательные, это основная логика, это отрисовка.
83. Владимир Пушин (vladnet) 223 22.08.12 11:19 Сейчас в теме
Для чего используются префиксы. Самое основное чтобы не спутаться в том где определена переменная и не определить ее дважды. Часто ошибки бывают что определил на форме, потом ту же переменную в модули и лезут ошибки, самое плохое не ясно какие это ошибки.

А вообще я считаю что хорошего программиста определяет то как он пишет и то как четко он следует своим принципам.

Можно кстати по структуре модуля? Что за рекомендованная?
84. Игорь Steelvan (Steelvan) 26 18.09.12 00:12 Сейчас в теме
Хм. Мысль хорошая. Надо будет построить с помощью graphwiz-а и этой программы www.схемы1С.рф интерактивные графы.

Построю DOT файл по структуре подчиненности, скормлю graphwiz-у, проанализирую результат, переведу его в xml файл понятный для ОптимаСофт:Схемы и получу интерактивный граф.

Кому интересно ?
85. Игорь Steelvan (Steelvan) 26 18.09.12 00:13 Сейчас в теме
Подписался на тему для обсуждения.
87. Игорь Steelvan (Steelvan) 26 24.10.12 16:23 Сейчас в теме
Ну как и обещался.
Сделал интерактивную структуру подчиненности по данным DOT.
Подробнее написал в статье http://www.схемы1с.рф/str_podch.html

С работой в управляемых формах, открытием документов и прочими удобностями.
88. Владимир Пушин (vladnet) 223 24.10.12 16:27 Сейчас в теме
(87) Хватит рекламироваться в моей теме.
89. Игорь Steelvan (Steelvan) 26 25.10.12 11:37 Сейчас в теме
Нет. Это не реклама. Это оповещение уважаемого сообщества о наличии альтернатив.
90. Александр Топольский (AlexanderKai) 23.07.13 05:51 Сейчас в теме
По ссылке схемы1с.рф просто жесткие схемы. Зигзагообразные линии вводят в ступор :)
91. Николай Андреев (stash_84) 21.10.14 09:37 Сейчас в теме
Проект еще продолжается? Есть данная обработка под 8.3?
92. Игорь Герман (German_Tagil) 3 15.02.17 14:49 Сейчас в теме
Я разачарован - всего 8 документов - а система выпадает в аут
заказ поставщику
и приходники
с поступлениями

И что платная что не платная обработки одинаковые
может я чего-то не понял?