gifts2017

Документообмен между двумя одинаковыми конфигурациями

Опубликовал Андрей Одинец (Andrey_O) в раздел Обработки - Обработка документов

Документообмен между двумя одинаковыми конфигурациями

Просто перенос документов через TXT между двумя одинаковыми конфигурациями

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Выгрузка_Загрузка_Док.ert
.1245008274 242,00Kb
25.09.09
193
.1245008274 242,00Kb 193 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. MnepoX (mnepox) 15.06.09 04:27
Переносит непроведенными ?
2. Епрст (Ёпрст) 15.06.09 11:39
Улыбнуло ...
Родитель1=ВыбЭлемент.Родитель.Родитель.Родитель.Родитель.Родитель.Родитель.Родитель.Родитель;
Родитель2=ВыбЭлемент.Родитель.Родитель.Родитель.Родитель.Родитель.Родитель.Родитель;
Родитель3=ВыбЭлемент.Родитель.Родитель.Родитель.Родитель.Родитель.Родитель;
Родитель4=ВыбЭлемент.Родитель.Родитель.Родитель.Родитель.Родитель;
Родитель5=ВыбЭлемент.Родитель.Родитель.Родитель.Родитель;
Родитель6=ВыбЭлемент.Родитель.Родитель.Родитель;
Родитель7=ВыбЭлемент.Родитель.Родитель;
Родитель8=ВыбЭлемент.Родитель
3. dushelov (Душелов) 15.06.09 11:42
4. Александр Рытов (Арчибальд) 15.06.09 11:49
(2)Причем два раза подряд ;))
5. Юрий Тимофеев (Tatitutu) 15.06.09 11:55
-кто у Вас семье самый старший ?
- пра ...пра...пра...пра...пра...дедушка !
- Но этого не может быть !!!
- мо..мо..мо..мо..мо...жет :-)
Арчибальд; +1 Ответить
7. Максим . (mvv1969) 17.06.09 20:50
....
Родитель4=ВыбЭлемент.Родитель.Родитель.Родитель.Родитель.Родитель;
Родитель5=ВыбЭлемент.Родитель.Родитель.Родитель.Родитель;
Родитель6=ВыбЭлемент.Родитель.Родитель.Родитель;
Родитель7=ВыбЭлемент.Родитель.Родитель;
Родитель8=ВыбЭлемент.Родите .......

Почитайте "простые примеры". там тоже так предлагается получать полный код справочника.
8. Альтаир (Altair777) 17.06.09 20:58
(7)
> Почитайте "простые примеры". там тоже так предлагается получать полный код справочника.
А где почитать?

А так не судьба?
Родитель8=ВыбЭлемент.Родитель;
Родитель7=Родитель8.Родитель;
Родитель6=Родитель7.Родитель;
Родитель5=Родитель6.Родитель;
Родитель4=Родитель5.Родитель;
Родитель3=Родитель4.Родитель;
Родитель2=Родитель3.Родитель;
Родитель1=Родитель2.Родитель;
9. Альтаир (Altair777) 17.06.09 21:02
(7) А при чем тут полный код?

см. СП
Синтаксис:
ПолныйКод()
Назначение:
Возвращает строку, содержащую полный код выбранного элемента справочника со всеми вышестоящими уровнями, разделенными символом /.
10. Максим . (mvv1969) 17.06.09 21:10
(8) так лучше
(9) через такую "лесенку" рекомендуется получать полный код запросом.
11. Альтаир (Altair777) 17.06.09 21:14
(10)
> (8) так лучше
Чем лучше?
> (9) через такую "лесенку" рекомендуется получать полный код запросом.
А запрос здесь при чем? И "Лесенка" :-)
12. Максим . (mvv1969) 17.06.09 21:24
(11) Лучше тем, что точек меньше. А чем больше точек, тем больше итераций. 8-ка умеет кешировать объекты и то будет дольше выкручивать владельцев с одного и того же элемента. в 7-ке было бы хуже.
13. Александр Венгер (venger) 17.06.09 21:31
Ух вы тут жжете с лесенками, аж страшно, брр, убегаю лучше опять в Life:-)
14. Альтаир (Altair777) 17.06.09 21:35
(12)
В (2)
Родитель1 - 8 точек
Родитель2 - 7 точек
Родитель3 - 6 точек
Родитель4 - 5 точек
Родитель5 - 4 точки
Родитель6 - 3 точки
Родитель7 - 2 точки
Родитель8 - 1 точка
Итого: 36 точек

В (8) 8 точек

П.С. Мне просто показалось, что Вы сказали что в (2) лучше :-)
15. Александр Венгер (venger) 17.06.09 21:47
(14) А че цикл или рекурсию не судьба?
16. Альтаир (Altair777) 17.06.09 21:53
(15) Если задача стоит в том, что бы найти самого первого предка, то можно и функцию написать - ОсновательДинастии() :-) с циклом
17. Александр Астафьев (alexandr_astafiev) 17.06.09 22:17
В ссылке сидят две обработки для универсального переноса документов и справочников между двумя одинаковыми конфигурациями. Обработкам "сто лет в обед" т.к когда то они шли на дисках 1С ИТС все работает через текстовый файл единственное что модернезировали в свое время добавили использование компоненты v7plus чтоб шустрее работало когда большие файлы получаются. Пользуйся народ. Удачи !!!
http://narod.ru/disk/5618530000/УниверсальнаяЗагрузкаВыгрузкаДля1С77%20(copy%202).rar.html
18. Александр Венгер (venger) 17.06.09 22:21
Типа так:

сп=СоздатьОбъект("СписокЗначений");
сп.ДобавитьЗначение(спр.ТекущийЭлемент().Родитель);
Для сч=1 По 7 Цикл
ТекЗнач=сп.ПолучитьЗначение(сч).Родитель;
Если ПустоеЗначение(ТекЗнач)=1 Тогда
Если ПустоеЗначение(сп.ПолучитьЗначение(1))=1 Тогда
сп.УдалитьВсе();
КонецЕсли;
Прервать;
КонецЕсли;
сп.ДобавитьЗначение(ТекЗнач);
КонецЦикла;
19. Александр Венгер (venger) 17.06.09 22:25
(18) Это так, самый примитивный, родителей то не всегда 8-м у каждого элемента справочника или что там... Это для семерки:-)
20. Альтаир (Altair777) 17.06.09 22:42
(19) А так?

Функция Родители(Элем)
Перем сп, Род;
сп=СоздатьОбъект("СписокЗначений");
Род=Элем.Родитель;
Пока ПустоеЗначение(Род)=0 Цикл
сп.ДобавитьЗначение(Род);
Род=Элем.Родитель;
КонецЦикла;
Возврат сп;
КонецФункции
21. Альтаир (Altair777) 17.06.09 22:46
+(20) ой.. описка

Функция Родители(Элем)
Перем сп, Род;
сп=СоздатьОбъект("СписокЗначений");
Род=Элем.Родитель;
Пока ПустоеЗначение(Род)=0 Цикл
сп.ДобавитьЗначение(Род);
Род=Род.Родитель;
КонецЦикла;
Возврат сп;
КонецФункции
22. Александр Венгер (venger) 17.06.09 23:07
(21) :-)))

Процедура УсеРодители(элем, сп)
Если ПустоеЗначение(элем.Родитель)=1 Тогда
Возврат;
Иначе
сп.ДобавитьЗначение(элем.Родитель);
УсеРодители(элем.Родитель,сп);
КонецЕсли;
КонецПроцедуры
23. Альтаир (Altair777) 17.06.09 23:13
Рекурсия ресурсы кушает... стеки вызовов там всякие.... ?-)
24. Александр Венгер (venger) 17.06.09 23:17
(23) Счас замерю:-) Но в любом случае, обожаю краткость кода:-) Хотя, это ж 1С, а не программирование:-)
25. Альтаир (Altair777) 17.06.09 23:19
(24) И график, пожалуйста... типа как про пиратов :-)
26. Александр Венгер (venger) 17.06.09 23:27
(25) Точно, чем меньше строк кода, тем больше ресурсов он жрет:-))) Вывод - пишите как можно больше кода:-)))
28. Александр Венгер (venger) 18.06.09 00:49
(27) Родилась шутка:-) Рекурсия, она как женщина, - затратна, но как красива, чертовка:-)))
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа