gifts2017

Юбиляры и дни рождения сотрудников

Опубликовал Владимир (for_les) в раздел Отчеты - Разное

Отчет для 1С: Зарплата и кадры 7.7

 

- отчет за выбранный период и за произвольное количество дней от текущей даты;
- показывает только штатных сотрудников;
- в разрезе подразделений  и по организации в целом;
- возможность добавления в список числа лет, которое считается юбилеем (по умолчанию предопределены: 50, 55 и 60 лет).

Скачать файлы

Наименование Файл Версия Размер
Юбиляры.ert 186
.1245134707 72,00Kb
25.09.09
186
.1245134707 72,00Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Timur Хамидуллин (timurei) 24.06.09 08:44
было бы удобнее если в списке выходили и другие данные такие как подразделение, должность ..и т.п. ...но их можно самим добавить кАму не лень..:)
2. Елена Иванчеглова (morpod) 24.06.09 10:25
Спасибо! Благодаря вашему отчету не забыли поздравить сотрудника!
3. Владимир (for_les) 25.06.09 00:49
(2) Благодарю за добрые слова!!!Рад слышать, что обработка реально пригодилась! ::)))
4. Юля Захарова (Юля21) 08.11.11 09:05
Спасибо, пригодилась)))) Теперь никого не забываем поздравить)))
5. Lexa О (e-lexa) 23.07.12 19:15
Спасибо, отчет полезный, скачал пользуюсь. Но есть небольшой баг если есть несколько сотрудников с одинаковой датой рождения в список попадает лишь один из них, надеюсь автор исправит. Для себя проблему решил таким образом (добавлением трех строк):
###############################
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;

ДатаФормироавания=ТекущаяДата();

Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ДатаФормироавания по ДатаФормироавания;
|ОбрабатыватьДокументы все;
|Сотрудники = Справочник.Сотрудники.ТекущийЭлемент;
|ДатаРождения = Справочник.Сотрудники.ДатаРождения;
|Подразделение = Справочник.Сотрудники.Подразделение;
|Физлицо = Справочник.Сотрудники.СостояниеФизлица;
|Группировка ДатаРождения;
|Группировка Сотрудники; //Добавлена Строка
|Условие(Подразделение в ВыборПодразделения);";

Если ТолькоШтатные = 0 Тогда
Иначе
ТекстЗапроса=ТекстЗапроса+"
|Условие(ПустоеЗначение(Физлицо)=0);";
КонецЕсли;
ТекстЗапроса=ТекстЗапроса+"
|Условие(ПустоеЗначение(ДатаРождения)=0);
|"//}}ЗАПРОС
;

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

ТЗ= СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("ФИО");
ТЗ.НоваяКолонка("ДатаРождения");
ТЗ.НоваяКолонка("ДеньРождения");
ТЗ.НоваяКолонка("МесяцРождения");

Пока Запрос.Группировка(1) = 1 Цикл
Пока Запрос.Группировка(2) = 1 Цикл //Добавлена Строка
ТЗ.НоваяСтрока();
ТЗ.ФИО = Запрос.Сотрудники;
ТЗ.ДатаРождения = Запрос.ДатаРождения;
ТЗ.ДеньРождения = ДатаЧисло(Запрос.ДатаРождения);
ТЗ.МесяцРождения = ДатаМесяц(Запрос.ДатаРождения);
КонецЦикла; //Добавлена Строка
КонецЦикла;

ТЗ.Свернуть("ФИО","ДатаРождения,ДеньРождения,МесяцРождения");

################################
ЕСЛИ ПРИГОДИТСЯ КОМУ НЕ СОЧТИТЕ ЗА ТРУД ПОСТАВИТЬ ПЛЮС
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа