gifts2017

Изменение некоторых реквизитов Договора

Опубликовал Vyacheslav Bondarchuk (freesyava) в раздел Обработки - Обработка справочников

Изменение некоторых реквизитов Договора по которым было движение

 

Уже даже и не помню, взял чью-то обработку (да простит меня автор) и добавил некоторые реквизиты, которые невозможно поменять руками, так как имеются проведенные документы. Можеткому-то пригодиться. Испытывалось на УПП

 

Скачать файлы

Наименование Файл Версия Размер
ИзменениеДоговора.epf 78
.1245419586 8,64Kb
30.01.13
78
.1245419586 8,64Kb Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение

Комментарии

1. Павел Рыжиков (RPV) 28.06.09 00:20
В БП 1.6 во-первых не дает редактировать поле "Вид договора", что очень нужно +при нажатии на кнопку "Выполнить" выдает ошибку:
"{Форма.Форма(39)}: Ошибка при вызове метода контекста (Записать): Операция не выполнена!
Док.Записать(РежимЗаписиДокумента.ОтменаПроведения);
по причине: Операция не выполнена!"
2. Lex Luthor (461120) 12.09.11 23:02
да, надо признать что обработка недоделана
меняет только те реквизиты, которые можно изменить стандартными средствами 1с.
:(
3. Ильшат Мазитов (байт) 01.11.11 18:51
Попытался я ею воспользоваться в итоге обошелся стандартными средствами, вообщем не помогла да простит меня автор)))
4. Vyacheslav Bondarchuk (freesyava) 01.11.11 21:55
Обработка была написана в 2009 году, может и не совершенна. Но если по договору было движение, то поменять реквизит ведения по документам или по договору в целом невозможно, а обработка делает все документы по договору непроведенными, меняет реквизит, и проводит обратно. Мне в свое время (в период внедрения бухи лепили что кому угодно) оч. помогла.
5. Ильшат Мазитов (байт) 21.12.11 10:50
(0) 1) автор обнаружил ошибку в следующем фрагменте кода
Если Найти(ТипЗнч(стрТЗ.Данные),"Документ")>0 Тогда, стрТЗ.Данные здесь ссылочный тип он не определяется в данном контексте нужно получить объект тогда сработает и соответственно доки не распроводит сделайте корректировку, я изменил на
Для Каждого стрТЗ ИЗ ТЗ Цикл
Состояние(стрТЗ.Данные);
Если не Найти(стрТЗ.Данные, "Регистр") > 0 Тогда
НужнОбъект = стрТЗ.Данные.ПолучитьОбъект();
Если Найти(ТипЗнч(НужнОбъект),"Документ")>0 Тогда
флПроведения = стрТЗ.Данные.Проведен;
Если флПроведения Тогда
Док = стрТЗ.Данные.Ссылка.ПолучитьОбъект();
Док.Записать(РежимЗаписиДокумента.ОтменаПроведения);
стрТЗ.Проведен = Истина;
Сообщить(""+СокрЛП(стрТЗ.Данные)+" - отмена проведения");
КонецЕсли;
КонецЕсли;
Иначе
Сообщить(ОписаниеОшибки());
КонецЕсли;
КонецЦикла;

2) не увидел что после изменения реквизита он заново проводит доки, тестировал на галочке "ВестиПоДокументамРасчетовСКонтрагентом"
6. Ильшат Мазитов (байт) 21.12.11 10:53
(5) а все понял там аналогичная ситуация...
7. Ильшат Мазитов (байт) 21.12.11 10:54
+(6) пункт 2 в (5) отметается...
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа