gifts2017

Подсистема настройки отображения штрих-кода

Опубликовал Алекс Климанов (fuxic) в раздел Программирование - Инструментарий

При работе сталкивался с задачей настройки отображения штрих-кодов в нескольких ситуациях, например, этикетках и ценниках, произвольных печатных формах клиентов для их поиска сканером. При этом необходимо учесть множество нюансов - размер, кодировка, макет. Например для кодирования договоров клиент очень не хотел цифры и тысячи раз просил "немного" подвинуть и поменять шрифт.

Для упрощения реализован справочник для настройки отображения штрих-кода и процедура получения изображения по настройке.

Далее этот шаблон можно использовать в обработке печати этикеток и ценников, для печати в любом вашем макете. Легко интеигрируется  и адаптируется под любые конфигурации.

Я всего лишь программист, поэтому поставляется "как есть" и способы использования и применение полностью на ваше усмотрение. Надеюсь, пригодится для основы.

 

UPD 2013/11/01

Версия для управляемых форм. Мелкие правки для удобства использования. Добавлен пример использования.

 

Как же все таки этим воспользоваться? Очень просто. Объедините три объекта приложеной конфигурации с вашей и в необходимых местах и печатных формах добавтьте картинку. Код для вывода изображения штрих-кода картинки:

 

&НаСервере
Процедура УстановитьШтрихкод(Знач Штрихкод, Рисунок, ВнешняяКомпонента)

	Если НЕ ЗначениеЗаполнено(Штрихкод) Тогда 
		Возврат;
	КонецЕсли;	
	
	Справочники.ШаблоныШтрихкодов.УстановитьРисунокШтрихкода(Рисунок, Объект.ШаблонШтрихкода, ВнешняяКомпонента, Штрихкод);

КонецПроцедуры

&НаСервере
Процедура СформироватьСервер(ТабДок = Неопределено)
	
	Если ТабДок = Неопределено Тогда 
		ТабДок = Новый ТабличныйДокумент;
	КонецЕсли;	
....

// шаблон искать по наименованию или где-то хранить в разрезе ПФ
	Если ЗначениеЗаполнено(Объект.ШаблонШтрихкода)
Тогда 
		
		ВнешняяКомпонента = Неопределено;
		Для Каждого Рисунок Из ТабДок.Рисунки Цикл 
			Если Найти(Рисунок.Имя, "Штрихкод") > 0 Тогда 
				Штрихкод = ""; // его надо хранить для печатной формы
				УстановитьШтрихкод(Штрихкод, Рисунок, ВнешняяКомпонента);
			КонецЕсли;	
		КонецЦикла;
		
	КонецЕсли;


КонецПроцедуры// СформироватьРисунок()

 


 

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
НастройкаШтрихкода.cf
.cf 4,85Mb
13.08.15
8
.cf 4,85Mb 8 Скачать
Демо настройка ШК 0.2.dt
.dt 8,85Mb
13.08.15
7
.dt 8,85Mb 7 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей (seermak) 31.10.13 12:40
Уже рисунки за стартмани пошли? Круто....
2. Алекс Климанов (fuxic) 31.10.13 14:26
3. Вячеслав Хахалев (Vyacheslav56) 01.11.13 07:35
4. Александр Ковалев (kovaleks78) 01.11.13 07:51
(3) Vyacheslav56, без доработки, как я понимаю - не будет.
5. Алекс Климанов (fuxic) 05.11.13 10:40
(3) Интегрируется с помощью программиста. Квалификация не играет большой роли, в публикации и демо-базе приведен пример и описание.

(4) Не будет. Но на основании этого можно встроить в систему механизм штрих-кодирования любых печатных форм в вашей учетной системе.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа