IE2017

Внешняя компонента - звуковой сигнал с помощью системного динамика

Программирование - Внешние компоненты

Внешняя компонента позволяет издавать звуки из системного динамика.

В параметрах можно передавать частоту и длительность сигнала.

Beep.dll скопировать в каталог базы.

Эту компоненту удобно применять в отчётах и обработках, которые долго выполняются. Как применять - смотреть в примере. Можно самому сочинить музыкальный фрагмент.

Скачать файлы

Наименование Файл Версия Размер
Beep.dll
.1245923534 18,96Kb
10.09.14
161
.1245923534 18,96Kb 161 Скачать

См. также

Комментарии
1. Александр Рытов (Арчибальд) 2659 25.06.09 14:12 Сейчас в теме
Вот я сейчас плюсану, потому, что мне надо. А когда завтра не найду описания, минусану, и всех знакомых попрошу....
Serg3141; Parazyte; +2 Ответить
2. Parazyte (Parazyte) 35 25.06.09 14:17 Сейчас в теме
Повезло автору, что в комплекте есть тестовая обработка с описанием :)
3. Александр Рытов (Арчибальд) 2659 25.06.09 14:30 Сейчас в теме
(2) Я видел ее, иначе не плюсовал бы. Но минус гарантирую, если описание на сайте останется столь же "информативным"
4. Альтаир (Altair777) 637 25.06.09 14:43 Сейчас в теме
(3) Ага, и не мешало бы еще описание через Ворд прогнать :-)
5. Александр Рытов (Арчибальд) 2659 25.06.09 15:04 Сейчас в теме
(4) Автор однозначно вменяем, что радует.
Описанием пока не удовлетворен, но минуса не будет.
6. Алексей Плутенко (Noy) 1057 25.06.09 16:04 Сейчас в теме
Можно "пиликать" с помощью DynamicWrapper.
http://www.script-coding.info/dynwrap.html - первый же пример кода про Beep.
Есть и на ИС блог: http://infostart.ru/blogs/905/

зачем делать ВК для одной функции?
7. Игорь (igor1318) 41 25.06.09 16:23 Сейчас в теме
Специально сделано, чтобы проще было "пиликать".
8. Сергей (Che) Коцюра (CheBurator) 3385 25.06.09 18:00 Сейчас в теме
(6) а что делать если не удалось инициализировать DynamicWrapper - у меня на некоторых машинах не получается...
Код
   //возможности ядра
   Попытка глWrapper = СоздатьОбъект("DynamicWrapper");
           ИнициализацияНот(); //пропишем ноты
   Исключение
      глWrapper = 0;
      Сообщить("> Не удалось создать объект ""DynamicWrapper""
             |Ничего страшного... можно продолжать работу...
             |Сообщите Программисту 1C!","i");
   КонецПопытки;   
Показать полностью
9. Сергей (Che) Коцюра (CheBurator) 3385 25.06.09 18:01 Сейчас в теме
попадаем в исключение - не удается создать объект...
???
10. anbxp (anbxp) 25.06.09 20:13 Сейчас в теме
(6) Какая разница - beep.dll грузить, или dynwrap.dll? Если нужен только звук?
11. Алексей Северянин (Ledokol-alt) 126 26.09.09 22:50 Сейчас в теме
А на ноутбуке не пашет (( Не для всех значит, не зер гуд.
12. Алексей Марченко (Alexez) 40 09.11.11 00:17 Сейчас в теме
Спасибо, замутил для работы с весами, на спикер поставил лампочку.
Parazyte; +1 Ответить
13. Андрей Волощук (karandashura) 03.07.12 12:26 Сейчас в теме
14. Ilya (ivisor_fil) 9 08.04.17 16:36 Сейчас в теме
Вот посылка звукового сигнала на спикер:

Процедура глБиип(КолЗвуков=0)
    Если КолЗвуков=0 Тогда Возврат; КонецЕсли;
    
    Shell = Новый COMОбъект("WScript.Shell");
    Команда = "%comspec% /c @echo ";
    Для Ном = 1 по КолЗвуков Цикл
        Команда = Команда + Символ(7);
    КонецЦикла;
    Shell.Run(Команда,0,0);
КонецПроцедуры
...Показать Скрыть


Скрыть
Оставьте свое сообщение