gifts2017

Внешняя печатная форма АО-1 для документа "Авансовый отчет" с выбором бухгалтера для конфигурации "Бухгалтерия предприятия"

Опубликовал Михаил Блохин (MikStyle) в раздел Печать - Печатные формы документов

Внешняя печатная форма АО-1 для документа "Авансовый отчет" с выбором бухгалтера в строке "расшифровка подписи"

Понадобилась такая форма с расшифровкой подписи бухгалтера

Скачать файлы

Наименование Файл Версия Размер
- 308
.1245953837 20,20Kb
19.07.13
308
.1245953837 20,20Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Erne100 (Erne100) 26.06.09 03:35
Не в обиду будет сказано, но вместо :
Представление = "";
Если ЗначениеЗаполнено(Бухгалтер) Тогда
ЗапросПоЛицам = Новый Запрос();
ЗапросПоЛицам.УстановитьПараметр("ДатаСреза" , СсылкаНаОбъект.Дата);
ЗапросПоЛицам.УстановитьПараметр("ФизЛицо" , Бухгалтер);
ЗапросПоЛицам.Текст =
"ВЫБРАТЬ
| ФИОФизЛицСрезПоследних.Фамилия,
| ФИОФизЛицСрезПоследних.Имя,
| ФИОФизЛицСрезПоследних.Отчество
|ИЗ
| РегистрСведений.ФИОФизЛиц.СрезПоследних(&ДатаСреза, ) КАК ФИОФизЛицСрезПоследних
|ГДЕ
| ФИОФизЛицСрезПоследних.ФизЛицо = &ФизЛицо";

Результат = ЗапросПоЛицам.Выполнить().Выбрать();

Пока Результат.Следующий() Цикл

ФИО = Новый Структура("Фамилия, Имя, Отчество, Представление");
Если НЕ (НЕ ЗначениеЗаполнено(Результат.Фамилия) или Результат.Фамилия = NULL) Тогда
ФИО.Фамилия = Результат.Фамилия;
КонецЕсли;
Если НЕ (НЕ ЗначениеЗаполнено(Результат.Имя) или Результат.Имя = NULL) Тогда
ФИО.Имя = Результат.Имя;
КонецЕсли;
Если НЕ (НЕ ЗначениеЗаполнено(Результат.Отчество) или Результат.Отчество = NULL) Тогда
ФИО.Отчество = Результат.Отчество;
КонецЕсли;
Представление = ОбщегоНазначения.ПолучитьФамилиюИмяОтчество(ФИО.Фамилия, ФИО.Имя, ФИО.Отчество);
Прервать;
КонецЦикла;
ОбластьМакета.Параметры.ПредставлениеБухгалтера = Представление;
КонецЕсли;


,достаточно одной строки:

ОбластьМакета.Параметры.ПредставлениеБухгалтера = ОбщегоНазначения.ДанныеФизЛица(СсылкаНаОбъект.Организация, Бухгалтер, ТекущаяДата()).Представление;
3. Erne100 (Erne100) 26.06.09 03:36
почему-то добавилось 2 раза, извините.
4. Erne100 (Erne100) 26.06.09 08:20
только вместо ТекущаяДата() - СсылкаНаОбъект.Дата
5. Erne100 (Erne100) 26.06.09 08:29
и вообще для одной подписи типа константа, можно обойтись без формы ввода,
тем самым сократив число кликов для пользователя:

1.Использовать регистр сведений "ОтветственныеЛицаОрганизаций"
2.Заполнить реквизит как у главбуха
6. Erne100 (Erne100) 26.06.09 08:30
7. Михаил Блохин (MikStyle) 26.06.09 15:25
(1-6) - спасибо за комментарий. Этот кусок кода - следствие недостаточного знания типовой конфигурации... А по поводу использования регистра, то например при подписи разными бухгалтерами этот вариант наверное будет не оптимальные. В принципе можно получить ссылку на физ.лицо текущего пользователя, но тут проблема может быть в том что один бухгалтер приходит взамен другого, а пользуется записью старого пользователя.
Кстати пока писал подумал, что может вот такой вариант прокатит. В форме регистрации печатной формы в "параметр" при установке тула любого значения форму выбора бухгалтера не выводить, иначе выводить и показать пользователю.. Как думаете такой вариант ...?
8. Erne100 (Erne100) 26.06.09 16:56
При таком варианете основному буху будет легче, а вот групповая печать все равно будет невозможна из-за остановок после вывода формы. Вот если бы бухи менялись с какой-нибудь закономерностью..... А так автоматизация бардака даёт автоматизированный бардак)))
9. Дмитрий К (DemonFM) 07.11.11 20:59
Очень пригодилась. Бухам чего-то в стандартной не хватало, а тут все было.
10. Эстер Коган (e.kogan) 11.01.12 10:04
Нормально, неплохая основа для собственного творчества.