gifts2017

Поиск и замена значений с плюшками для 8.1

Опубликовал Эстер Коган (e.kogan) в раздел Администрирование - Поиск данных

Обработка "Поиск и замена значений" с ИТС. Доработки: возможность загрузки из таблицы (с использованием доработанной типовой загрузки из табличного документа), определение типа "на что заменять" при выборе конкретного значения "что заменять", удобный отбор объектов, в которых заменять ссылки, по типам объектов.

Обработка "Поиск и замена значений" с ИТС. Доработки:

1. Возможность загрузки из таблицы (с использованием доработанной типовой загрузки из табличного документа)

2. Определение типа "на что заменять" при выборе конкретного значения "что заменять"

3. Удобный отбор объектов, в которых заменять ссылки, по типам объектов.

4. Нормальное отображение типов заменяемых объектов.

5. Нормальное отображение типов объектов, в которых заменяются ссылки.

6. Увеличена прозрачность процесса замены ссылок (добавлен показ конкретного места замены в объекте). Пример информационного сообщения о замене ссылки:

Обрабатывается <> (Справочник ссылка: Сохранённые расшифровки АВР для клиентов)
 В <> ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите шапки "Договор контрагента"
Обрабатывается Акт сверки взаиморасчетов 00000000265 от 20.04.2009 14:44:02 (Документ ссылка: Акт сверки взаиморасчетов)
 В Акт сверки взаиморасчетов 00000000265 от 20.04.2009 14:44:02 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите шапки "Договор контрагента"
 В Акт сверки взаиморасчетов 00000000265 от 20.04.2009 14:44:02 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите "Договор" табличной части "По данным организации"
 В Акт сверки взаиморасчетов 00000000265 от 20.04.2009 14:44:02 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите "Договор" табличной части "По данным организации"
Обрабатывается Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 (Документ ссылка: Платежное поручение входящее)
 В Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите шапки "Договор контрагента"
 В Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите "Договор контрагента" табличной части "Расшифровка платежа"
 В движениях Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 (Регистр бухгалтерии: Журнал проводок (бухгалтерский учет)) ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в субконто Кт №2
 В движениях Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 (Регистр накопления: НДС расчеты с покупателями) ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в измерении "Договор контрагента"
Обрабатывается РегистрСведенийКлючЗаписи.ЗначенияСвойствОбъектов (Регистр сведений ключ записи: Дополнительные свойства)
 В РегистрСведенийКлючЗаписи.ЗначенияСвойствОбъектов ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов) в "Объект"

7. Добавлена кнопка "Поменять местами" для выделенных строк таблицы заменяемых значений.

Планируется: оптимизация процесса замены ссылок, внедрение блока замены в регистрах сведений от tormozit (если автор разрешит).

01.09.09 - добавлена замена ссылок в предопределённых ТЧ ПВХ, спасибо RomikMf.

29.04.10 - исправлена ошибка, возникающая в нетиповых конфигурациях - вызов несуществующего общего модуля.

22.06.11 - для конвертации в 8.2 макет сохраняете как epf (это обычная обработка), конвертируете отдельно, загружаете обратно.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.epf 116,70Kb
08.09.14
2128
.epf 116,70Kb 2128 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Алексей Коробов (WiseSnake) 14.07.09 18:42
Спасибо! Думаю буду пользоваться, посему плюс...
А теперь вопросы по существу:
1. У типовой обработки есть бяка... иногда она не заменяет ссылки должным образом, Вы не правили алгоритм в связи с этим?
2. Что означает галочка "Koнтpoлиpoвaть кoppeктнocть"? Хочется услышать от разработчика и в коде смотреть лень ;)
3. При вызове справки... справка все время на заднем фоне, ИМХО баг с настройкой вывода формы...
2. Герман (German) 15.07.09 09:52
>возможность загрузки из таблицы (с использованием доработанной типовой загрузки из табличного документа)... как аналогия http://main.1c-ei.ru/Articles/replacement
3. Эстер Коган (e.kogan) 15.07.09 10:34
(1)
1. Пока не правила. Думаю дорабатывать, возможно, за основу возьму http://infostart.ru/projects/1134/ . Обязательно буду выводить информацию, где конкретно заменено (имя реквизита/реквизита ТЧ/измерения и т.д.)
2. ОбменДанными.Загрузка=Истина
3. Не замечала, честно говоря. У меня всё нормально выводится.

(2) Ну так оно ж для юзверей в основном, а приведённая вами как-то на пользовательски понятную мало похожа )
4. Эстер Коган (e.kogan) 16.07.09 13:45
(1) Кстати, а как именно не заменяет? В каких ситуациях?
5. Сергей Старых (tormozit) 19.07.09 19:36
(0) Я не против. Используй и улучшай.
6. Эстер Коган (e.kogan) 20.07.09 10:59
(5) Спасибо, будет время - займусь.
7. RomikMf (RomikMf) 19.08.09 20:37
(4). Не заменяет в предопределенных табличных частях планов видов расчета. Я добавлял следующий код в функцию вВыполнитьЗаменуЭлементов в текст по замене в справочниках, ПВР и т.п:

// Обработаем предопределенные таблицы ПВР
Если Метаданные.ПланыВидовРасчета.Содержит(СтрокаТаблицы.Метаданные) Тогда

Если СтрокаТаблицы.Метаданные.ЗависимостьОтВидовРасчета <> Метаданные.СвойстваОбъектов.ИспользованиеБазыПланаВидовРасчета.НеИспользовать Тогда

// Базовые
Для каждого СтрокаТЧ Из Параметры.Объект.БазовыеВидыРасчета Цикл
Если СтрокаТЧ.ВидРасчета = Ссылка Тогда
СтрокаТЧ.ВидРасчета = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;

// Ведущие
Для каждого СтрокаТЧ Из Параметры.Объект.ВедущиеВидыРасчета Цикл
Если СтрокаТЧ.ВидРасчета = Ссылка Тогда
СтрокаТЧ.ВидРасчета = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;

КонецЕсли;

Если СтрокаТаблицы.Метаданные.ИспользованиеПериодаДействия Тогда

// Вытесняющие
Для каждого СтрокаТЧ Из Параметры.Объект.ВытесняющиеВидыРасчета Цикл
Если СтрокаТЧ.ВидРасчета = Ссылка Тогда
СтрокаТЧ.ВидРасчета = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЕсли;
8. Сергей Романов (Romanovfastov) 28.08.09 15:06
Спасибо все работает на ура.
9. Эстер Коган (e.kogan) 01.09.09 11:23
10. Андрей Д. (detec) 28.04.10 13:37
Желательно было бы сразу сделать обработку универсальной, без допиливания.
11. Эстер Коган (e.kogan) 28.04.10 13:41
12. Андрей Д. (detec) 28.04.10 22:52
(11)

При открытии в нетивовой конфигурации ругается на ОбщегоНазначения.
13. Эстер Коган (e.kogan) 29.04.10 09:51
(12) О, спасибо. Сейчас поправлю.
14. IP43 (IP43) 14.05.10 15:37
Скачал, поработал, понравилось. Потребовалось снова, не нашел, снова скачал... и о УЖАС я оказывается забыл плюсануть :)
15. Vlad Romanov (Tailbone) 21.05.10 10:39
Плюс от меня однозначно, думал просто скачать навроде стандартной, потом допиливать ОбменДанными = Истина и шерстить регистры (чтоб доки не перепроводились). Всё это уже есть за что бальшое спасибо!!!

Единственный пустячок, незнаю может на моей нетиповой конфе (на типовых не проверял).

Если заменяемое значение найдено в константах, то обработка не понимает этого и в Форма.НайденныеСсылки.ДанныеСтроки.Данные = Неопределено, а так всё замчательно :D
16. Алексей Северянин (Ledokol-alt) 16.02.11 18:41
Спасибо! Скачал, проверил, все отлично!
17. toci (toci) 22.06.11 12:51
Не конвертируется обработка под 82, точнее конвертация происходит, а макет под 82 не открывается.
{Форма.Форма.Форма(741)}: Ошибка при вызове метода контекста (Создать)
обр=ВнешниеОбработки.Создать(рИмяПутьФайла);
по причине:

по причине:
Ошибка подключения внешних метаданных
по причине:
Ошибка загрузки документа.
Внешняя обработка не может быть прочитана текущей версией программы.


как этот макет конвертнуть или может разработчик выложит поправленный вариант для 82?
Заранее, спсб.
18. Эстер Коган (e.kogan) 22.06.11 13:25
(17) Макет сохраняете как epf (это обычная обработка), конвертируете отдельно, загружаете обратно.
19. toci (toci) 22.06.11 13:37
20. Алексей Михайловскй (cobroid) 29.09.11 10:08
Отличная разработка для бухов а то они часом не ведают чего подвешивают :)
21. Zoomby Zoomby (Zoomby) 29.09.11 10:16
Хорошая работа. автору плюсик.
22. Alex AlexX (_iAlex) 04.10.11 13:28
Работает хорошо ! Автор молодец!
23. spryn (spryn) 04.10.11 13:53
24. Ирина Сергеева (Limbo23) 05.10.11 01:12
Отлично работает. Срочно нужно было.
25. Владимир (ARL) 17.10.11 12:41
Отличные "плюшки". Раньше отменял проведение в транзакции у типовой оброботки - слишком много объектов по одной ссылке - памяти не хватало, а тут уже все сделано, и отбор весьма кстати. Добавил только индикацию количества найденных и отобранных ссылок, при больших количествах - видеть это приятно. Обработкой пользуюсь с удовольствием, автору - благодарность.
26. Эстер Коган (e.kogan) 20.10.11 10:42
(25) индикацию количества я когда-то тоже добавляла, но, возможно, запуталась в версиях ;)
27. Алина Алинова (Acasta) 30.10.11 20:56
28. toci (toci) 31.10.11 01:04
29. Юля Захарова (Юля21) 08.11.11 12:48
Спасибо за обработку!!! Пригодилась!!!
30. Сергей Павлов (greyboy666) 08.12.11 14:21
Спасибо за обрботку! Пригодилась
31. Андрей Гросу (trustgros) 14.12.11 18:21
Спасибо за обработку!!! Пригодилась как раз под нужную задачу
32. Юлия Петрова (petrovaUL) 18.01.12 08:29
А если вместо ссылки на объект <Объект не найден> (76:9633 и т.д.) будет работать?
33. Эстер Коган (e.kogan) 18.01.12 12:33
34. Ирина Баранова (Ироида) 22.01.12 00:14
Очень пригодилась, спасибо огромное!
35. AlexShap Shap (AlexShap) 25.01.12 11:35
Спасибо. Очень помогло в решении огрех бухгалтеров.
36. ivan ivanov (ivan07) 25.01.12 13:44
Отличная обработка. Большое спасибо автору. Теперь пользуюсь только ей
37. Виктор (Luca) 08.02.12 02:19
Объясните тупому, как эту обработку заполучить? При попытке скачать - выдаёт кучу способов оплаты. В том числе предлагается купить в магазине. Но в магазине обнаружить её не получается.
38. Олег Нестеров (nestorpetrovi4) 13.02.12 17:56
Отличная обработка, автору +++ , немногое переделал :
1.После обработки элемента справочника являющегося подчиненным другому справочнику ("Договоры контрагентов"), была необходимость выбирать его владельца ("Контрагента"), устанавливаю в форме выбора активную строку являющуюся владельцем предыдущих данных. На мой взгляд удобно ))))
39. Сергей Старых (tormozit) 19.02.12 02:35
В подсистеме Инструменты разработчика в мощном инструменте "Поиск дублей и замена ссылок" были заимствованы некоторые идеи из этой обработки. Спасибо.
40. hamsar hamsar (hamsar) 19.02.12 02:41
Спасибо за обработку буду пользоваться.
41. Эстер Коган (e.kogan) 20.02.12 13:09
43. Геннадий Пиганов (Totoro) 21.07.12 01:16
(0) Жаль поздно обнаружил, уже свою почти аналогичную сделал. Плюс однозначно.
Единственное замечание по (7) - я заменял значение вида расчета только если его уже не было в табличной части, иначе просто удалял строку с заменяемым значением. Чтобы не возникало лишних дублей.
Сделал выгрузку заменяемых значений в табличный документ (чтобы потом в КД использовать как таблицу соответствий). И при выгрузке/загрузке заменяемых значений из табличного документа использовал уникальные идентификаторы.
44. Arthur Gambler (Release) 31.07.12 15:30
Добавлю и я плюс. Хотя, лично для меня, есть некоторые недоработки:
1. Нужно бы деактивировать кнопку "Выполнить замену значений", если таблица "ссылок" (нижняя) пуста (иначе вылазит ошибка) или если происходили какие либо изменения в таблице "замен" (верхней).
2. Хотелось бы, видеть список движений содержащих искомые ссылки. Опционально, т.к. увеличит время поиска.
Но, думаю, это я доделаю сам. Спасибо.
45. Эстер Коган (e.kogan) 31.07.12 16:07
(44) А вроде делала уже п.1... Насчёт движений - при полном комментировании оно вроде отображается, где меняют.
Прикрепленные файлы:
ПоискИЗаменаЗначений_Расширенная.epf
46. Вадим Янчук (vadimlp77) 30.08.13 02:08
Не работает (ошибка выполнения) если измерение регистра бухгалтерии не балансовое - ищет по "Измерение1" (например), а нужно "Измерение1Дт" и "Измерение1Кт". Для себя исправил - работает.
47. Николай Глаголев (NickOmskiy2) 21.05.15 11:41
ошибка :
{Форма.Форма.Форма(221)}: Ошибка при вызове метода контекста (Найти)
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
по причине:
Неверное имя колонки

1С:Предприятие 8.3 (8.3.5.1517)
Бухгалтерия государственного учреждения, редакция 1.0 (1.0.33.8)
48. Эстер Коган (e.kogan) 21.05.15 16:53
(47) NickOmskiy2, под 8.3 не тестила даже. Может не взлететь ввиду разницы платформ.
49. Ник Скворцов (Tohohoro) 08.06.16 08:18
(18) e.kogan, Добрый день! Извините за глупый вопрос, но каким образом можно сохранить макет как epf? Заранее спасибо!
Прикрепленные файлы:
50. Эстер Коган (e.kogan) 13.06.16 19:40
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа