gifts2017

Быстрое копирование настроек пользователей в типовых конфигурациях

Опубликовал Эстер Коган (e.kogan) в раздел Администрирование - Защита, права, пароли

Обработка помогает автоматизировать копирование настроек пользователей как новым пользователям, так и существующим. Работать должна во всех типовых конфигурациях, которые выпущены по 1С:Предприятие 8.1
Исходная обработка: http://infostart.ru/projects/3231/
Так как автор исходника не отзывается на вопрос, куда скинуть доработанную, выкладываю отдельно. Отличие от исходника: возможность создания пользователя ИБ, интерактивная работа с копируемыми настройками.

Вариант использования №1: Создание нового пользователя с готовыми настройками

Часто нужно добавить нового пользователя в базу и присвоить ему такие же настройки, какие присвоены его коллеге. Но беда в том, что при вводе пользователя копированием его настройки не копируются.

С помощью этой обработки вы вводите краткое и полное имя нового пользователя и выбираете пользователя, у которого уже установлены нужные настройки. Обработка автоматически предлагает также создать пользователя ИБ, скопировав также и роли и настройки пользователя-образца. Можно создать только пользователя или пользователя ИБ. Все настройки можно установить вручную.

Вариант использования №2: Установка настроек одновременно нескольким пользователям

Нужно у нескольких (или всех) пользователей поменять некоторые (все) настройки. Достаточно установить эти настройки у одного пользователя, выбрать его как эталонного. Указать список настроек, которые надо скопировать и список пользователей, которым надо копировать эти настройки.

Примечание: обработка не трогает настройку «Основной ответственный» - считаю, что там всегда должен стоять сам пользователь.

 

29.07.09 - немного переработан блок управления настройками пользователя (изначально был взят из Бух 8.1, на сегодня проверен для ЗУП 8.1)

01.09.09 - добавлен отбор пользователей при выборе образца для прав ИБ, спасибо limg.

02.12.09 - добавлена сокращённая версия для клонирования пользователей ИБ и БД с настройками и группами пользователей. Должна работать в любой типовой 8.1 (БП, ЗУП, УТ, УПП).

08.02.10 - установлена "защита от дурака" при копировании настроек пользователей. При снятом отборе на пользователей, которым будут установлены настройки выбранного, переспрашивает подтверждения.

Скачать файлы

Наименование Файл Версия Размер
Полная версия 459
.epf 33,11Kb
10.02.10
459
.epf 33,11Kb Скачать
Сокращённая версия 14
.epf 20,32Kb
02.12.09
14
.epf 20,32Kb Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение
Комментарии
1. Артур Аюханов (artbear) 28.07.09 15:41
(0) Не понятно, в чем отличие от исходной версии?
2. Эстер Коган (e.kogan) 28.07.09 15:43
(1) Поправила анонс. Отличие от исходника: возможность создания пользователя ИБ, интерактивная работа с копируемыми настройками.
3. Сергей Ожерельев (Поручик) 28.07.09 20:11
плюс поставил, хоть и обжёгся с ней. предложение автору: сделать вывод вопроса о начале процесса копирования настроек. у себя пофиксил, после того, как обжёгся.
4. marta (rostova.it@gmail.com) 29.07.09 08:32
{Форма.Форма(222)}: Поле объекта не обнаружено (ТекущаяСтраницаПанелиФункций)
Если ДанныеСтроки.Настройка = ПланыВидовХарактеристик.НастройкиПользователей.ТекущаяСтраницаПанелиФункций Тогда
5. marta (rostova.it@gmail.com) 29.07.09 08:33
{Форма.Форма(623)}: Поле объекта не обнаружено (УчетПоВсемОрганизациям)
Если Запись.Настройка = ПланыВидовХарактеристик.НастройкиПользователей.УчетПоВсемОрганизациям Тогда
6. Алексей Заболотнов (z-alexey) 29.07.09 09:53
>Так как автор исходника не отзывается на вопрос, куда скинуть доработанную, выкладываю отдельно.

Все претензии к авторам сайта Инфостарт.ру, которые отключили уведомления на почту о том, что в личном ящике новое сообщение. Отправил ответ еще неделю назад :)
7. Эстер Коган (e.kogan) 29.07.09 10:23
(6) Самое интересное, что переписку я проверяла вроде регулярно. В таком случае забирайте отсюда и выкладывайте, а эту я грохну. Предложения по дальнейшей доработке в таком случае - к вам )
8. Эстер Коган (e.kogan) 29.07.09 10:28
(4,5) А у вас какая конфигурация?
9. Алексей Заболотнов (z-alexey) 29.07.09 10:29
(7) Да пусть остается. Доделали - получите благодарность от пользователей.
10. Эстер Коган (e.kogan) 29.07.09 11:36
11. marta (rostova.it@gmail.com) 30.07.09 09:22
(5) так и не изменилось. При нажатии кнопки создать пользователя при копировании настроек
12. marta (rostova.it@gmail.com) 30.07.09 09:23
При добавлении нового пользователя копированием настроек с уже имеющегося
13. Эстер Коган (e.kogan) 03.08.09 10:06
(12) А, поняла. Сейчас проверю.
14. Sergey (limg) 21.08.09 13:48
Хорошо бы на закладке "Добавление нового пользователя", в закладке "Настройки прав пользователя ИБ" при выборе значения в поле "Скопировать настройки пользователя ИБ:" (элемент ПользовательИБ) при выборе показывать только тех пользователей, для которых заведены пользователи информационной базы, например, так:

Процедура ПользовательИБНачалоВыбора(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;

Справ = Справочники.Пользователи;
Выб = Справ.Выбрать();
лСписокОтбора = Новый СписокЗначений;
Пока Выб.Следующий() Цикл
Если Не Выб.ЭтоГруппа Тогда
Попытка
лПользовательИБ = ПользователиИнформационнойБазы.НайтиПоИмени(СокрЛП(Выб.Код));
Исключение
лПользовательИБ = Неопределено;
КонецПопытки;
Если лПользовательИБ <> Неопределено Тогда
лСписокОтбора.Добавить(Выб.Ссылка);
КонецЕсли;
КонецЕсли;
КонецЦикла;
ФормаВыбора = Справ.ПолучитьФормуВыбора(, Элемент);
ФормаВыбора.ПараметрВыборГруппИЭлементов = Элемент.ВыборГруппИЭлементов;
Если лСписокОтбора.Количество() > 0 Тогда
ФормаВыбора.СправочникСписок.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
ФормаВыбора.СправочникСписок.Отбор.Ссылка.Значение = лСписокОтбора;
ФормаВыбора.СправочникСписок.Отбор.Ссылка.Использование = Истина;
ФормаВыбора.ЭлементыФормы.СправочникСписок.НастройкаОтбора.Ссылка.Доступность = Ложь;
КонецЕсли;

ФормаВыбора.ПараметрТекущаяСтрока = Элемент.Значение;

ФормаВыбора.Открыть();

КонецПроцедуры
sergio199; e.kogan; susorov; +3 Ответить 1
15. Эстер Коган (e.kogan) 01.09.09 11:06
(14) Спасибо за идею, добавила.
16. Алексей Козаченко (borman) 12.01.10 09:23
Отличная и полезная вещь. Автору респект и уважуха (ну и плюсик само сабой :)!
17. Александр Крынецкий (echo77) 01.02.10 20:45
неплохо бы было оптимизировать запись набором записей - так было бы быстрее
18. Яков Коган (Yashazz) 04.02.10 12:22
Внимание!!!!
Ни в коем случае не пользуйтесь "Копированием настроек", оно работает ошибочно и уродует базу!!!
19. Михаил Ражиков (tango) 04.02.10 12:43
настройки пользователя полезно удалять
20. Александр Крынецкий (echo77) 06.02.10 20:00
21. Эстер Коган (e.kogan) 08.02.10 10:10
(20) Я таких случаев при корректно установленных отборах не замечала.
22. Виталий Глазунов (Altez) 10.02.10 15:02
УТ 10.3.8.9
{Форма.Форма(488,3)}: Переменная не определена (ДополнительныйРАТ)
<<?>>ДополнительныйРАТ.КопироватьОтбор(ПостроительПользователи,рПроверка);
23. Эстер Коган (e.kogan) 10.02.10 16:28
(22) Упс. Прошу прощения, в течение пяти-десяти минут появится нормальная.
24. Виталий Глазунов (Altez) 07.03.10 00:32
(23)
В который раз Мерси Как хочется весною
сменить тропу пожухлых желто-красных книг
На мимолетный взгляд бросаемый Тобою
С суровой аватарки на нелепый стих
25. Anny (tit) 14.03.10 06:54
На обработку http://infostart.ru/public/18755/ стоит комменарий: Редкостная дрянь. При групповом копировании настроек и неустановленном отборе на пользователя ничего не спрашивая, гробит настройки всех пользователей. Вдобавок уродует рассчитанность итогов и сносит ещё какие-то настройки в базе. Прервать обработку невозможно. После её применения - как после Хиросимы.


потом извенения и ссылка на эту обработку как на причину. Я ей пользовалась и в одной из баз проблемы - хотелось бы выяснить из-за нее ли.

26. Петр Сусоров (susorov) 14.08.11 15:49
Спасибо автору, отличная обработка.
Просьба: добавить копирование Дополнительных Прав Пользователя
27. Сергей Сергеев (Рамзес) 01.09.11 16:01
При копировании настроек в таблице "Отбор пользователей..." выбрал пользователя, но все равно предупреждение, что отбор не установлен. А также ошибка: "Ошибка при копировании отбора Пользователь, {ВнешняяОбработка.КопированиеНастроекПользователя.МодульОбъекта(31)}: Ошибка при вызове метода контекста (Добавить): Недопустимое значение параметра (параметр номер '1')"
28. Ю М (mtv:)) 18.09.11 10:40
(0) Обработка полезная, спасибо.
А вот для конфигураций УПП 1.3 и КА 1.1 возможно полезна будет эта доработка.
29. Владимир Насыров (Spacer) 26.09.11 14:27
У меня ошибка такая же как в (27) пробовал на УПП 1.3 для Украины.
Теперь даже как-то стремно использовать. Боюсь как бы чего не послетало.
30. Эстер Коган (e.kogan) 26.09.11 14:47
(27), (29) - возможно, с момента выпуска этой версии обработки в новых конфигурациях что-то поменялось. Лично я тестировала только на БП 1.6 и ЗУП 2.5. Попробуйте версию из (28).
31. Эстер Коган (e.kogan) 26.09.11 14:48
(27), (29) - возможно, с момента выпуска этой версии обработки в новых конфигурациях что-то поменялось. Лично я тестировала только на БП 1.6 и ЗУП 2.5. Попробуйте версию из (28).
32. stas chernyatiev (gromkolaet) 01.12.11 12:18
Хооршо бы добавить в обработку возможность группового подбора списка пользователей, которым необходимо назначить одинаковые настройки пользователям. я немного переделал эту обработку, позволяющую сделать это. кому надо могу выложить. А так очень спасибо. иначе просто невозможно каждому сотруднику из сотни настраивать его пользовалки
33. Des Blyum (desblyum) 09.11.12 12:38
Благодарю. попробовал на 8.1 УТ 10.3 вполне корректно и главное быстро заводится новые пользователи.
34. Евгений Смольняков (Wizard82) 09.11.12 14:37
35. dima_gsv (dima_gsv) 19.03.13 13:09
У меня ошибка такая же как и в (27). Появляется, видимо, из-за того что запускал на платформе 8.2.
Не очень понятно назначение следующего кода, являющегося причиной возникновения ошибки:
рПроверка=Новый ПостроительЗапроса;
мКопироватьОтбор(ПостроительПользователи,рПроверка);
Отказ=(рПроверка.Отбор.Количество()=0);

Я этот код у себя закомментировал.
36. Эстер Коган (e.kogan) 19.03.13 13:14
(35) dima_gsv, всё может быть, я эту обработку сто лет не трогала :)
37. Виталий Быков (sick_russian) 22.10.13 05:29
Копирует ли обработка группы пользователя и дополнительные права помимо настроек?
38. Эстер Коган (e.kogan) 22.10.13 10:36
(37) sick_russian, там даже на скриншоте показано, что да.