gifts2017

Преобразование синонима в имя

Опубликовал Женя Мохин (mevgenym) в раздел Обработки - Универсальные обработки

Стыкует несколько слов в одно, с удалением разделителей.

Удобно при массовом создании новых объектов по какой нибудь спецификации в ворде.

Скачать файлы

Наименование Файл Версия Размер
- 18
.1249023816 6,52Kb
25.09.09
18
.1249023816 6,52Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Котэ Пруидзе (kote) 31.07.09 16:12
Что то не пойму, как этим пользоваться. Можно поподробнее?
2. Женя Мохин (mevgenym) 31.07.09 17:49
) Кнопок мало? Чтобы узнать как, для этого надо попользоваться.
3. kolpak_mp3 26.11.09 08:40
Можно использовать просто функцией:

Функция ПреобразоватьСинонимВИмя(пСиноним)
     
     Если НЕ ЗначениеЗаполнено(пСиноним) Тогда Возврат ""; КонецЕсли;
     
     НачалоСлова = Истина;
     пИмя = "";
     
     Для Индекс = 1 По СтрДлина(пСиноним) Цикл
          
          ТекСимвол = Сред(пСиноним, Индекс, 1);
          
          Если Найти(" (),.;:?""=«»•o	¶\/*-+&#@!", ТекСимвол) Тогда
               НачалоСлова = Истина;
               ТекСимвол = "";
          ИначеЕсли НачалоСлова Тогда
               ТекСимвол = ВРег(ТекСимвол);
               НачалоСлова = Ложь;
          Иначе
               
          КонецЕсли;
          
          пИмя = пИмя + ТекСимвол;
          
     КонецЦикла;
     
     Возврат СтрЗаменить(пИмя, "№", "N"); 
     
 КонецФункции
...Показать Скрыть
Патриот; +1 Ответить