gifts2017

Контроль изменения "Даты запрета редактирования", блокировка

Опубликовал Дмитрий Литовченко (kompas-dm) в раздел Администрирование - Защита, права, пароли

Кто менял "дату запрета редактирования"?

Иногда бывают такие скандалы - мало не покажется...

Молча зашел, сделал задним числом и нет валюты баланса за прошлые периоды.

Конечно, решений этого вопроса много. Я сделал так.

Внешний отчет спрашивает пароль и фиксирует изменения даты: когда, кто, что было, что стало.

 

Пароль придумать самому.

// Глобальный модуль
// ======================================
Процедура ПриЗаписиКонстанты(ИмяКонстанты,Значение)
    Если ИмяКонстанты="НомерРелиза" Тогда
      ...
    ИначеЕсли ИмяКонстанты="ДатаЗапретаРедактирования" Тогда 
            Было= константа.ДатаЗапретаРедактирования; 
              // константа.КаталогРегОтчетов - строка с  каталогом, где лежит "ключ". Можно любой...
            Файл_ = сокрлп(константа.КаталогРегОтчетов)+"key.txt";  
            Если ФС.СуществуетФайл(Файл_)=1 Тогда  
                Текст_ = СоздатьОбъект("Текст");
                Текст_.Открыть(Файл_);
                Стр_ключ = сокрлп(Текст_.ПолучитьСтроку(1));  
                Если пустоезначение(Стр_ключ)=0 тогда
                предупреждение("У Вас нет прав изменять дату запрета редактирования ! "+разделительстрок+"Для выхода нажмите ",5);     
                СтатусВозврата(0);
                конецесли;    
            КонецЕсли;  
    КонецЕсли;   
КонецПроцедуры

Вот и все.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Блокировка.rar
.1249199289 7,76Kb
25.09.09
42
.1249199289 7,76Kb 42 Бесплатно

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа