gifts2017

ВоркингТейбл ... или а-ля РабочийСтол …

Опубликовал Александр Шишкин (Шёпот теней) в раздел Программирование - Работа с интерфейсом

Конечно же, это не «РабочийСтол» в его обычном понимании. Но избавиться от повседневности помогает. Для меня вся его ценность заключается в том, что часто используемые или тестируемые внешние обработки можно закрепить за кнопками рабочего стола, а  не искать их по просторам дискового пространства.

Для автоматической загрузки «цепляется» к процедуре 1С типа «ПриНачалеРаботыСистемы».


Вызов меню «Настройка» осуществляется через правую клавишу мыши. Кнопки «Панели» устанавливаются через конфигуратор.

 

Хотелось штатными средствами сделать «а-ля Рабочий стол» а именно:

  1. "Картинка" во весь экран ... (надоедает "пустое" поле 1С ...)
  2. "на форме" кнопки часто используемых и тестируемых ВНЕШНИХ (по отношению к 1С) обработок ...


... всЁ остальное прекрасно делают панели самой 1С ...

Поэтому предлагается рассматривать данную обработку не как повторение идей "РабочийСтол-ВиндоУса" а кАК создание "Доски Информации" для пользователей 1С ...

 

 ... для вЕрсии "Организация" - как идея - хорошо прикрутить:

  1. дни рождения сотрудников
  2. телефонный спрАвочник
  3. ссылки на сайт организации

добавочно:

  1. календарь
  2. часы
  3. ссылки на сайты
  4. погода
  5. ...

отсюда "вытекает" её основное преимущество - централизованное использование на всех ПК пользователей 1С ...

 

   ... ЗА дополнения, конструктивную критику, сообщения о замеченных неточностях или ошибках - буду благодарен ...

Желающих продолжить работу над данным проектом прошу присоединяться. 

 с Уважением Шёпот теней …

… вОт …

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
-
.1250849123 107,09Kb
25.09.09
117
.1250849123 107,09Kb 117 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Епрст (Ёпрст) 21.08.09 14:23
Было же недавно ?
В чем улучшение ?...
2. Александр Шишкин (Шёпот теней) 21.08.09 14:26
... всЕгда ... ВСЁ... что-то было недавно ...

... совершенной разные подходы к организации "рабочего стола" ...

... "здесь" - попытка за счЁт штатных средств ...

... вОт ...
3. Евгений Люлюк (Evg-Lylyk) 21.08.09 14:56
Сделайте скрины нормальные ничего не видно
4. Александр Шишкин (Шёпот теней) 21.08.09 15:01
(3) ... честно говоря там и смотреть нечего ...

... большая картинка, 9 маленьких картинок и формаНастройки ...

... сейчас попробую ...

.. вОт ...
5. Александр Шишкин (Шёпот теней) 21.08.09 15:10
(3) ... ПЕРЕделал ... вОт ...
6. Евгений Люлюк (Evg-Lylyk) 21.08.09 15:29
(4) ну тогда бы и не делал
(5) теперь получше :)

Попробовал :((( жесть вообще ничего не понятно как добавлять и что можно что нельзя.На каких конфах будет работать. Я пробовал на конфе примеры 8.1 там нету например РегистрыСведений.КонтактнаяИнформация.
Я так понял можно добавлять только внешние отчеты обработки причем в фиксированные места на РС т.е. я программист должен через конфигуратор все делать.
Зачем в архиве читальщик XML? (просто для примера)

если честно пока правдо смотреть не на что... таже история что и с читальщиком XML видимо 9 кнопок достаточно и код соответствующий.
Я помоему вам писал ну должно быть чтонить уникальное что есть только в сабже иначе лучше его удалить чтобы люди на него не тратили время

Плюс поставил мне не жалко, но обработка
НиОчЁМ... вОт... ;)
7. Александр Шишкин (Шёпот теней) 21.08.09 15:39
8. Александр Шишкин (Шёпот теней) 21.08.09 15:44
(6) ... просто ВЫ сравниваете с: http://infostart.ru/projects/5232/

... кто ЖЖЖ спорит ...

... для меня это разные вещи ... и Я не люблю "пАнели" .. но "+" вАм пОставил ... мнеНЕжалко ...

... вОт ...
9. Артур Аюханов (artbear) 21.08.09 16:03
Рабочим столом пользоваться неудобно, что в Винде, что в данной обработке :(
приходится юзать очень-очень малое число обработок/программ, иначе становиться очень неудобно пользоваться
Минус.
10. Епрст (Ёпрст) 21.08.09 16:03
Я сравниваю с
http://infostart.ru/projects/5466/
например... и в (1) имелось ввиду именно это..
11. Александр Шишкин (Шёпот теней) 21.08.09 16:10
повторюсь ...
1. хотелось штатными средствами сделать а-ля ... т.е. какая-нибудь "Картинка" во весь экран ... (надоедать "пустое" поле 1С ...)
2. кнопки часто используемых и тестируемых обработок ...

... всЁ остальное прерасно делают панели самой 1С ...

... вОт ...
12. Андрей Скляров (coder1cv8) 21.08.09 16:18
Линейка с количеством символов понравилась! ха-ха, надо взять на заметку )
Правда она врет, по моему?... )
13. Александр Шишкин (Шёпот теней) 21.08.09 16:27
(12) ... конЕчно врЁт ... врЁт но примерно +- 2...3 симвОла
... ширина символов-то разная...

... ))) ...

... вОт ...
14. Александр Шишкин (Шёпот теней) 21.08.09 16:49
... для вЕрсии "Организация" - хорошо прикрутить:

обязательно:
1. дни рождения сотрудников (не для ЗУП)
2. телефонный спрАвочник
3. ссылки на сайт организации

добавочно:
3. календарь
4. часы
5. ссылки на сайты
6. погода
7. ...

... чЕм и зАймусь на дОсуге ...

... вОт ...
15. Алексей Мутовкин (mrWatson) 21.08.09 16:56
16. Александр Шишкин (Шёпот теней) 21.08.09 16:57
(15) ... я состою в почЁтном клубе "опенсорс" .. ))) всегДАопенсорс ... вОт ...
17. Сергей (Che) Коцюра (CheBurator) 21.08.09 18:51
мдя... скатываемся в украшательство.. без ценных идей... но право на существование - имеет..
18. Игорь <...> (I_G_O_R) 21.08.09 20:37
чо за херня!!! а где перетаскивание??????
19. Игорь <...> (I_G_O_R) 21.08.09 20:43
При клике:
Файл не найден ... Проверьте путь и имя файла ...


{Форма.ФормаНастроек(64)}: Поле объекта не обнаружено (ФизическоеЛицо)
ЭлементыФормы.поле_Картинка.Картинка = БиблиотекаКартинок.ФизическоеЛицо;


еще и глюков полно...

количество ярлыков ограничено...

бред полный... минус


20. Александр Шишкин (Шёпот теней) 21.08.09 20:51
(19) ... ну а как вы прикажите обрабытывать ситуацию отсутствия файла ...? по "ярлыку" он есть а по факту его нЕт ... вОт вАм и пишут: Файл не найден ... Проверьте путь и имя файла ... люой вИндУУУс вАм так напишет ...

... про "БиблиотекаКартинок.ФизическоеЛицо;" - и сОвсем всЁ понятно ...

...

(18) ... ну ВЫ это .. рЕализУёте а я посмОтрю ...



21. Александр Шишкин (Шёпот теней) 21.08.09 20:53
(17) ... а какие "ценные идеи" дОлжны присутствовАт ь... ?

... вся "ценная" идея описана в "описание" - 1. картинка. 2. используемые обработки на столе (путь - всегда под рукой) ...
22. Александр Шишкин (Шёпот теней) 21.08.09 20:56
... ещЁ рАз пишу для ВСЕХ: - А-ЛЯ "рабочий стол" ... нАзовите его "жалкой" ПОДделкой ...

.... я сдЕлал то, что мне нУжно было ... мне нрАвится и мне удОбно .... (см. описание, после слов "идея:" ...

... кому-то понравится и хОрОшО ...

... ВОТ ...
23. Игорь <...> (I_G_O_R) 21.08.09 21:09
24. DAVID (СССР) 21.08.09 21:19
(23) ты чегой то разорался тут (18) еще дети не спят.
25. Игорь <...> (I_G_O_R) 21.08.09 21:19
(20) читальщик_ХМЛ_файлов_ред5 док 02.epf не открывается в пустой конфиге т.к. там обнаружены ошибки, а пишет: Файл не найден ... Проверьте путь и имя файла ...
вводит в заблуждение...

... ВОТ ...
26. Игорь <...> (I_G_O_R) 21.08.09 21:38
(24) так это сайт для детей??? чтож вы сразу не сказали...
27. DAVID (СССР) 21.08.09 21:43
(26) а женщины и девушки - тоже не в счет ?
28. Игорь <...> (I_G_O_R) 21.08.09 21:45
(27) в счет конечно, просто эмоции, не сдержался, ожидал гораздо бОООООльшего
29. Игорь <...> (I_G_O_R) 21.08.09 21:47
все таки перетаскивание можно было и сделать, если даже не знаете как сделать чтоб работало мышкой, можно хотя бы координаты в настройках
30. Евгений Люлюк (Evg-Lylyk) 21.08.09 21:56
(8) Когда написано рабочий стол я вспоминаю рабочий стол Windows и какие в нем есть функции. Про "плюс" писал чтобы подчеркнуть негодование :(
(12) да интересно... было бы красивее если картинкой (шрифт можно поставить растровый чтоб не врала)
31. Игорь Исхаков (Ish_2) 21.08.09 22:32
(18) Осуждаю. Дельную идею , можно и без крика.

Шепот , а ведь правда .
В свойствах формы два флажка РазрешитьПеретаскивание и РазрешитьНачалоПеретаскивания. Есть четыре (кажется) события на перетаскивание.
Может и получится.
Раз люди просют - может попробуешь ?
32. larissa builova (larisab) 22.08.09 07:33
33. Александр Шишкин (Шёпот теней) 22.08.09 10:42
(23) ...


идея:

хотелось штатными средствами сделать «а-ля» а именно:
1. "Картинка" во весь экран ... (надоедаеть "пустое" поле 1С ...)
2. «на форме» кнопки часто используемых и тестируемых ВНЕШНИХ (по отношению к 1С)обработок ...

... всЁ остальное прекрасно делают панели самой 1С ...

.... основное слово : "ШТАТНЫМИ СРЕДСТВАМИ" ...

... ВОТ ...
34. Александр Шишкин (Шёпот теней) 22.08.09 10:47
(31) ... "перетаскивание" - это "НЕтаскание" картинки по экрану .... это ЗАтаскивание в нЁЁ ...

.. ВОТ ...
35. Александр Шишкин (Шёпот теней) 22.08.09 11:01
сколько у вас "картинок" на рабочем соле ...?

лично у меня 12 ... а пользуюсь 3 -4 ... и ЭТО на столе виндоУоса ...

здесь - задача совершенно другая - что я и написал в "Описании" ...

при всех НЕдостатках сравнения с "общеПрнятымРабочимСтолом" - у этой обработки есть дополнительные преимущества, например: всЁ что описано в "Дополнительных идеях" ... + можно прицепить дополнительную информацию не обходимую в работе бухгалтеров, различного рода новости, обЪявления, справочники и т.д. и т.п.

...

п.с. пока констатируется только "формальные" признаки похожести/НЕпохожести на "РабочийСтолВиндуса" ... Лично меня "похожесть" и не волнует - она, обработка, должны выполнять мною ЗАдумАнное ...

ЕЁ главное достоинство - облегчить мне жизнь, жизнь моего предприятия разве НЕ этим озабочены всЕ наши рАзработки ...(сделал пробную версию "Организация" - пока замечаний нЕт - потому, что пользователи не ассоциируют ЭТО с "РабочимСтолом" - это скорее "Доска Информации") -

...

если данная разработка поможет ещЁ ком-нибудь - буду рад ... или натолкнЁт кого-нибудь на дополнения или новые идеи - вОООбще отлично ....


... ВОТ ...
36. Игорь Исхаков (Ish_2) 22.08.09 14:44
37. Игорь <...> (I_G_O_R) 22.08.09 19:08
(33) даю подсказку: в событии Ярлыка(то есть "ПолеКартинки", кот. мы перетаскиваем) "НачалоПеретаскивания" рисуем вокруг невидимые картинки 8 штук с событием "ПроверкаПеретаскивания", в котором присваиваем новые координаты нашему Ярлыку. А в событии Ярлыка "ОкончаниеПеретаскивания" удаляем все картинки. Вот такая идея использовалась в выше указаном рабочем столе. Если бы вы заметили, то ярлыки передвигаются строго по сетке, иначе никак штатными средствами. много картинок программно не нарисуешь, 1С-ка слишком медленно с графикой работает.

Вот код формы обработки, чтоб работало нужно у формы добавить событие "При открытии" и потом скопировать весь этот код и вставить в форму:

========================= начало ===========================
Перем ПеремещаемаяКартинка;

/////////// Обработчики событий формы /////////////////////

Процедура ПолеПроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)

// перемещаем картинку
ПеремещаемаяКартинка.Лево = Элемент.Лево+5;
ПеремещаемаяКартинка.Верх = Элемент.Верх+5;

УдалитьВокругКартинки();
НарисоватьВокругКартинки();

КонецПроцедуры

Процедура КартинкаНажатие(Элемент)

Предупреждение("Вы нажали ярлык!");

КонецПроцедуры

Процедура КартинкаНачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)

ПеремещаемаяКартинка = Элемент;
НарисоватьВокругКартинки();

КонецПроцедуры

Процедура КартинкаОкончаниеПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)

УдалитьВокругКартинки();

КонецПроцедуры



////////// Вспом. процедуры ////////////////////////////

Процедура НарисоватьВокругКартинки()

х = ПеремещаемаяКартинка.Лево-5;
у = ПеремещаемаяКартинка.Верх-5;

НП("К1", х - 50, у - 50); НП("К2", х , у - 50); НП("К3", х + 50, у - 50);

НП("К4", х - 50, у ); НП("К5", х + 50, у );

НП("К6", х - 50, у + 50); НП("К7", х , у + 50); НП("К8", х + 50, у + 50);

КонецПроцедуры

// процедура НарисоватьПоле(Имя, х, у)
Процедура НП(Имя, х, у)

Если х>0 И у>0 И х < (Ширина - 48) И у < (Высота - 73) Тогда

Картинка = ЭлементыФормы.Добавить(Тип("ПолеКартинки"), Имя);
Картинка.Лево = х;
Картинка.Верх = у;
Картинка.Ширина = 50;
Картинка.Высота = 50;
//Картинка.Рамка = Новый Рамка(ТипРамкиЭлементаУправления.Одинарная);
Картинка.РазрешитьПеретаскивание = Истина;
Картинка.ПрозрачныйФон = Истина;
Действие = Новый Действие("ПолеПроверкаПеретаскивания");
Картинка.УстановитьДействие("ПроверкаПеретаскивания", Действие);

КонецЕсли;

КонецПроцедуры

Процедура УдалитьВокругКартинки()

Для к= 1 По 8 Цикл
Картинка = ЭлементыФормы.Найти("К" + к);
Если Не Картинка = Неопределено Тогда
ЭлементыФормы.Удалить(Картинка);
КонецЕсли;
КонецЦикла;

КонецПроцедуры

Процедура Перерисовать()

Картинка = ЭлементыФормы.Добавить(Тип("ПолеКартинки"), "Картинка1");
Картинка.Лево = 8+5;
Картинка.Верх = 33+5;
Картинка.Ширина = 40;
Картинка.Высота = 40;
//Картинка.Рамка = Новый Рамка(ТипРамкиЭлементаУправления.Одинарная);
Картинка.РазрешитьНачалоПеретаскивания = Истина;
Картинка.Картинка = БиблиотекаКартинок.ДокументОбъект;
Картинка.Гиперссылка = Истина;
Действие = Новый Действие("КартинкаНачалоПеретаскивания");
Картинка.УстановитьДействие("НачалоПеретаскивания", Действие);
Действие = Новый Действие("КартинкаОкончаниеПеретаскивания");
Картинка.УстановитьДействие("ОкончаниеПеретаскивания", Действие);
Действие = Новый Действие("КартинкаНажатие");
Картинка.УстановитьДействие("Нажатие", Действие);

Картинка = ЭлементыФормы.Добавить(Тип("ПолеКартинки"), "Картинка2");
Картинка.Лево = 8+5+50;
Картинка.Верх = 33+5+100;
Картинка.Ширина = 40;
Картинка.Высота = 40;
//Картинка.Рамка = Новый Рамка(ТипРамкиЭлементаУправления.Одинарная);
Картинка.РазрешитьНачалоПеретаскивания = Истина;
Картинка.Картинка = БиблиотекаКартинок.ГеографическаяСхема;
Картинка.Гиперссылка = Истина;
Действие = Новый Действие("КартинкаНачалоПеретаскивания");
Картинка.УстановитьДействие("НачалоПеретаскивания", Действие);
Действие = Новый Действие("КартинкаОкончаниеПеретаскивания");
Картинка.УстановитьДействие("ОкончаниеПеретаскивания", Действие);
Действие = Новый Действие("КартинкаНажатие");
Картинка.УстановитьДействие("Нажатие", Действие);

КонецПроцедуры

Процедура ПриОткрытии()
Перерисовать();
КонецПроцедуры

========================= начало ===========================





adun; Ish_2; Шёпот теней; +3 Ответить 2
38. Александр Шишкин (Шёпот теней) 22.08.09 19:21
(37) ... слОв нЕт ... пОздрАвляю ... !!!

... моЁ мнение: зАчем ...? зачем слепо и тупо дЕлать как у виндоУоса ... ?

п.с. ... я воооообще не помню когда я последний раз двигал "ярлыки" ...

спАсибо ! пОздравляю ! и "+" за идЕю ...

... вОт ...
39. Игорь <...> (I_G_O_R) 22.08.09 19:29
(38) это не я придумал, а http://infostart.ru/projects/5466/, но код написал сам т.к. там код был закрыт паролем

как зачем двигать??? потому что это удобно, у меня например часть ярлыков в одном углу, а часть в другом, сгруппированы так сказать по какому-то признаку
40. Игорь Исхаков (Ish_2) 22.08.09 19:29
(37) А чего ты ,Шепот , плюсиком отделываешься ?
Ты отвечай конкретно : будешь реализовывать или нет ?
41. Игорь <...> (I_G_O_R) 22.08.09 19:36
(40) да какая разница, мне кажется прикрутить действия к ярлыкам сможет практически любой программист, кому надо и так сделает, главное ИДЕЯ
42. Александр Шишкин (Шёпот теней) 22.08.09 19:49
(40) ... я уже ответил в (38) ... зАчем ...? неТЕ задачи и НЕтот фУнкционал ...

штатными срЕдствами двигать не получится - получится только на букву "г" или "ж" ... опЯть же нАйдутся товарищЬчи и всЁ "о" ...

... вОттАкмнеДумается ...
43. Александр Шишкин (Шёпот теней) 22.08.09 19:49
44. Игорь Исхаков (Ish_2) 22.08.09 19:50
45. Александр Шишкин (Шёпот теней) 22.08.09 19:53
(44) ... ПРОвоКАТор ... ))) ... прАвы все ... всё имЕЕт прАво на жизнь ...

... БОЛЬШЕмненийБОЛЬШЕидейБОЛЬШИЙвыбор ...
46. Александр Смоленский (Alex_Smolensky) 26.08.09 16:16
47. Александр Шишкин (Шёпот теней) 28.08.09 13:06
(46) ...спАсибо - Alex_Smolensky ... большое ... вот ! ...
48. Михаил Ражиков (tango) 28.08.09 13:15
расписание электричек с павелецкого еще. прикрутить
49. Михаил Ражиков (tango) 28.08.09 13:15
19.46 - хорошая электричка, до домодедова
50. Александр Шишкин (Шёпот теней) 28.08.09 14:12
(49) ... привЕт ! ... нууу... хорошо хоть только электричек ... ))) вОООт ...
51. Ярослав Радкевич (WKBAPKA) 28.08.09 16:21
как прикольно, взять чужую идею и выложить как свою ... если уж хотел усовершенствовать, то добавил бы хотя бы слои. значительно удобнее было бы работать.
52. Ярослав Радкевич (WKBAPKA) 28.08.09 16:23
(18) Осуждаю. Дельную идею , можно и без крика.

Шепот , а ведь правда .
В свойствах формы два флажка РазрешитьПеретаскивание и РазрешитьНачалоПеретаскивания. Есть четыре (кажется) события на перетаскивание.
Может и получится.
Раз люди просют - может попробуешь ?

так реализовано же перетаскивание в приводимой в качестве примера обработке :)
чужие лавры не дают покоя )
53. Ярослав Радкевич (WKBAPKA) 28.08.09 16:55
2(I_G_O_R): А идея то действительно на поверхности лежит. Я сначала не врубился в то что вы написали, немного почитл мануал и все стало понятно. Ключ в проверке перетаскивания :)
54. Ярослав Радкевич (WKBAPKA) 28.08.09 16:55
блин а так хер бы догадался )))
55. Ярослав Радкевич (WKBAPKA) 28.08.09 16:58
я вот только пока еще не нашел как они добились изменения курсора при наведении на ярлык
56. Игорь <...> (I_G_O_R) 28.08.09 17:10
57. Ярослав Радкевич (WKBAPKA) 28.08.09 17:45
когда наводишь курсор на ярлык он меняет форму с указателя на указатель в виде руки... не могу найти событие что бы отслеживать перемещение курсора мыши в 1С
58. Игорь <...> (I_G_O_R) 28.08.09 23:27
(57) у некоторых элементов управления есть свойство "Гиперссылка", так вот когда оно установлено в истина, при наведении курсор становится рукой
59. Ярослав Радкевич (WKBAPKA) 29.08.09 14:26
ептит, точно, если положить туже напдись установить свойство гиперссылка, положить поверх картинку в итоге получим вот такой результат. гениально. голь на выдумку хитра :)
61. Ярослав Радкевич (WKBAPKA) 29.08.09 14:27
у полекартинки тоже есть такое свойство :)
62. Ярослав Радкевич (WKBAPKA) 29.08.09 15:37
2(I_G_O_R): У тебя немножко наварочено определение координат. Вот мой код, используется на форме одно поле картинки которое перетаскиваем:

Процедура ПолеКартинки1НачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)
Действие = Новый Действие("ПроверкаПеретаскивания");
Элементыформы.ПолеКартинки1.УстановитьДействие("ПроверкаПеретаскивания",Действие);
Картинка = Элементыформы.Добавить(Тип("ПолеКартинки"),"ПолеКартинкиЛево");
// Картинка лево
Картинка.Лево = Элемент.Лево - Элемент.Ширина;
Картинка.Верх = Элемент.Верх;
Картинка.Ширина = Элемент.Ширина;
Картинка.Высота = Элемент.Высота;
Картинка.УстановитьДействие("ПроверкаПеретаскивания",Действие);
Картинка.РазрешитьНачалоПеретаскивания = Истина;
Картинка.РазрешитьПеретаскивание = Истина;
// Картинка верх
Картинка = Элементыформы.Добавить(Тип("ПолеКартинки"),"ПолеКартинкиВерх");
Картинка.Лево = Элемент.Лево;
Картинка.Верх = Элемент.Верх-Элемент.Высота;
Картинка.Ширина = Элемент.Ширина;
Картинка.Высота = Элемент.Высота;
Картинка.РазрешитьНачалоПеретаскивания = Истина;
Картинка.РазрешитьПеретаскивание = Истина;
Картинка.УстановитьДействие("ПроверкаПеретаскивания",Действие);
// Картинка низ
Картинка = Элементыформы.Добавить(Тип("ПолеКартинки"),"ПолеКартинкиНиз");
Картинка.Лево = Элемент.Лево;
Картинка.Верх = Элемент.Верх + Элемент.Высота;
Картинка.Ширина = Элемент.Ширина;
Картинка.Высота = Элемент.Высота;
Картинка.РазрешитьНачалоПеретаскивания = Истина;
Картинка.РазрешитьПеретаскивание = Истина;
Картинка.УстановитьДействие("ПроверкаПеретаскивания",Действие);
// Картинка право
Картинка = Элементыформы.Добавить(Тип("ПолеКартинки"),"ПолеКартинкиПраво");
Картинка.Лево = Элемент.Лево + Элемент.Ширина;
Картинка.Верх = Элемент.Верх;
Картинка.Ширина = Элемент.Ширина;
Картинка.Высота = Элемент.Высота;
Картинка.РазрешитьНачалоПеретаскивания = Истина;
Картинка.РазрешитьПеретаскивание = Истина;
Картинка.УстановитьДействие("ПроверкаПеретаскивания",Действие);
КонецПроцедуры

Процедура ПроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)
Если Элемент.Имя <> "ПолеКартинки1" Тогда
ЭлементыФормы.ПолеКартинки1.Лево = Элемент.Лево;
ЭлементыФормы.ПолеКартинки1.Верх = Элемент.Верх;
ЭлементыФормы.ПолеКартинки1.Высота = Элемент.Высота;
ЭлементыФормы.ПолеКартинки1.Ширина = Элемент.Ширина;
УдалитьКартинки();
ПолеКартинки1НачалоПеретаскивания(ЭлементыФормы.ПолеКартинки1, Неопределено,Ложь );
КонецЕсли;
КонецПроцедуры

Процедура УдалитьКартинки()
Элементыформы.Удалить(ЭлементыФормы["ПолеКартинкиЛево"]);
Элементыформы.Удалить(ЭлементыФормы["ПолеКартинкиПраво"]);
Элементыформы.Удалить(ЭлементыФормы["ПолеКартинкиВерх"]);
Элементыформы.Удалить(ЭлементыФормы["ПолеКартинкиНиз"]);
КонецПроцедуры

Процедура ПолеКартинки1ОкончаниеПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)
УдалитьКартинки();
КонецПроцедуры

63. Ярослав Радкевич (WKBAPKA) 29.08.09 15:37
использовал для простоты только 4-ре картинки. Код естественно можно сократить
64. Ярослав Радкевич (WKBAPKA) 29.08.09 23:05
кстати, так и не оценили идею относительно слоев. Есть у меня такая фича на компе как Shock 4Way 3D, очень прикольная штука. идея простая, делаем слои, количество слоев столько сколько нам нужно . один слой - документы, второй слой - справочники, 3 - отчеты, а один из слоев общий. это значително удобнее чем просто один рабочий стол. это я и хочу реалиховать в своем продукте
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа