gifts2017

Игра "Пятнадцать спичек" (разновидность игры "Ним")

Опубликовал Александр Венгер (venger) в раздел Сообщество - Игры

Правила: 15-ть спичек выкладываются в три ряда, по 3, 5, 7 спички в ряду. Противники ходят по очереди. За один ход можно взять любое количество спичек из произвольного ряда (но только из одного ряда). Тот, кто взял последнюю спичку — проиграл.
Количество спичек, которые разрешается брать, — неограниченно. Можно первым же ходом "смести" весь первый ряд, забрав из него все 7 спичек. Но нельзя, например, взять одну спичку из первого ряда и еще одну — из второго.

Взять спичку - кликом мышки. Чтобы взять, например, три спички из ряда за один ход - щелкните мышкой по третьей справа спичке в ряду.

Примечание: отчет/обработка всегда должен быть внешним.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
fifteen_matches.zip
.1251279778 16,59Kb
25.09.09
143
.1251279778 16,59Kb 143 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Alxd (salexdv) 26.08.09 13:57
В обед погонять - самое то! :) +
2. Александр Венгер (venger) 26.08.09 13:58
(0) Буду благодарен за тестирование алгоритма игры компа, писал на скорую руку, мог что-то и не учесть... Выиграть реально, если ходишь первым...
3. Юрий Тимофеев (Tatitutu) 26.08.09 14:38
чуть не убил компьютер. А чего он все время побеждает )))
(1) коротковат у тебя обед
4. Alxd (salexdv) 26.08.09 14:42
(3) Ну эт смотря как гонять :))))
5. Юрий Тимофеев (Tatitutu) 26.08.09 14:47
(4) Согласен. Не поспоришь.

" - А ты кто ?
- Говорящий пес Артемон. Гав !
- Так говорите у Вас нет коробка - боробка ?!?!!!" (с) КВН
6. Епрст (Ёпрст) 26.08.09 15:27
Да... убери ты к едрени фени Это:
"Примечание: отчет/обработка всегда должен быть внешним."

И встроенный отчет можно открывать модально.
7. Александр Венгер (venger) 26.08.09 16:10
(6) Как узнать "свое" имя во встроенном отчете/обработке? Я не в курсе просто... Подскажи, в общем, чего уж там...
8. Sergey (seven77782) 26.08.09 16:16
Все время выигрывает компьютер
9. Епрст (Ёпрст) 26.08.09 16:44
(7) Если нет ВК, то тупо прописать его в самом отчете.
А дальше проверять на Форма.МодальныйРежим()
10. Епрст (Ёпрст) 26.08.09 16:44
+9 аналогично работают все кнопки "Обновить" и "Настройка" во всех типовых отчетах - тупо передается имя отчета, как из метаданных.
11. Епрст (Ёпрст) 26.08.09 16:45
(8) я пока тоже не выиграл..
лень смотреть...
12. Епрст (Ёпрст) 26.08.09 16:45
+11 но чуствую - глобальное наипалово на всех уровнях общества :))
13. Александр Рытов (Арчибальд) 26.08.09 16:46
14. Епрст (Ёпрст) 26.08.09 16:48
15. Александр Венгер (venger) 26.08.09 16:52
(9) Вот и я к тому, что если вставили в конфу с другим именем - то привет...
16. Епрст (Ёпрст) 26.08.09 16:53
(15) ну дык с умом нужно вставлять..
17. Александр Венгер (venger) 26.08.09 17:02
(16) Со знанием, скорее:-) А кто просто чуток пользователь или админ, и особо не в курсе тонкостей 1С и конфигуратора, тому не лишне будет и написать, чтоб не парился, а тот, кто знает, тому оно не помешает.... ИМХО, конечно. Но все-равно спасибо, ибо не оскуднеет источник мастерства твоего, чтоб было всегда чему поучиться у тебя!
18. Юрий Тимофеев (Tatitutu) 26.08.09 17:16
Шурик на как вариант ))))

Процедура ПриОткрытии()
Если Форма.МодальныйРежим()=0 Тогда
Для Сч=1 По Метаданные.Отчет() Цикл
Если Прав(Метаданные.Отчет(Сч).Комментарий,6)="Венгер" Тогда
ОткрытьФормуМодально("Отчет."+Метаданные.Отчет(Сч).Идентификатор);
СтатусВозврата(0);
Прервать;
КонецЕсли;
КонецЦикла;
Для Сч=1 По Метаданные.Обработка() Цикл
Если Прав(Метаданные.Отчет(Сч).Комментарий,6)="Венгер" Тогда
ОткрытьФормуМодально("Обработка."+Метаданные.Отчет(Сч).Идентификатор);
СтатусВозврата(0);
Прервать;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецПроцедуры
19. Епрст (Ёпрст) 26.08.09 17:23
(18) И откуда Комментарий брать во внешнем отчете ?...
20. Александр Венгер (venger) 26.08.09 17:28
(18) Комментарий и синоним во внешнем не остается... Если его вставить в конфу, то комментарий будет пуст.... только что пробовал... Но юмор заценил...:-)))
21. Юрий Тимофеев (Tatitutu) 26.08.09 17:29
(19) )))) молодца - быстро мышей ловишь. Как вариант )))
22. Юрий Тимофеев (Tatitutu) 26.08.09 17:35
(6) Сань конечно у тебя самомнение - Высший класс !!!
Или на лоха расчитано.
Я бы хотел посмотреть тому в глаза, кто бы твои "спички" прикрутил бы к конфигурации ЗИК или ПУБ.Я бы ему их в глаза бы и вставил )))
23. Александр Венгер (venger) 26.08.09 20:27
(22) Грубоватая провокация:-)))) Но мож кто и клюнет:-))))
24. Александр Венгер (venger) 26.08.09 20:39
+23, или я не догнал, короче не важно, кто куда чего вставит:-)))
25. Александр Венгер (venger) 26.08.09 20:39
+24, главное наперед предусмотреть все возможные действия пользователя - это и есть мастерство:-))
26. DAVID (СССР) 26.08.09 21:08
Молодец ! А я пока "лузер"...до по следующей среды. Проект сдаю - времени нет на "игрушечки",хотя пару интересных идей есть в голове.Моего ПЕРЕВЕРТЫША осилил или несмотрел даже ?
27. Александр Венгер (venger) 26.08.09 21:49
(26) > Проект сдаю - времени нет на "игрушечки"

Без проблем, понятно, что время не резиновое, да и помимо работы еще куча всего есть, так что тут без напрягов.

> хотя пару интересных идей есть в голове

Как-нибудь, как появится время, в фоновом режиме, и главное желание, то будет классно, если чего еще релизуете в удовольствие.

> Моего ПЕРЕВЕРТЫША осилил или несмотрел даже ?

У меня боролись два желания (тоже из-за ограниченности по времени) - погонять в Ваши или сваять свои, вот разрываюсь надвое:-)

Да и все-равно было приятно, а победила дружба, что самое главное!
28. Алексей Иванов (Lexus) 27.08.09 17:50
я знаю другую версию, там нет разбивки по рядам и ограничения в количестве спичек.
в таком варианте чтобы выиграть надо всегда оставлять противнику количество спичек равное степени двойки за вычетом единицы, т.е. (2^2-1), (2^3-1), (2^4-1) и т.п.
29. Аркадий Кучер (Abadonna) 27.08.09 18:55
ХЗ, как работает движок? Плюс, чтобв не пакостили
30. Сергей (Che) Коцюра (CheBurator) 28.08.09 01:49
плохо.. выбор количества снимаемых спичек должен делаться выделением области мышью... низачот, короче...
31. Сергей (Che) Коцюра (CheBurator) 28.08.09 01:50
а вот еще раньше без всяких компов, на спичечных коробках была самообучаемая машина по игре в крестики-нулики...
32. Михаил Семенов (Shaman100M) 28.08.09 11:01
на пальцах можно выйграть если знать секрет
33. Александр Венгер (venger) 28.08.09 11:35
(31) Ух-ты, где бы поподробнее об этом узнать? Про такую самообучаемую машину, да еще на спичечных коробках.....
34. Александр Венгер (venger) 28.08.09 11:35
(28),(32) Можно усложнить, добавить еще ряд с 11-й спичками, т.е. 4 ряда - 3,5,7,11 и т.д. Простые числа в рядах должны быть, вроде как, т.е. 5-й ряд если добавлять, то 13 спичек и т.д. Можно поменять условие - побеждает тот, кто последний взял. В общем, как-нибудь, надо будет развить идею...
35. Михаил Семенов (Shaman100M) 28.08.09 11:43
(34) без разницы, сколько рядов, какое количество, главное, правильно выбрать, кому первым ходить.
36. Иляна Кандаурова (lilly) 12.01.12 20:41
Забавная игра))) Раньше такую не встречала)))
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа