gifts2017

1НДФЛ для 1С Бухгалтерии 7.7 (заполнить по всем сотрудникам)

Опубликовал Петр Петров (Adoms) в раздел Печать - Справки

Налоговая карточка 1НДФЛ с возможностью заполнить по всем сотрудникам
(добавлена карточка для 2010 года Форма1НДФЛ2010.ert)

Близится конец года. Ежегодно приходится тратить драгоценное рабочее время на заполнение налоговых карточек 1НДФЛ. Приходится подставлять каждого сотрудника в карточку вручную, затем нажимать кнопку «Заполнить» затем «Сохранить» в общем довольно таки муторная и однообразная процедура если сотрудников много. Попросили приходящего программиста это дело автоматизировать. Налоговая карточка сохранена как внешняя обработка и добавлена кнопка «Заполнить всех» Бухгалтерам пригодится. Программисту – спасибо! :)

1НДФЛ2009 - для реалица 7.70.507
1NDFL_old.rar - для реализов до 7.70.507

(добавлена карточка для 2010 года Форма1НДФЛ2010.ert)

Скачать файлы

Наименование Файл Версия Размер
Форма1НДФЛ2010.ert 106
.ert 404,50Kb
30.08.14
106
.ert 404,50Kb Скачать
1НДФЛ2009.rar 201
.1251872870 52,52Kb
30.08.14
201
.1251872870 52,52Kb Скачать
1NDFL_old.rar 93
.1251885348 51,53Kb
30.08.14
93
.1251885348 51,53Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Изергин (serguson) 02.09.09 11:49
? Отчет "Подготовка сведений для ИФНС" после этого формируется?
2. Петр Петров (Adoms) 02.09.09 11:52
(1) да, конечно, ведь карточки все получаются заполненными и сохраненными, в коде ничего не менялось, просто добавили дополнительную кнопочку, чтобы убрать рутину
3. Дониэла Иванова (Доня) 02.09.09 12:26
Очень хорошо.
Уточните - что для ЗиК
для Бух она не открывается
4. Эдуард (samadurov) 02.09.09 12:26
(3) В Бухе очень даже открывается и прекрасно работает!!!
5. анка (анфиска) 02.09.09 13:44
Не работает нив бухе ни в ЗиК
6. анка (анфиска) 02.09.09 13:46
В Бух пишет "ВычетыСотрудниковПоНДФЛ = СоздатьОбъект("Справочник.ВычетыСотрудниковПоНДФЛ");
{C:\DOCUMENTS AND SETTINGS\N2\РАБОЧИЙ СТОЛ\ОБРАБОТКИ\1НДФЛ2009 ПО ВСЕМ СОТРУДНИКАМ\1НДФЛ2009.ERT(3562)}: Неудачная попытка создания объекта (Справочник.ВычетыСотрудниковПоНДФЛ)", а в Зик- "Буфер.Установить("Название","Налоговая карточка по учету доходов и налога на доходы физических лиц за "+Год+" год № "+глПреобразоватьНомерДок<<?>>(ФизЛицо.Код, 0, 0));
{C:\DOCUMENTS AND SETTINGS\N2\РАБОЧИЙ СТОЛ\ОБРАБОТКИ\1НДФЛ2009 ПО ВСЕМ СОТРУДНИКАМ\1НДФЛ2009.ERT(1586)}: Функция не обнаружена (глПреобразоватьНомерДок)
Буфер.Установить("Название","Налоговая карточка по учету доходов и налога на доходы физических лиц за "+Год+" год № "+глПреобразоватьНомерДок(ФизЛицо.Код, 0, 0)<<?>>);
{C:\DOCUMENTS AND SETTINGS\N2\РАБОЧИЙ СТОЛ\ОБРАБОТКИ\1НДФЛ2009 ПО ВСЕМ СОТРУДНИКАМ\1НДФЛ2009.ERT(1586)}: Неопознанный оператор
Буфер.Установить("Название","Налоговая карточка по учету доходов и налога на доходы физических лиц за "+Год+" год № "+глПреобразоватьНомерДок(ФизЛицо.Код, 0, 0))<<?>>;
{C:\DOCUMENTS AND SETTINGS\N2\РАБОЧИЙ СТОЛ\ОБРАБОТКИ\1НДФЛ2009 ПО ВСЕМ СОТРУДНИКАМ\1НДФЛ2009.ERT(1586)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (ПриВводеСуммИзменяющихСальдо)"
7. Петр Петров (Adoms) 02.09.09 13:49
(6) У Вас не обновлена конфигурация, загрузите последнее обновление бухгалтерии, реализ 7.70.507
В этом обновлении кардинально пересмотрена процедура предоставления вычетов
8. Петр Петров (Adoms) 02.09.09 13:51
(3)Доня, тоже пожалуйста обновите, так как всеравно придется это делать в конце года и все заработает. Обработка для не для ЗиК а для Бухгалтерии
9. Петр Петров (Adoms) 02.09.09 13:57
Для необновленных конфигураций добавил файл 1NDFL_old.rar
10. Инга (ЛюблюТебя) 02.09.09 16:55
почему то не ставится налог исчисленный, только удержанный указывается, релиз у меня последний.
11. Петр Петров (Adoms) 02.09.09 22:27
(10) Спасибо, что заметили, все поправил, скачайте пож. еще раз
12. Елена Кукушкина (KEVE) 03.09.09 19:33
Пока + за идею. Дальнейший + или - будет когда посмотрю
13. Елена Кукушкина (KEVE) 03.09.09 19:57
Теперь + окончательный.Работает. Быстро.Бухгалтера в начале года будут очень рады, ведь это огромная экономия их времени. Проверила на отчетах в ПФ и ИМНС. Цифири в отчетах и бухгалтерии совпадают без погрешностей.
Спасибо.
14. Петр Петров (Adoms) 04.09.09 09:47
(13) Спасибо большое! а то другие скачивают, а плюсофф не ставят... жадины :)))
15. Инга (ЛюблюТебя) 04.09.09 10:00
(11) теперь все работает :). Спасибо.
16. алена вас (zoriki) 10.09.09 09:17
Все работает красиво. Я стараюсь проверять ндфл каждый месяц, а обработка значительно сокращает время:) Спасибо.
17. Айрат (Craig) 14.09.09 12:00
Безусловно "+" Я еще в 2006 году написал такую же обработку. Но, что-то не догадался тут выложить((( А еще как вариант – можно сделать привязку к закрытию месяца.
Марита Х; +1 Ответить 2
18. Марита бух (Марита Х) 20.09.09 12:10
все отлично, (17) присоединяюсь было бы класно связать с начислением налогов по ФОТ в закрытии месяца
19. Петр Петров (Adoms) 21.09.09 10:03
(17) (18) Конечно можно привязать к «Закрытию месяца» но тогда конфигурация получится измененная, и при каждом обновлении нужно будет документ «Закрытие месяца» корректировать вручную.
Если же все-таки изменение конфигурации для Вас не критично, то в модуль документа «Закрытие месяца» нужно вставить строку:

ОткрытьФорму("Отчет",,КаталогИБ()+"ExtForms\1НДФЛ2009.ert")

А в саму обработку 1НДФЛ2009.ert в конец процедуры ПриОткрытии() вставить следующий код:

Сотр=СоздатьОбъект("Справочник.Сотрудники");
Сотр.ВыбратьЭлементы();
ном=0;
Пока Сотр.ПолучитьЭлемент()=1 Цикл
Если Сотр.ЭтоГруппа()=1 Тогда
Продолжить;
КонецЕсли;
Если Сотр.ПометкаУдаления()=1 Тогда
Продолжить;
КонецЕсли;
ном=ном+1;
Сообщить("-------------------------------------------------");
Сообщить(""+ном+": Обрабатывается ->"+Сотр.ТекущийЭлемент()+" Таб. номер:"+Сотр.ТекущийЭлемент().Код);
ФизЛицо=Сотр.ТекущийЭлемент();
ПриВыбореСотрудника();
Заполнить();
Сохранить();
КонецЦикла;

И все будет заполнятся автоматически в момент закрытия месяца
20. Сергей Х (immaxi) 20.02.10 08:31
Нужная вещь :)
Тоже самое но для УСН смотрите здесь http://infostart.ru/public/65904/
21. син (син) 26.02.10 20:23
Еще бы добавить печать всех карточек, группой или по выбранным сотрудникам :)
22. И С (irishen) 10.01.12 09:39
"Обработка для не для ЗиК а для Бухгалтерии." Скажите, пожалуйста, где найти такую для конфигурации 1с 7.7 зарплата и кадры?
23. Vetal Vetal (Vetal85) 07.02.12 12:29
Налоговая карточка 1-НДФЛ. Почему то сумма за класность задваивается. Смотрю в ячейке Сумма дохода и там в строке "По данным введенным вручную" откуда-то сумма за классность. откуда она там? и как сделать чтобы она туда не попадала?
24. Vetal Vetal (Vetal85) 07.02.12 12:30
поставьте им техзадание... уж проще и нельзя поставить... всё разжёвано...

1. карточка 1-НДФЛ остаётся в том же виде, что и раньше
2. по щелчку по ячейке месяца идёт подённая расшифровка месяца в виде:
дата регистрации ... дата действия... код дохода ... сумма дохода ...
почему важна дата действия? да потому, что необходимо фиксировать неизбежные исправления ошибок в закрытых периодах...
3. по щелчку по ячейке итога идёт подённая расшифровка всего года... это важно
4. аналогично расшифровается НДФЛ_удержанный подённо по датам выплаты дохода из доков выплат... здесь же возврат НДФЛ по исправлению ошибок в закрытых периодах...
------
с 1-НДФЛ всё...

5. отдельный сборный налоговый регистр по всей фирме на основании 3. и 4. карточек 1-НДФЛ
дата регистрации ... дата действия ... НДФЛ_исчисленный ... НДФЛ_удержанный ... НДФЛ_перечисленный
перечисленный НДФЛ берётся из нового дока регистрации платёжных поручений по перечислению НДФЛ в бюджет

6. теперь по карточке 2-НДФЛ
на любую дату выдачи справки или же на дату годовой отчётности в ИФНС из налогового регистра 5. всегда известен коэффициент К = Мин(1,НДФЛ_перечисленный_Итого/НДФЛ_удержанный_Итого)

тот новый грустный пункт 5.5 в 2-НДФЛ о перечисленном налоге за сотра авторассчитывается напрямую при формировании карточки как К * НДФЛ_удержанный (п.5.4)
25. Vetal Vetal (Vetal85) 07.02.12 12:33
Раздел3НК.Область(Имя).Текст = ?(ТипЗначения(Зн)=1,Формат(Зн,"Ч015.2."),Зн);
{\\NDFL1.ERT(301)}: Значение не представляет агрегатный объект (Текст)
а обработка полезная.
26. Vetal Vetal (Vetal85) 07.02.12 12:33
В Бух пишет "ВычетыСотрудниковПоНДФЛ = СоздатьОбъект("Справочник.ВычетыСотрудниковПоНДФЛ");
{C:\DOCUMENTS AND SETTINGS\N2\РАБОЧИЙ СТОЛ\ОБРАБОТКИ\1НДФЛ2009 ПО ВСЕМ СОТРУДНИКАМ\1НДФЛ2009.ERT(3562)}: Неудачная попытка создания объекта (Справочник.ВычетыСотрудниковПоНДФЛ)", а в Зик- "Буфер.Установить("Название","Налоговая карточка по учету доходов и налога на доходы физических лиц за "+Год+" год № "+глПреобразоватьНомерДок<<?>>(ФизЛицо.Код, 0, 0));
{C:\DOCUMENTS AND SETTINGS\N2\РАБОЧИЙ СТОЛ\ОБРАБОТКИ\1НДФЛ2009 ПО ВСЕМ СОТРУДНИКАМ\1НДФЛ2009.ERT(1586)}: Функция не обнаружена (глПреобразоватьНомерДок)
Буфер.Установить("Название","Налоговая карточка по учету доходов и налога на доходы физических лиц за "+Год+" год № "+глПреобразоватьНомерДок(ФизЛицо.Код, 0, 0)<<?>>);
{C:\DOCUMENTS AND SETTINGS\N2\РАБОЧИЙ СТОЛ\ОБРАБОТКИ\1НДФЛ2009 ПО ВСЕМ СОТРУДНИКАМ\1НДФЛ2009.ERT(1586)}: Неопознанный оператор
Буфер.Установить("Название","Налоговая карточка по учету доходов и налога на доходы физических лиц за "+Год+" год № "+глПреобразоватьНомерДок(ФизЛицо.Код, 0, 0))<<?>>;
{C:\DOCUMENTS AND SETTINGS\N2\РАБОЧИЙ СТОЛ\ОБРАБОТКИ\1НДФЛ2009 ПО ВСЕМ СОТРУДНИКАМ\1НДФЛ2009.ERT(1586)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (ПриВводеСуммИзменяющихСальдо)"
27. Петр Петров (Adoms) 07.02.12 13:32
Vetal85, здравствуйте.
Обработка была актуальна в 2009-2010, сейчас видимо 1С переделало в корне конфу, и вот такие ошибки выдает.... я не проверял н наверное так и есть. Попробуйте поступить так: сохранить нужную обработку заполнения карточек из Вашей конфы, в виде внешнего файла, вставте туда кнопку, а к кнопке прикрепите код, описанный в посте № 19, может заработает... Больше никаких изменений я в стандартную обработку не вносил, кроме как добавленного кода (п.19)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа