gifts2017

Журнал кассовых операций, форма КО-3

Опубликовал Михаил Сысоев (Ghost171184) в раздел Отчеты - Бухгалтерские

Отчет "Журнал кассовых операций, форма КО-3" с разделением по подразделениям.

Посмотрел на сайте несколько таких Отчетов, но все они были не доработанными.
Поэтому предлагаю свой отчет "Журнал кассовых операций, форма КО-3" с разделением по подразделениям.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Изменённая КО-3
.ert 61,50Kb
09.11.09
98
.ert 61,50Kb 98 Скачать
-
.1253693821 61,00Kb
09.11.09
42
.1253693821 61,00Kb 42 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр Рытов (Арчибальд) 23.09.09 13:13
... были недоработанными.
В чем?
Вот http://infostart.ru/projects/260/ Автор - Мастер. Объясните, в чем Вы его превзошли?
2. Михаил Сысоев (Ghost171184) 23.09.09 13:30
У него есть один недочет. Формирование идет отдельными списками ПКО и РКО без разбивки по дням. Я добавил его отчет и сформировал, все нормально, но на контроле в банке сказали это грубая ошибка. Поэтому переделал отчет с разбивкой по дням.
P.S. А по поводу контроля того отчета - может так и должно быть а в банке просто докопались, а может и должна быть разбивка списка первички по дням, а не отдельными списками.
3. Александр Рытов (Арчибальд) 23.09.09 13:38
(2) Будь эта информация в описании, разве я приставал бы? Теперь ясно.
4. Михаил Сысоев (Ghost171184) 23.09.09 13:40
Просто я первый раз выкладываю файлы. На будущее учту. Большое СПАСИБО.
5. kalitwa kalitwa (kalitwa) 30.09.09 10:02
6. Петр Петров (Adoms) 30.09.09 10:46
да, действительно не работает :( пишет приходных кас.ор. - ноль, расходных - ноль
7. Ден (lion11) 09.10.09 08:12
А для 8-ки не планируется?
8. Михаил Сысоев (Ghost171184) 09.11.09 12:17
Проверенно, у меня в 4 отделениях и в центральном офисе работает
9. Михаил Сысоев (Ghost171184) 09.11.09 12:17
10. Михаил Сысоев (Ghost171184) 09.11.09 13:15
В цикле "Пока Запрос.Группировка(1) = 1 Цикл " после строки "Док = Запрос.Документы;" добавить следующее:
Если Метаданные.РазделительУчета.Выбран() = 1 Тогда
Если ПоВсемРУ=0 Тогда
Если Лев(Строка(Док.НомерДок),1)<>ПрИБ Тогда
Продолжить;
КонецЕсли;
КонецЕсли;
КонецЕсли;
И в начале добавить переменную "ПрИБ"
11. Вячеслав (kras) 12.03.10 11:49
А чего так позорно сделана группировка по дням... :evil:
Запрос выполняется в цикле!!!

перепиши запрос:
...
|Период с ВыбНачПериода по ВыбКонПериода;
|ОбрабатыватьДокументы Проведенные;
|
|Документы = Документ.ПриходныйОрдер.ТекущийДокумент,
| Документ.ПриходныйОрдерТорг.ТекущийДокумент,
| Документ.РасходныйОрдер.ТекущийДокумент,
| Документ.РасходныйОрдерТорг.ТекущийДокумент;
|ДатаДок = Документ.ПриходныйОрдер.ДатаДок,
| Документ.ПриходныйОрдерТорг.ДатаДок,
| Документ.РасходныйОрдер.ДатаДок,
| Документ.РасходныйОрдерТорг.ДатаДок;
|
|Группировка ДатаДок;
|Группировка Документы упорядочить по Документы.НомерДок;
...

И циклы маленько поменяй, вместо
...
Пока перДатаНач <= ВыбКонПериода Цикл
Запрос.Выполнить(ТекстЗапроса);
Пока Запрос.Группировка(1) = 1 Цикл
...
напиши
...
Пока Запрос.Группировка(1) = 1 Цикл

Пока Запрос.Группировка(2) = 1 Цикл
...
Ghost171184; +1 Ответить
12. Михаил Сысоев (Ghost171184) 16.03.10 06:58
Возможно это и выглядит позорно, но сделано по необходимости.
Согласен, что запрос выполняется быстрее и меньше кода используется, но это дополнительная нагрузка на сервак, т.к. все запросы выполняются на нём. Вот как поменяю серверную машину, так доработаю не позорно.
13. Вячеслав (kras) 17.03.10 06:47
Михаил, Вы ничего не перепутали? ;) Или может я чего-то не понимаю.

Формирую ваш отчет за квартал, делаю замер производительности вашего отчета, время выполнения 17 секунд, при этом запрос вызывается 92 раза!!!
Не это ли называется дополнительной нагрузкой на сервак?

Тебе код нужно изменить всего то в двух местах, поменять запрос и оператор первого цикла. Это займет времени меньше, чем время за которое ты писал предыдущее сообщение. При этом отчет, за тот-же период, теперь формируется за 0,2 секунды, в 85 раз быстрее!!!! На два порядка быстрее, задумайтесь!!!

Запрос выполняется 1 раз, и это вместо 92, чем не подмога вашему многострадальному серверу?
14. Елена Кукушкина (KEVE) 13.05.10 18:49
не увидела смысла в этой обработке. За многолетний период не один банк не потребовал для проверки такого журнала. Если уж хочется проявить себя в кассовой дисциплине, то ещё ни разу не видела обработки для спецрежимников "кассовая книга" на одном листе по дням (как вкладной лист или лист кассира), ведь в стандартной обработке тратится много бумаги. Для "малышей" это накладно.
15. Михаил Сысоев (Ghost171184) 03.06.10 06:35
Кассиры просто обленились, писать не желают.
16. 4103 (Soikalv) 15.07.12 19:03
С нового года проверять будет не банк, а налоговая. И уж они-то, наверняка придерутся - отсутствие регистров учета и пр.
17. Дониэла Иванова (Доня) 17.02.16 13:51
Скачала, но долго открывается
Спасибо!
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа