gifts2017

Расчетно-платежная ведомость 0504401 для ЗКБУ 8.2

Опубликовал Игорь Зуйков (quares) в раздел Отчеты - Бухгалтерские

Многим бюджетникам необходима именно форма 0504401. Она реализована в этом отчете.

За основу взят скаченный с инфостарта отчет (http://infostart.ru/public/177482/).

В чем разница?

Разница в том, что данный отчет содержит шапку и подписи, как того требует 401я форма, а так же начисления и удержания разбиты по фунцианальным блокам, как того требует та же 401я форма.

В начале номер, должность, а фио и поле для подписи в конце.

Организация по которой будет формироваться отчет, в самой форме отчета не указывается. Так как бюджетники, как правило, ведут в одной базе одно учреждение, то организация подтягивается из настроек пользователя - организация по умолчанию. Если не указана, то отчет будет ругаться на это.

Шапка отчета и подвал (подписи) "рисуются в коде" - данный отчет может послужить наглядным пособием как работать с табличным документом через код.

В поле "Роспись в получении" по умолчанию стоит "перечислено" - так было задумано мной (21й век всё таки - зп идет на карточки). Если необходимо то можно изменить в коде.

В подписи отчета, в поле "Составил" подтягивается значение указанное в регистре сведений - ответственные лица - роль "Исполнитель". В шапке стандартно - "Руководитель" и "Главный бухгалтер".

Поле "Заработная плата" в блоке "итого удержано" - это ведомости с видом выплаты "Плановый аванс".

Поле "Межрасчетная выплата" в блоке "итого удержано" - это не "Плановый аванс" и документы (Касса, банк) дата выплаты которых (дата завершения выплаты) не равна концу месяца за который происходит выплата. Например: Документ "Зарплата к выплате" выплачивает зарплату за январь 2013 года, а ведомость в банк, созданная на основании этого документа, имеет дату завершения выплаты раньше чем последний день января. Т.е. 30.01.2013 и ранее. Все выплаты которые "итоговые" (дата завершения - последний день месяца) попадут в последнюю колонку "Сумма к выдаче".

В данной форме нет отдельных полей для больничного листа и дней сколько оплачено - это нарочно так :-)

Скачать файлы

Наименование Файл Версия Размер
Расчетно платежная ведомость 0504401 198
.erf 24,46Kb
11.11.13
198
.erf 1 24,46Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Игорь Паршиков (igorscorp77) 04.11.13 20:37
Вопрос актуальный. Мой клиент пользуется доработанным вариантом этого отчёта.
1. Почему не включил больничные?
2. Как происходит сортировка по табельному номеру?
3. Шапка выводится на каждой странице?
ВадимЛитовченко; makas; +2 Ответить
2. Игорь Зуйков (quares) 05.11.13 10:35
1) Не было необходимости (задачи) включать их отдельно. Можно доработать - это пара часов труда при желании.
2) Сортировка происходит банально ТЗ.Сортировать("ФизЛицо"); (модуль объекта:1213)
3) Да, на каждой. Итоги выводятся постранично + общие итоги на последнем листе. Если листов всего 1, то строк итогов будет две 1й итог по странице 2й итог по ведомости.
ВадимЛитовченко; +1 Ответить
3. Игорь Зуйков (quares) 05.11.13 14:51
Исправил ошибку: не проставлялся номер строки.
4. Антон Назаров (crypton) 09.11.13 09:18
{ВнешнийОтчет.РасчетнаяВедомость.МодульОбъекта(813)}: Ошибка при вызове метода контекста (ПроверитьВывод)
Если Не Таб.ПроверитьВывод(ВыводимыеОбласти) Тогда

В чем может быть дело ?
ВадимЛитовченко; +1 Ответить 1
5. Игорь Зуйков (quares) 11.11.13 12:42
(4) crypton,

Если посмотреть синтаксис этого метода (ПроверитьВывод) то увидим следующее:

ТабличныйДокумент (SpreadsheetDocument)
ПроверитьВывод (CheckPut)
Синтаксис:

ПроверитьВывод(<Таблицы>)
Параметры:

<Таблицы> (обязательный)

Тип: Массив; ТабличныйДокумент.
Массив из проверяемых таблиц или табличный документ.
Возвращаемое значение:

Тип: Булево.
Истина - умещаются; Ложь - в противном случае.
Описание:

Проверяет, умещаются ли переданные табличные документы на страницу при печати.

Доступность:

Сервер, толстый клиент, внешнее соединение.
Примечание:

При возникновении проблем с получением информации о текущем принтере (например, в системе не установлено ни одного принтера), будет вызвано исключение.
Пример:

Т.Добавить(ШапкаДокумента);
Т.Добавить(СтрокаДокумента);
Т.Добавить(ПодвалДокумента);
Если Не ТабДок.ПроверитьВывод(Т) Тогда
Сообщить("Документ не умещается на страницу!");
КонецЕсли;

Мои выводы: в системе не установлено ни одного принтера
Варианты обхода ошибки:
1) Добавить в систему информацию о принтере.

2) Скачать исправленную версию отчета.

3) Внести изменения в коде. Модуль объекта строка 812 (найти вот этот блок):
Если Не Таб.ПроверитьВывод(ВыводимыеОбласти) Тогда
ВывестиИтоги(Истина); // итоги по странице
ВывестиОтветственныеЛица();
Таб.ВывестиГоризонтальныйРазделительСтраниц();
ВывестиШапкуТаблицы();
КонецЕсли;
И сделать следующее:
Попытка
Если Не Таб.ПроверитьВывод(ВыводимыеОбласти) Тогда
ВывестиИтоги(Истина); // итоги по странице
ВывестиОтветственныеЛица();
Таб.ВывестиГоризонтальныйРазделительСтраниц();
ВывестиШапкуТаблицы();
КонецЕсли;
Исключение
Сообщить ("Возникли проблемы с получением информации о текущем принтере (например, в системе не установлено ни одного принтера).");
КонецПопытки;
6. Антон Назаров (crypton) 11.11.13 17:58
(5)Спасибо большое за очень развернутый ответ !
7. Игорь Зуйков (quares) 11.11.13 19:46
(6) crypton, Пожалуйста. Если будут вопросы - всегда рад ответить.
8. Алексей (AlexGS) 06.02.14 15:05
Отличная ведомость. Если бы были еще больничные - просто супер.
9. Игорь Зуйков (quares) 11.02.14 10:23
(8) AlexGS, Спасибо за высокую оценку.
Будет свободное время - добавлю галочку на форму "Отображать больничные" :-)
10. Алексей (AlexGS) 17.02.14 07:21
Да не за что, ведомость нужная. Больничные ждемс )))
11. Nata (Nata) 24.06.14 12:25
Ведомость очень нужная.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа