gifts2017

Установка ведения договоров по документам расчетов

Опубликовал Марк Воронов (yam) в раздел Обработки - Обработка документов

Обработка позволяет перейти на ведение взаиморасчетов по договорам по документам расчетов с контрагентами. Это может потребоваться, если нужно отслеживать дату оплаты или просроченную дебиторку.

 Если вы решили отслеживать даты оплаты, просроченную дебиторку, или переходите с конфигураций на 77 на УТ 10, пользуясь типовыми правилами переноса, то это обработка может быть вам полезна. 

Обработка выполняет 2 функции:

  1. Устанавливает реквзит справочника Договоры контрагенты "Вести по документам расчетов с контрагентом" в значение Истина. Поскольку в конфигурации уже будут документы, есть нюанс с изменением этого реквизита - при записи включаются проверки на наличие документов по договорам. Обойти это можно с помощью установки свойства ОбменДанными.Загрузка  = Истина.
  2. Заполняет табличную часть документов взаиморасчетов документами расчета. Обрабатывает документы: ПКО, РКО, платежные поручения, корректировка долга, РТиУ, ПТиУ, поступление доп. расходов, возврат товаров от покупателя, возврат товаров поставщику.

Обработка использует типовые механизмы заполнения, которые иногда работают некорректно. Поэтому, прийдется внести изменения в общий модуль УправлениеДенежнымиСредствами, в процедуру  ЗаполнитьРасшифровкуПлатежей(СтруктураПараметров).

Вместо кода

Если СтруктураПараметровАвто.Свойство("ОтборПоДоговорам") Тогда

   ОбработкаОбъект.ПостроительОтбораДоговоров.УстановитьНастройки(СтруктураПараметровАвто.ОтборПоДоговорам, Истина, Ложь, Ложь, Ложь, Ложь);

КонецЕсли;

 нужно вставить 

Если СтруктураПараметровАвто.Свойство("ОтборПоДоговорам") Тогда
      Если СтруктураПараметров.Интерактивно Тогда
           ОбработкаОбъект.ПостроительОтбораДоговоров.УстановитьНастройки(СтруктураПараметровАвто.ОтборПоДоговорам, Истина, Ложь, Ложь, Ложь, Ложь);
      Иначе
           ЭлементОтбора = ОбработкаОбъект.ПостроительОтбораДоговоров.Отбор.Добавить("ДоговорКонтрагента",, "ДоговорКонтрагента"); //мае 
           ЭлементОтбора.ВидСравнения = ВидСравнения.Равно;
           ЭлементОтбора.Значение = СтруктураПараметровАвто.ОтборПоДоговорам;
           ЭлементОтбора.Использование = Истина;
      КонецЕсли;
КонецЕсли;

 Затем, нужно изменить обработку ПодборПараметровРасшифровкиПлатежа.

В функцию ПолучитьДоговорПоУмолчанию() нужно вставить следующие строки в самом начале

       Отбор = ПостроительОтбораДоговоров.Отбор;
       Если Отбор.Количество() > 0 И Отбор[0].имя = "ДоговорКонтрагента" Тогда
              ДоговорПоУмолчанию = Отбор[0].Значение;
              Возврат ДоговорПоУмолчанию; 
       КонецЕсли;:

Реквизит Организация на форме не фильтрует организацию, а заполняет аналогичено поле в договорах, если оно вдруг пустое.

 

 


 

 

 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
УстановкаРасчетовПоДокументам.epf
.epf 11,10Kb
15.11.13
3
.epf 11,10Kb 3 Скачать
УстановкаРасчетовПоДокументам.epf
.epf 11,10Kb
15.11.13
13
.epf 11,10Kb 13 Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа