gifts2017

Предопределенные варианты отчетов в УТ 11

Опубликовал Юрий Слободянюк (mechanic80) в раздел Программирование - Инструментарий

Пару строк кода для обновления данных предопределенных вариантов отчетов

Конфигурация УТ 11, версия 11.1.2. Создал новый отчет в конфигурации, в ходе тестирования наставил своих настроек и группировок. После такого "Тестирования" естественно хочется сбросить настройки или выбрать вариант отчета по умолчанию. Я в варианты отчетов, а их нет. На форумах в ответах нашел код: ВариантыОтчетов.ОбработкаПредопределенныхВариантов(), и советы по обновлению версии конфигурации, тогда варианты обновляются. В текущей версии УТ нет такой процедуры, а обновление мне не подходит, но зачем обновлять версию конфигурации, попробую ка я найти нужный код который выполняется при обновлении.

Обработку не создавал, вот собственно код:

    Параметры = Новый Структура;
   
Параметры.Вставить("МонопольныйРежим", Истина);
   
Параметры.Вставить("РазделенныеОбработчики", ОбновлениеИнформационнойБазы.НоваяТаблицаОбработчиковОбновления());
   
ВариантыОтчетов.ОбновитьОбщиеДанные(Параметры);

   
Параметры = Новый Структура;
   
Параметры.Вставить("МонопольныйРежим", Истина);
   
ВариантыОтчетов.ОбновитьРазделенныеДанные(Параметры);

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Ожерельев (Поручик) 10.12.13 17:23
Запомним на будущее, чтобы не ломать голову.
2. Александр Савостин (savostin.alex) 11.12.13 18:06
Работает только на УФ+БСП:

Модуль менеджера отчета:

Процедура НастройкиОтчета(Настройки) Экспорт
	ВариантыОтчетов.УстановитьОписаниеВариантаВДопНастройках(Настройки, "Основной", "Анализ возвратов");
КонецПроцедуры


Плюс общая команда:

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
	//Вставить содержимое обработчика.
	//ПараметрыФормы = Новый Структура("", );
	//ОткрытьФорму("ОбщаяФорма.", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно);
	ВыполнитьЗаполнение();
КонецПроцедуры

&наСервере
Процедура ВыполнитьЗаполнение()
	
	ВариантыОтчетов.ОбработкаПредопределенныхВариантов();
	
КонецПроцедуры
...Показать Скрыть
3. Dmitry The Wing (wing) 20.02.14 07:18
(2) savostin.alex, Как уже говорилось в самой статье:
В текущей версии УТ нет такой процедуры
, точнее процедур...

Спасибо автору темы, однако в версии УТ 11.1.4.10 помогает уже другой код:
	Перем ЕстьИзменения, ЕстьУдаленные, ЕстьКритичныеИзменения, ТребуетсяОбновитьКэш, СписокКритичныхИзменений;
	Справочники.ИдентификаторыОбъектовМетаданных.ВыполнитьОбновлениеДанных(ЕстьИзменения, ЕстьУдаленные, Ложь, ЕстьКритичныеИзменения, ТребуетсяОбновитьКэш, СписокКритичныхИзменений);
	
	Параметры = Новый Структура;
    Параметры.Вставить("МонопольныйРежим", Истина);
    Параметры.Вставить("РазделенныеОбработчики", ОбновлениеИнформационнойБазы.НоваяТаблицаОбработчиковОбновления());
	ВариантыОтчетов.ОбновитьОбщиеДанные(Параметры);
    ВариантыОтчетов.ОбновитьРазделенныеДанные();
...Показать Скрыть
4. aQuarius (n0ther) 11.07.15 15:44
Спасибо, очень помогло. Для БСП 2.1.3.50 работает
5. Антон Ворон (ptica-voron) 23.07.15 10:38
Мне в УТ 11.1.10.138 помог код:

&НаСервере
Процедура ОбновитьВариантыОтчетовНаСервере()
	Перем ЕстьИзменения, ЕстьУдаленные, ЕстьКритичныеИзменения, ТребуетсяОбновитьКэш, СписокКритичныхИзменений;
	ЕстьИзменения = Истина;
	ЕстьУдаленные = Ложь;
	
	Справочники.ИдентификаторыОбъектовМетаданных.ОбновитьДанныеСправочника(ЕстьИзменения, ЕстьУдаленные);
	
	Парам = Новый Структура;
	Парам.Вставить("МонопольныйРежим", Истина);
	Парам.Вставить("РазделенныеОбработчики", ОбновлениеИнформационнойБазы.НоваяТаблицаОбработчиковОбновления());
	ВариантыОтчетов.ОбновитьОбщиеДанные(Парам);
	ВариантыОтчетов.ОбновитьРазделенныеДанные();
	
КонецПроцедуры

&НаКлиенте
Процедура ОбновитьВариантыОтчетов(Команда)
	ОбновитьВариантыОтчетовНаСервере();
	
	Сообщение = Новый СообщениеПользователю();
    Сообщение.Текст = "Варианты отчетов обновлены";
    Сообщение.Сообщить();
КонецПроцедуры
...Показать Скрыть
6. Александр Прилуцкий (Alex13185) 07.10.16 15:15
Спасибо, помогло!!!
Правда в моем случае не отображались родные отчеты в настройках
В УТ 11.2.3.189 Помог код:
ВариантыОтчетов.ОперативноеОбновлениеРазделенныхДанныхКонфигурации();
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа