gifts2017

Как закрыть надоедливые окна, открывающиеся при старте

Опубликовал Ийон Тихий (cool.vlad4) в раздел Программирование - Работа с интерфейсом

По мотивам http://forum.infostart.ru/forum26/topic99217/  . Закрываем окно ПереходНаРедакцию30 в Бухгалтерии 2.0 при старте.

По мотивам http://forum.infostart.ru/forum26/topic99217/ . Ничего особенного и секретного в публикации нет, так, что старожилам советую дальше не читать, не имеет смысла. А суть в следующем - при запуске конфигураций часто запускаются всякие окна. Да мы можем их один раз посмотреть. Но что делать если запускаем программу в 1000 раз? В частности дело касается последних релизов 1С Бухгалтерия 2.0 . Создаем обработку. Например teststart.epf . создадим в ней основную форму и обработчик для нее Перед Открытием:

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
	Попытка
        Ф = Обработки.ПереходНаРедакцию30.ПолучитьФорму();
	Если Ф.Открыта() Тогда
		Ф.Закрыть();
	КонецЕсли;
	Ф = Обработки.ДополнительнаяИнформация.ПолучитьФорму("Форма");
	Если Ф.Открыта() Тогда
		Ф.Закрыть();
	КонецЕсли;
        Исключение
	
        КонецПопытки;
       Отказ = Истина;
КонецПроцедуры

А дальше пропишем в параметрах запуска /Execute "C:\teststart.epf" (ну или вместо C:\ путь, где находится обработка) Да пустячок, но сэкономит нервы, порой так необходимые. И конфигурацию не пришлось менять. 

Скачать файлы

Наименование Файл Версия Размер
teststart.epf 50
.epf 5,97Kb
20.12.13
50
.epf 5,97Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Макас (makas) 20.12.13 15:19
2. Артем Артеменко (dock) 20.12.13 18:10
огромный плюс за примечание
И конфигурацию не пришлось менять.
3. Александр Лыткин (TrinitronOTV) 20.12.13 20:33
вот это здорово, как теперь стало нормально работать с бухгалтерией
4. Юрий Осипов (yuraos) 20.12.13 20:39
Плюс за смекалку и
приверженность к "простым радостям жизни"!
5. Юрий Осипов (yuraos) 20.12.13 20:43
(4)
а как бы ее нам при старте из справочника "ВнешниеОбработки" запустить?
...
а то хранить ее где-то на диске ... отдельно от базы
одним словом - не удобняк
6. Владимир Лагутин (Lukich66) 21.12.13 17:41
Без использования Формы и +отключить Интернет-поддержку в модуле обработки:
//сообщить("Василий Алибабаевич");
Попытка
Ф = Обработки.ПереходНаРедакцию30.ПолучитьФорму();
Если Ф.Открыта() Тогда
Ф.Закрыть();
КонецЕсли;
Ф = Обработки.ДополнительнаяИнформация.ПолучитьФорму("Форма");
Если Ф.Открыта() Тогда
Ф.Закрыть();
КонецЕсли;
Исключение

КонецПопытки;
ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь);
ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь);
MasterTonLab; it-on; AzagTot; playoffer; Andy83; +5 Ответить
7. Анянов Михаил (insurgut) 24.12.13 12:55
(5) yuraos, в конфигурации 1 строчку закомментируйте при начале работы системы - будет "удобняк" безо всяких обработок :)
8. Виталий Мжачих (vitaspsp) 24.12.13 14:22
По-моему если интернет-поддержку отключить, то и на 3.0 БП не предлагает переходить.
9. Анянов Михаил (insurgut) 24.12.13 14:44
(8) vitaspsp, предлагает, нет там никаких проверок на открытие этой обработки при начале работы системы.
10. Виталий Мжачих (vitaspsp) 25.12.13 05:53
проверки то нет, а вот вы попробуйте сделать как вам написал "Lukich66", последние 2 строки, или воспользуйтесь приложенной обработкой и не будет никакого окна с переходом на 3.0.
11. Анянов Михаил (insurgut) 25.12.13 07:48
(10) vitaspsp, зачем мне пробовать, если я знаю, что эти строчки не имеют никакого отношения к показу формы с информацией перехода? Без запуска одновременного обработки со строчками:

Ф = Обработки.ПереходНаРедакцию30.ПолучитьФорму(); 
Если Ф.Открыта() Тогда 
Ф.Закрыть(); 
КонецЕсли; 


...как висело окно перехода так и будет висеть. Вы хоть код на запуск этой обработки при старте БП посмотрите :)
12. Виталий Мжачих (vitaspsp) 25.12.13 10:32
(11) insurgut, Извиняюсь, туплю. Просто у меня конфигурации клиентов доработанные все, при сравнении- объединении, в модуле обычного приложения эту строку
// Открытие информации о переходе на ред. 3.0
Обработки.ПереходНаРедакцию30.ПолучитьФорму().Открыть();
пропускаю.
13. DAnry (DAnry) 26.12.13 01:33
Идея хорошая. Работаю в основном с конфигурациями "для Украины". У нас "тройка" еще не вышла. Но тема актуальна. Бухгалтера часто просят убрать самопроизвольно выползающие окна. И если конфигурация снята с поддержки то "нет проблем", но в случае невозможности изменения конфигурации, представленная обработка, конечно, выход.
15. Евгений Фалин (Gotcha) 27.01.14 15:49
А что-за проблема - обновлять конфигурацию поддержки, 1 раз на ее основе сделать свои доработки и 2 раза накатывать обновления-поддержки и свои, на конфигурацию поддержки?
16. Ийон Тихий (cool.vlad4) 27.01.14 16:52
(15) Gotcha, нет проблем. меняйте, я же вам не запрещаю, что хотите-то и делайте)))
17. Евгений Фалин (Gotcha) 27.01.14 17:15
Вынужден это делать, увы...
18. Евгений Рачковский (eugen91) 03.04.14 17:08
"при запуске конфигураций часто запускаются всякие окна."
Отличная идея, давно подобное решение уже искали.спасибо за решение!
19. Василий Пименов (dinovasya) 22.01.15 10:58
ожибка файлового при запуске вылетает