gifts2017

Быстрая настройка прав доступа в УТ 11 (а также конфигурации на БСП)

Опубликовал Юрий Слободянюк (mechanic80) в раздел Администрирование - Защита, права, пароли

Обработка предназначена для просмотра ролей доступа, профилей доступа, групп доступа объектов конфигурации в УТ 11

Совсем недавно мне нужно было настроить права доступа в конфигурации УТ 11. Опыт настройки прав подсказует, что создавать новые роли нужно только тогда, когда не найдено существующих удовлетворяющих требованиям задачи. Но если есть существующие роли, рекомендовано их использовать или же скопировать а потом править.

Исходя из сложившейся потребности создал обработку для быстрого получения информации по правам доступа для объектов конфигурации

Краткое описание интерфейса:

Можно выбирать объект метаданных 3 способами (вверху слева);

Можно использовать таблицу избранных для быстрого поиска (внизу слева) ;

Доступные роли находятся вверху справа;

Использованные профили и группы доступа для текущей выделенной роли находятся внизу справа; 

Image Hosted by PiXS.ru

Скачать файлы

Наименование Файл Версия Размер
Права объектов метаданных 134
.epf 12,78Kb
25.12.13
134
.epf 12,78Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Инженер Гарин (Гарин) 30.12.13 17:41
По правам на отчеты не работает
2. yuricslb (mechanic80) 30.12.13 19:02
Гарин(1), Для отчетов я использую поле "Строка метаданных", там пишу строку "Отчет.ИмяОтчета". Если не использовали, попробуйте
3. Инженер Гарин (Гарин) 02.01.14 14:18
(2) yuricslb, так и сделал, но вместо включенных ролей выводятся все какие есть в конфигурации
4. yuricslb (mechanic80) 08.01.14 11:58
(3) Гарин, свою ошибку нашел. У отчетов просто нету таких прав как "Чтение", "Просмотр", "Изменение", из за этого некорректная работа. В ближайшее время исправлю. Спасибо за замечание.
5. Алексей Никонов (Aristo_) 18.06.14 20:10
УТ 11.1, ошибка при открытии
Ошибка инициализации модуля: Форма.Форма.Форма
по причине:
{Форма.Форма.Форма(115,28)}: Переменная не определена (ОбщегоНазначения)
ОБъект.СтрокаМетаданных = <<?>>ОбщегоНазначения.ИмяТаблицыПоСсылке(Объект.ПустаяСсылка);
6. yuricslb (mechanic80) 19.06.14 11:30
Aristo_, у вас наверное нету общего модуля "ОбщегоНазначения". Обработка работает в конфигурациях УТ 11, Документооборот, ну то есть у всех конфигурациях на основе более-менее последних БСП. Можно было мне конечно перенести все внешние процедуры в обработку, так было бы универсальнее, но как то все никак не могу подобраться и доработать.
7. Роман Хлебородов (Romankhv7) 12.02.15 04:54
УТ 11.1, ошибка при открытии
Ошибка инициализации модуля: Форма.Форма.Форма
по причине:
{Форма.Форма.Форма(115,28)}: Переменная не определена (ОбщегоНазначения)
ОБъект.СтрокаМетаданных = <<?>>ОбщегоНазначения.ИмяТаблицыПоСсылке(Объект.ПустаяСсылка);
Та же самая беда
8. v spl (vspl) 24.02.15 22:16
ОбщегоНазначения - в последних УТ 11 - это серверный модуль, на клиенте не будет работать
Добавьте вызов из сервера

&НаКлиенте
Процедура ПустаяСсылкаПриИзменении(Элемент)
	
	//ТекущиеДанные = Элементы.ПраваДоступа.ТекущиеДанные;
	//Если ТекущиеДанные = Неопределено Тогда
	//	Возврат;
	//КонецЕсли;
	//
	//СписокТипов = Новый СписокЗначений;
	ПустаяСсылкаПриИзмененииНаСервере();
	//ОБъект.СтрокаМетаданных = ОбщегоНазначения.ИмяТаблицыПоСсылке(Объект.ПустаяСсылка);
	//Объект.ПустаяСсылка = Неопределено;
	//Объект.ПустаяСсылка = ВремПустаяСсылка;
	
КонецПроцедуры

&НаСервере
Процедура ПустаяСсылкаПриИзмененииНаСервере()
	
	//ТекущиеДанные = Элементы.ПраваДоступа.ТекущиеДанные;
	//Если ТекущиеДанные = Неопределено Тогда
	//	Возврат;
	//КонецЕсли;
	//
	//СписокТипов = Новый СписокЗначений;
	
	ОБъект.СтрокаМетаданных = ОбщегоНазначения.ИмяТаблицыПоСсылке(Объект.ПустаяСсылка);
	Объект.ПустаяСсылка = Неопределено;
	//Объект.ПустаяСсылка = ВремПустаяСсылка;
	
КонецПроцедуры
...Показать Скрыть
9. Александр Фомин (alex15650) 15.07.15 09:48
Добрый день!
При открытии обработки УТ зависает и вылетает.
10. ssn5810 (ssn5810) 25.01.16 06:41
Подскажите как сделать (где посмотреть) права ( на использование ) на доп отчеты и обработки
11. Роман Рогачев (janibeg) 24.03.16 10:03
11.2.2.106:
{Форма.Форма.Форма(115,28)}: Переменная не определена (ОбщегоНазначения)
ОБъект.СтрокаМетаданных = <<?>>ОбщегоНазначения.ИмяТаблицыПоСсылке(Объект.ПустаяСсылка);
12. Роман Рогачев (janibeg) 24.03.16 10:07
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа