gifts2017

РИБ для УНФ

Опубликовал Кирилл Ларькин (ZhAmAn) в раздел Администрирование - Распределенная БД (УРИБ, УРБД)

Штатного механизма типового полного обмена (РИБ) нет. Добавляем этот функционал. Данный способ подойдет для типового релиза УНФ начиная с версии 1.4.7.37 или для конфигураций на основе БСП.

За основу взята статья: http://infostart.ru/public/156559/

Для включения данного обмена необходимо будет добавить и изменить  следующие метаданные:

Подсистемы

 -СервисныеУслуги (изменить состав)

Общие модули 

 -ОбменДаннымиПереопределяемый (изменить типовую процедуру)

 -ОбменДаннымиПолный  

Планы обмена  

 -Полный   

Подписки на события   

 -ОбменДаннымиПолныйЗарегистрироватьИзменение   

 -ОбменДаннымиПолныйЗарегистрироватьИзменениеДокумента   

 -ОбменДаннымиПолныйЗарегистрироватьИзменениеКонстанты    

 -ОбменДаннымиПолныйЗарегистрироватьИзменениеНабораЗаписей    

 -ОбменДаннымиПолныйЗарегистрироватьУдаление   

Общие команды  

 -ВыполнитьОбменДанными    (изменить тип параметра команды)

 -НастроитьПараметрыТранспортаСообщенийОбмена (изменить тип параметра команды)   

 -ОткрытьПравилаРегистрацииОбъектов (изменить тип параметра команды)   

 -ОткрытьСценарииОбменовДанными  (изменить тип параметра команды)  

 -ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных (изменить тип параметра команды)   

 -ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных   (изменить тип параметра команды) 

 -ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы  (изменить тип параметра команды) 

Справочники   

 -ИдентификаторыОбъектовМетаданных   (закоментировать часть процедуру). 


Общее дерево изменяемых метаданных:

 

За основу для дальнейшего упрощения можно использовать УТ 11 или модули с диска ИТС и БСП. В качестве упрощения также можно взять штатные обмены с БП и оттуда взять часть процедур,заменив в них обработчики на "заглушки".

Необходимые этапы доработки конфигурации:

1. Добавляем новый ПланОбмена:Полный или копируем из УТ 11.

    Обязательно ставим галку РИБ.

2. Редактируем состав плана обмена Полный.

Включаем в состав все объекты,исключив объекты,аналоличные в УТ.(Перечислять здесь долго,в основном Константы,Справочники,остальные все объекты).

Добавляем дополнительно:

Производственные календари и все объекты,связанные с расчетными задачами.

Общие виды объектов состава:

3. Отменяем авторегистрацию у всех объектов.

4. Включаем ПланОбмена Полный в подсистему: СервисныеФункции.

5. В модуль объекта ПланОбмена Полный вставляем код:


Перем КоличествоОбъектовЗагружено;
Перем
КоличествоОбъектовВыгружено;

Процедура
ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента, СозданиеНачальногоОбраза)
 
КоличествоОбъектовВыгружено = КоличествоОбъектовВыгружено + 1;
КонецПроцедуры

Процедура
ПриОтправкеДанныхГлавному(ЭлементДанных, ОтправкаЭлемента)
 
КоличествоОбъектовВыгружено = КоличествоОбъектовВыгружено + 1;
КонецПроцедуры

Процедура
ПриПолученииДанныхОтПодчиненного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
 
КоличествоОбъектовЗагружено = КоличествоОбъектовЗагружено + 1;
КонецПроцедуры

Процедура
ПриПолученииДанныхОтГлавного(ЭлементДанных, ПолучениеЭлемента, ОтправкаНазад)
 
КоличествоОбъектовЗагружено = КоличествоОбъектовЗагружено + 1;
КонецПроцедуры

Процедура
ПередЗаписью(Отказ)
  Если
ОбменДаннымиСервер.НадоВыполнитьОбработчикПослеВыгрузкиДанных(ЭтотОбъект, Ссылка) Тогда
   
ПослеВыгрузкиДанных(Отказ);
  ИначеЕсли
ОбменДаннымиСервер.НадоВыполнитьОбработчикПослеЗагрузкиДанных(ЭтотОбъект, Ссылка) Тогда
   
ПослеЗагрузкиДанных(Отказ);
  КонецЕсли;
КонецПроцедуры

Процедура
ПослеВыгрузкиДанных(Отказ)

 
Сообщить("КоличествоОбъектовВыгружено: " + Строка(КоличествоОбъектовВыгружено));

КонецПроцедуры



Процедура
ПослеЗагрузкиДанных(Отказ)
 
Сообщить("КоличествоОбъектовЗагружено: " + Строка(КоличествоОбъектовЗагружено));
КонецПроцедуры

КоличествоОбъектовЗагружено = 0;
КоличествоОбъектовВыгружено = 0;

 6. В модуль менеджера ПланОбмена Полный вставляем код:

 Функция ПояснениеДляНастройкиПараметровУчета() Экспорт
     Возврат
"";
 КонецФункции

 Функция
ЗначенияПоУмолчаниюНаУзле(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Неопределено;
 КонецФункции

 Функция
ЗначенияПоУмолчаниюНаУзлеБазыКорреспондента(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Неопределено;
 КонецФункции

 Функция
ИмяФайлаНастроекДляПриемника() Экспорт
     Возврат
НСтр("ru = 'Настройки обмена УНФ-УНФ Полный обмен РИБ'");
 КонецФункции

 Функция
ИспользуемыеТранспортыСообщенийОбмена() Экспорт
    
Результат = Новый Массив;
    
Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FILE);
    
Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FTP);
     Возврат
Результат;
 КонецФункции

 Функция
ИмяФормыСозданияНачальногоОбраза() Экспорт
     Возврат
"ОбщаяФорма.СозданиеНачальногоОбразаСФайлами";
 КонецФункции

 Функция
ЗаголовокКомандыДляСозданияНовогоОбменаДанными() Экспорт
     Возврат
НСтр("ru = 'Создать обмен УНФ-УНФ(Полный) обмен РИБ'");
 КонецФункции

 Функция
ИспользоватьПомощникСозданияОбменаДанными() Экспорт
     Возврат Истина;
 КонецФункции

 Функция
НастройкаОтборовНаУзле(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Новый
Структура;
 КонецФункции

 Функция
НастройкаОтборовНаУзлеБазыКорреспондента(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат Неопределено;
 КонецФункции

 Функция
ОписаниеЗначенийПоУмолчанию(ЗначенияПоУмолчаниюНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
ОписаниеЗначенийПоУмолчаниюБазыКорреспондента(ЗначенияПоУмолчаниюНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
ОписаниеОграниченийПередачиДанных(НастройкаОтборовНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
ОписаниеОграниченийПередачиДанныхБазыКорреспондента(НастройкаОтборовНаУзле, ВерсияКорреспондента) Экспорт
     Возврат
"";
 КонецФункции

 Функция
КраткаяИнформацияПоОбмену() Экспорт
     Возврат
"Полный обмен РИБ УНФ-УНФ";
 КонецФункции

 Функция
ПодробнаяИнформацияПоОбмену() Экспорт
     Возврат
"Полный обмен РИБ между конфигурациями УНФ-УНФ"
 
КонецФункции

 Функция
ПланОбменаИспользуетсяВМоделиСервиса() Экспорт
     Возврат Ложь;
 КонецФункции

 Функция
ОбщиеДанныеУзлов(ВерсияКорреспондента, ИмяФормы) Экспорт
     Возврат
"ДатаНачалаВыгрузкиДокументов, Организации, РежимВыгрузкиПриНеобходимости, ЗагружатьДокументыИзБухгалтерииПредприятия, РучнойОбмен";
 КонецФункции

 Функция
РежимЗапускаСинхронизацииДанных(УзелИнформационнойБазы) Экспорт
     Возврат
"АвтоматическаяСинхронизация";
 КонецФункции

7. Создаем новый общий модуль ОбменДаннымиПолный (сервер,внешнее соединение) и вставляем в него код:

////////////////////////////////////////////////////////////////////////////////
// Обмен Полный

// Процедура-обработчик события "ПередЗаписью" ссылочных типов данных (кроме документов) для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - источник события, кроме типа ДокументОбъект
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередЗаписью(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписью("Полный", Источник, Отказ);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" документов для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - ДокументОбъект - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередЗаписьюДокумента(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюДокумента("Полный", Источник, Отказ, РежимЗаписи, РежимПроведения);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" константы для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - КонстантаМенеджерЗначения - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередЗаписьюКонстанты(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюКонстанты("Полный", Источник, Отказ);
КонецПроцедуры

// Процедура-обработчик события "ПередЗаписью" регистров для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - НаборЗаписейРегистра - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//  Замещение      - Булево - признак замещения существующего набора записей
//
Процедура ОбменДаннымиПолныйПередЗаписьюРегистра(Источник, Отказ, Замещение) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередЗаписьюРегистра("Полный", Источник, Отказ, Замещение);
КонецПроцедуры

// Процедура-обработчик события "ПередУдалением" ссылочных типов данных для механизма регистрации объектов на узлах
//
// Параметры:
//  ИмяПланаОбмена – Строка – имя плана обмена, для которого выполняется механизм регистрации
//  Источник       - источник события
//  Отказ          - Булево - флаг отказа от выполнения обработчика
//
Процедура ОбменДаннымиПолныйПередУдалением(Источник, Отказ) Экспорт
   
ОбменДаннымиСобытия.МеханизмРегистрацииОбъектовПередУдалением("Полный", Источник, Отказ);
КонецПроцедуры

8. Создаем ПодпискиНаСобытие и назначем для каждой одноименный обработчик из указанного выше модуля:

8.1.ОбменДаннымиПолныйЗарегистрироватьИзменение

Источник:

Все справочники,за исключением:

АвансовыйОтчетПрисоединенныеФайлы

ДоговорыКонтрагентовПрисоединенныеФайлы

ЗаданиеНаРаботуПрисоединенныеФайлы

ЗаказПокупателяПрисоединенныеФайлы

ЗаказПоставщикуПрисоединенныеФайлы

ИдентификаторыОбъектовМетаданных

ИнвентаризацияЗапасовПрисоединенныеФайлы

КлючевыеОперации

НоменклатураПрисоединенныеФайлы

ОрганизацииПрисоединенныеФайлы

ОчередьЗаданий

ОчередьЗаданийОбластейДанных

ПапкиФайловПрисоединенныеФайлы

ПоставляемыеДанные

ПоставляемыеДополнительныеОтчетыИОбработки

ПоступлениеНаСчетПрисоединенныеФайлы

ПриходнаяНакладнаяПрисоединенныеФайлы

ПроизводственныеКалендари

РасходСоСчетаПрисоединенныеФайлы

СообщенияОбластейДанных

СообщенияСистемы

СпецификацииПрисоединенныеФайлы

СценарииОбменовДанными

СчетНаОплатуПоставщикаПрисоединенныеФайлы

СчетФактураПолученныйПрисоединенныеФайлы

СчетФактураПрисоединенныеФайлы

ТомаХраненияФайлов

ЭДПрисоединенныеФайлы

Отметить все ПланВидовХарактеристикОбъект.

Событие: ПередЗаписью.

 

8.2.ОбменДаннымиПолныйЗарегистрироватьИзменениеДокумента

Источник: Все документы.

Событие: ПередЗаписью.


8.3.ОбменДаннымиПолныйЗарегистрироватьИзменениеКонстанты

Источник: КонстантаМенеджерЗначения,за исключением:

АдресАгентаСервиса

БлокировкаОтправкиБыстрыхСообщений

ВыполнитьРезервноеКопированиеОбластиДанных

ВыполнятьЗамерыПроизводительности

ВыполнятьПроверкуЭЦПНаСервере

ДатаОбновленияПовторноИспользуемыхЗначенийМРО

ДатаПоследнейВыгрузкиЗамеровПроизводительностиUTC

ДетализироватьОбновлениеИБВЖурналеРегистрации

ЗаголовокСистемы

ЗапрещатьЗагрузкуФайловПоРасширению

ЗарегистрированыИзмененияДанных

ИзвлекатьТекстыФайловНаСервере

ИмяСлужебногоПользователяМенеджераСервиса

ИспользоватьАвтономнуюРаботуВМоделиСервиса

ИспользоватьНапоминанияПользователя

ИспользоватьНесколькоПроизводственныхКалендарей

ИспользоватьОбменСПодключаемымОборудованиемOffline

ИспользоватьОтложеннуюОтправкуЭлектронныхДокументов

ИспользоватьПолнотекстовыйПоиск

ИспользоватьРазделениеПоОбластямДанных

ИспользоватьСинхронизациюДанных
ИспользоватьСинхронизациюДанныхВЛокальномРежиме
ИспользоватьСинхронизациюДанныхВМоделиСервиса
ИспользоватьСинхронизациюДанныхВМоделиСервисаСЛокальнойПрограммой
ИспользоватьСинхронизациюДанныхВМоделиСервисаСПриложениемВИнтернете

КаталогВременныхФайловДляLinux
КаталогВременныхФайловДляWindows
КлючОбластиДанных

КонечнаяТочкаМенеджераСервиса
КонтекстАвторизации
КонтекстКриптографии

КопироватьОбластиДанныхИзЭталонной

МаксимальнаяДлительностьВыполненияИсполняющегоФоновогоЗадания
МаксимальноеКоличествоИсполняющихФоновыхЗаданий
МаксимальныйРазмерФайла
МаксимальныйРазмерФайлаОбластиДанных
МинимальныйИнтервалРегламентныхЗаданийДополнительныхОтчетовИОбработокВМоделиСервиса
НастройкаАвтономногоРабочегоМестаЗавершена
НастройкаПодчиненногоУзлаРИБЗавершена
НастройкаПроксиСервера
НастройкиВыполненияРегламентныхЗаданий
НастройкиПодчиненногоУзлаРИБ

НезависимоеИспользованиеДополнительныхОтчетовИОбработокВМоделиСервиса
НеИспользоватьРазделениеПоОбластямДанных

ОбщийКаталогВременныхФайлов
ОбщийКаталогВременныхФайловLinux

ПараметрыАдминистрированияИБ

ПараметрыИтоговИАгрегатов
ПараметрыОграниченияДоступа
ПараметрыРаботыПользователей
ПараметрыСлужебныхСобытий
ПарольДляОтправкиSMS
ПарольПользователяАгентаСервиса

ПарольСлужебногоПользователяМенеджераСервиса

ПоддержкаРезервногоКопирования

ПредставлениеОбластиДанных
ПрефиксДляОбменаССайтом
ПрефиксОбластиДанных
ПрефиксПоследнегоАвтономногоРабочегоМеста
ПрефиксУзлаРаспределеннойИнформационнойБазы
ПровайдерSMS

РазделыОписанияИзмененийСистемы
РазмерБлокаПередачиФайла
РазрешитьВыполнениеДополнительныхОтчетовИОбработокРегламентнымиЗаданиямиВМоделиСервиса
РежимИспользованияИнформационнойБазы

СинхронизироватьДанныеСПриложениемВИнтернетеПриЗавершенииРаботыПрограммы
СинхронизироватьДанныеСПриложениемВИнтернетеПриНачалеРаботыПрограммы
СообщениеБлокировкиПриОбновленииКонфигурации
СообщениеОбменаДаннымиИзГлавногоУзла

СписокЗапрещенныхРасширений
СписокЗапрещенныхРасширенийОбластиДанных

СписокРасширенийФайловOpenDocument
СписокРасширенийФайловOpenDocumentОбластиДанных

СтатусОбновленияКонфигурации

ХранитьФайлыВТомахНаДиске
ЧасовойПоясОбластиДанных

ЭтоАвтономноеРабочееМесто

Событие: ПередЗаписью.

8.4.ОбменДаннымиПолныйЗарегистрироватьИзменениеНабораЗаписей

Источник:  Все РегистрыНакопленияНаборЗаписей.

РегистрСведенийНаборЗаписей, за исключением:

БлокировкиСеансовОбластейДанных

ВерсииПодсистем
ВерсииПодсистемОбластейДанных

ДанныеПроизводственногоКалендаря

ЗависимостиПравДоступа

ЗамерыВремени

ИзмененияОбщихДанныхУзлов

ИспользованиеПоставляемыхДополнительныхОтчетовИОбработокВОбластяхДанных

КэшПрограммныхИнтерфейсов

НапоминанияПользователя

НастройкиОтправителя

НастройкиТранспортаОбмена
НастройкиТранспортаОбменаОбластейДанных
НастройкиТранспортаОбменаОбластиДанных
НеразделенныеПользователи

ОбластиДанных
ОбластиПерсональныхДанных
ОбластиТребующиеОбработкиПоставляемыхДанных
ОбщиеНастройкиУзловИнформационныхБаз

ОчередьИзвлеченияТекста
ОчередьИнсталляцииПоставляемыхДополнительныхОтчетовИОбработокВОбластиДанных

ПодпискиПолучателей

ПоставляемыеДанныеТребующиеОбработки
ПраваПоЗначениямДоступа
ПраваРолей
ПравилаДляОбменаДанными

ПутиМодулейКриптографииСерверовLinux
РабочиеКаталогиФайлов
РезультатыОбменаДанными
РейтингАктивностиОбластейДанных
РучныеИзмененияГрафиковРаботы
СессииОбменаСообщениямиСистемы

СообщенияОбменаДанными
СообщенияОбменаДаннымиОбластейДанных
СоответствияОбъектовИнформационныхБаз

СостоянияОбменовДанными
СостоянияОбменовДаннымиОбластейДанных

СостоянияУспешныхОбменовДанными
СостоянияУспешныхОбменовДаннымиОбластейДанных

УдалитьОбластиДанных
УдалитьОбластиКРезервномуКопированию
УдалитьОчередьЗаданий

ФайлыВРабочемКаталоге

Событие: ПередЗаписью.

8.5.ОбменДаннымиПолныйЗарегистрироватьУдаление

Источник: Все ПланВидовХарактеристикОбъект,ДокументОбъект.

СправочникОбъект,за исключением:

ДоговорыКонтрагентовПрисоединенныеФайлы

ЗаданиеНаРаботуПрисоединенныеФайлы
ЗаказПокупателяПрисоединенныеФайлы
ЗаказПоставщикуПрисоединенныеФайлы

ИнвентаризацияЗапасовПрисоединенныеФайлы

КлючевыеОперации

КонтрагентыПрисоединенныеФайлы

НоменклатураПрисоединенныеФайлы

ОрганизацииПрисоединенныеФайлы
ОчередьЗаданий
ОчередьЗаданийОбластейДанных

ПапкиФайловПрисоединенныеФайлы

ПолныеПутиКФормам

ПоставляемыеДанные
ПоставляемыеДополнительныеОтчетыИОбработки
ПоступлениеНаСчетПрисоединенныеФайлы

ПредопределенныеВариантыОтчетов
ПриходнаяНакладнаяПрисоединенныеФайлы

ПроизводственныеКалендари

РасходСоСчетаПрисоединенныеФайлы

СценарииОбменовДанными
СчетНаОплатуПоставщикаПрисоединенныеФайлы
СчетФактураПолученныйПрисоединенныеФайлы
СчетФактураПрисоединенныеФайлы

Ячейки

Событие: ПередУдалением.

9. В общем модуле  ОбменДаннымиПереопределяемый  в процедуру ПолучитьПланыОбмена в конце процедуры добавить:

ПланыОбменаПодсистемы.Добавить(Метаданные.ПланыОбмена.Полный);

 

10. В Общие команды  добавить новый тип параметра команды:ПланОбменасСсылка.Полный.

     для команд:

    ВыполнитьОбменДанными    

    НастроитьПараметрыТранспортаСообщенийОбмена    

    ОткрытьПравилаРегистрацииОбъектов    

    ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных    

    ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных    

    ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы  

 

На этом этапе все необходимые доработки внедрены,осталось только установить префикс у ИБ и создать новую настройку сихронизацию через Мастер.

 

Также можно вручную создать начальный образ ИБ через ПланыОбмена.

 

   На этом все,можно пользоваться обменом. Тестировалось на релизе УНФ 1.4.7.37.

См. также

Подписаться Добавить вознаграждение

Комментарии

1. юрий гулидов (gull22) 15.01.14 12:49
2. Иван Сорокин (sudo90) 09.02.14 12:59
Уточните пожалуйста что нужно закоментировать в Справочнике ИдентификаторыОбъектовМетаданных, в статье не увидел.

Заранее спасибо
3. Кирилл Ларькин (ZhAmAn) 09.02.14 15:45
(2) sudo90,
В процедуре модуля объекта ПередЗаписью:
//Если ОбщегоНазначения.ЭтоПодчиненныйУзелРИБ() Тогда
//
// Если ЭтоНовый() Тогда
// ВызватьИсключениеПоОшибке(
// НСтр("ru = 'Добавление новых элементов может быть выполнено
// |только в главном узле распределенной информационной базы.'"));
// КонецЕсли;
//
// Если НЕ ПометкаУдаления Тогда
// Если ВРег(ПолноеИмя) <> ВРег(ОбщегоНазначения.ПолучитьЗначениеРеквизита(Ссылка, "ПолноеИмя")) Тогда
// ВызватьИсключениеПоОшибке(
// НСтр("ru = 'Изменение реквизита ""Полное имя"" может быть выполнено
// |только в главном узле распределенной информационной базы.'"));
// КонецЕсли;
// КонецЕсли;
//КонецЕсли;
//

sart-b@mail.ru; kosta_ks; sudo90; +3 Ответить 1
4. Иван Сорокин (sudo90) 14.02.14 09:58
5. alexanderal (alexanderal) 12.03.14 16:48
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменение: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменениеДокумента: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменениеКонстанты: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьИзменениеНабораЗаписей: Обработчик события должен быть задан
ПодпискаНаСобытие.ОбменДаннымиПолныйЗарегистрироватьУдаление: Обработчик события должен быть задан

не нахожу где в тексте об обработчиках есть
6. alexanderal (alexanderal) 31.03.14 14:22
разобрался, заработала, только инструкция немного неполная... надфилем пришлось обработать и открытый вопрос остался с плпном счетов - новые счета не уходят в перефирийку ... чешим репу... ищем где... может кто то решал - подскажите
7. george alexandroff (goshua) 08.10.14 19:35
(6) alexanderal, так что там в обработчиках надо указать?
8. Олег Козиков (kosikov_oleg) 31.01.15 08:25
Спасибо за полезную статью.

Подскажите, пожалуйста, как бороться со следующей проблемой.
При первоначальном старте подчиненного узла добавляется "Администратор", а потом после атоперезапуска вылетает ошибка


{ОбщийМодуль.Пользователи.Модуль(620)}: Ошибка при вызове метода контекста (Записать)
Пользователь.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{ОбщийМодуль.ОбменДаннымиСервер.Модуль(7708)}: Ошибка при вызове метода контекста (Записать)
НаборЗаписей.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{ОбщийМодуль.ПользователиСлужебный.Модуль(316)}: Авторизация не выполнена. Работа системы будет завершена.
Пользователь: Администратор не найден в справочнике "Пользователи".

При попытке добавления пользователя в справочник возникла ошибка:
"Попытка получения неинициализированного значения параметра сеанса".

Обратитесь к администратору.
ВызватьИсключение ТекстСообщенияОбОшибке;
9. Алексей Швадченко (titanium2008) 20.11.15 12:41
Добрый день, кто нибудь для 1.5 реализовывал?
10. Артём Шарипов (borodatii) 20.11.15 12:47
(9) titanium2008, месяца два назад делал обновление УНФ 1.4, где уже был реализован РИБ подобным образом, до 1.5. Сейчас уже точно не вспомню, что именно делал, но принцип простой - запускаешь, получаешь ошибку, смотришь на неё, смотришь в код УТ 11, перетаскиваешь оттуда и пробуешь опять. Пару-тройку итераций и оно работает. Можно сразу смотреть код УТ 11 и тянуть оттуда. Насколько помню, там некоторые методы поменялись, некоторые добавились.
11. Игорь (Ygich) 29.12.15 21:26
(6) alexanderal, нужно добавить новую подписку на событие изменения плана счетов. Либо в подписке ОбменДаннымиПолныйЗарегистрироватьИзменение поставить галку план счетов управленческий.
12. Ксения Дунаева (mind-rubbish) 16.06.16 15:30
Кто-нибудь может ответить, уважаемые, что делать с РИБ для УНФ 1.6? Я стала делать по данной статье, тестово сделала для 1.4, вроде все нормально было (Честно говоря, я столько раз уже пробовала и переделывала, что запуталась даже в количестве и какие ошибки на каких версиях были).. Но в УНФ 1.6, а конкретно 1.6.4.27, я вижу следующее - появились разные документы новые и справочники и тд, и я естественно оставляла на них подписку, может быть кто-то знает логику, почему на некоторые объекты в подписке на события снимается галка?

Плюс второй момент - Глобальные команды. Некоторых команд нет в УНФ 1.6, а именно:

ВыполнитьОбменДанными - есть в УНФ 1.5
НастроитьПараметрыТранспортаСообщенийОбмена - есть в УНФ 1.6
ОткрытьПравилаРегистрацииОбъектов - есть в УНФ 1.5
ПерейтиВЖурналРегистрацииСобытийВыгрузкиДанных - есть в УНФ 1.5
ПерейтиВЖурналРегистрацииСобытийЗагрузкиДанных - есть в УНФ 1.5
ПолучитьНастройкиОбменаДаннымиДляВторойИнформационнойБазы - в УНФ 1.5 это есть, в УНФ 1.6 есть похожее - ПолучитьНастройкиОбменаДанныхДляДругойПрограммы. Судя по комментариям это одно и то же.

Но все равно не ясно - просто добавить эти команды из УНФ 1.5 или УНФ 1.4?

Еще для таких невнимательных как я - в модуле менеджера появились дополнительные параметры в некоторых функциях, я первый раз просто заменяла функции на те, которые в этой статье, в общем сама виновата =) Зато в справочнике ИдентификаторыОбъектовМетаданных больше нечего комментировать - там всего одна строчка
13. Алексей Сидоров (alexstav) 01.08.16 09:20
Присоединяюсь к вопросу. Как настроить для 1.6?
14. Ёк Макарёк (Shaldryn) 08.11.16 15:08
Кто нибудь делал это в 1.6? Сделал, РИБ запускается, но проблема в том что разделы не все отображает и добавить невозможно, из списка доступных нет
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа