gifts2017

Алкогольные декларации ф 11 и 12 (4.30) для ТИС 9.2

Опубликовал Александр Несмеянов (Угрюмый) в раздел Печать - Регламентированная отчетность

Обработка создает табличные формы деклараций, производит выгрузку декларации в файл xml проверяет файл по схеме xsd. Также в обработку включены различные проверки (длина ИНН и КПП, неправильная слеш и т.п.), упрощающие сдачу в ФСРАР.

Основные доработки ТИС:

 В глобальном модуле добавить три функции:
Функция глГенерироватьИмяФайлаВыгрузки(ИНН,ДатаКвартала) Экспорт
    ЗагрузитьВнешнююКомпоненту(КаталогИБ()        +    "v7plus.dll");
    Инфо = СоздатьОбъект("AddIn.V7SysInfo");
    ГлобальноУникальныйИдентификатор = Инфо.СоздатьGUID();
    ДатаФормированияФайлаВыгрузки = Формат(РабочаяДата(), "Д ДДММГГГГ");
    ДатаФормированияФайлаВыгрузки = СтрЗаменить(ДатаФормированияФайлаВыгрузки,".","");
    КодОтправителяИнформации = "";
     КварталСтрока = "";
    МесяцКвартала = ДатаМесяц(ДатаКвартала);  
    Если МесяцКвартала = 12 Тогда
        КварталСтрока = "00";
    Иначе
        КварталСтрока = "0"+МесяцКвартала;
    КонецЕсли;
    // Код отправителя информации
    КодОтправителяИнформации = СокрЛП(ИНН) + "_" + КварталСтрока + Прав(Строка(ДатаКвартала),1);
    ИмяФайлаВыгрузки = КодОтправителяИнформации + "_"    + ДатаФормированияФайлаВыгрузки + "_" + ГлобальноУникальныйИдентификатор;  
    Возврат ИмяФайлаВыгрузки;
КонецФункции //глГенерироватьИмяФайлаВыгрузки()   

Функция глПризПериодОтч(ДатаКвартала) Экспорт
    КварталСтрока = "";
    МесяцКвартала = ДатаМесяц(КонКвартала(ДатаКвартала));  
    Если МесяцКвартала = 12 Тогда
        КварталСтрока = "0";
    Иначе
        КварталСтрока = ""+МесяцКвартала;
    КонецЕсли;
    Возврат КварталСтрока;    
КонецФункции  //глПризПериодОтч(ДатаКвартала)

Функция глРазложить1(Знач Стр, Разделитель = ",") Экспорт
    Список = СоздатьОбъект("СписокЗначений");
    Длина  = СтрДлина(Разделитель);
    Стр = СокрЛП(Стр);
    Поз = Найти(Стр, Разделитель);
    Пока 0 < Поз Цикл
        Список.ДобавитьЗначение(СокрП(Лев(Стр, Поз-1)));
        Стр = СокрЛ(Сред(Стр, Поз+Длина));
        Поз = Найти(Стр, Разделитель);
    КонецЦикла;
    Список.ДобавитьЗначение(Стр);
    Список.ДобавитьЗначение(Стр);
    Возврат Список;
КонецФункции // глРазложить1() 

Кроме того, добавлены справочники:
1. Завод (реквизиты: код, наименование, ИНН, КПП).
2. Классификация (реквизиты: код, наименование).
3. Лицензии (реквизиты: СерияНомер, ДатаВыдачи,  ДатаОкончания, КемВыдана). Подчинен справочнику Контрагенты.
4.ЛицензииФирм (реквизиты: СерНомЛиц, ДатаНачЛиц, ДатаОконЛиц). Подчинен справочнику Фирмы.

 В справочнике Номенклатура добавлены реквизиты:
1. Классификация (ссылка на справочник.Классификация).
2. Завод (ссылка на справочник.Завод).
3. Литраж.
4. Алкоголь (перечисление: алкогольная, пиво, безалкогольная).

 КПП контрагента указывается в реквизите ИНН через "/".

В шапке документа ПоступлениеТМЦРозница добавлен реквизит Лицензия (Ссылка на справочник.Лицензии).

При наличии схем xsd (http://www.fsrar.ru/files/structure/2260.zip) в папке Каталог ИБ\Схемы\430 обработка проверяет файл на валидность с помощью функции (http://forum330.com/forum/79/0#p79-9) от andrewks.

 Если что-то упустил, спрашивайте. И всем удачи в сдаче деклараций!

Скачать файлы

Наименование Файл Версия Размер
ДекларацияПоАлкоголю140113.ert 17
.ert 85,50Kb
16.01.14
17
.ert 85,50Kb Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.