gifts2017

Обработка для группового редактирования любых справочников с общими реквизитами

Опубликовал Макс Такойто (Maks888) в раздел Обработки - Обработка справочников

Скромный пример кода для группового редактирования любых справочников, имеющих общие реквизиты при помощи работы с метаданными. Ее можно с легкостью адаптировать под свои нужды, в том числе и для создания аналогичной обработки для работы с документами.

Процедура КнопкаВыполнитьНажатие(Кнопка)
//// Вставить содержимое обработчика.
Для каждого Справочник из Метаданные.Справочники Цикл // Метаданные.Справочники
ИмяСправочника = Справочник.Объект;
МенеджерСправочника = Справочники[ИмяСправочника];
Табуляция = Символы.Таб;
Сч = 0;
ВыборкаСправочника = МенеджерСправочника.Выбрать();
Пока ВыборкаСправочника.Следующий() Цикл
Попытка
ОбъектСправочник = ВыборкаСправочника.ПолучитьОбъект();
ОбъектСправочник.Узел = Справочники.ИнформационныеБазы.ГоловнойУзел; // здесь можно любой реквизит замест "Узел" вписать и его заполнять нужными значениями
ОбъектСправочник.Записать();
Сообщить("Успешно проставлен 'Головной узел' для справочника" + Табуляция + ВыборкаСправочника);
Исключение
Сообщить("Узел справочника" + Табуляция + ВыборкаСправочника + "не удалось изменить");
КонецПопытки;
Сч = Сч + 1;
Состояние("Элементов обработано " + Сч + " Сейчас обрабатывается справочник " + ИмяСправочника + ": " + ВыборкаСправочника.Наименование);
ОбработкаПрерыванияПользователя();
КонецЦикла;
КонецЦикла;
КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Обработка "Поменять общий реквизит в любых справочниках"
.epf 6,35Kb
21.01.14
3
.epf 6,35Kb 3 Скачать

См. также

Contragent+ 5.0 от 2 500

Автор запретил комментарии