gifts2017

СКД программно для обработки (не отчета) + программное восстановление значений полей из настроек для управляемых форм

Опубликовал Александр Медведев (anig99) в раздел Программирование - Практика программирования

Во многих источниках в качестве примера программного выполнения СКД в обработке (не отчете) приводится код, который обладает одним существенным недочетом, который ограничивает его функциональность. В данной публикации приведен код с исправлением этого недочета.

Сам недочет заключается в том, что в коде не используется КомпоновщикНастроекКомпоновкиДанных, что не позволяет нормально работать со настройками СКД. В частности, недоступна (без извращений или лишнего кода) установка параметров.

 

        //Получаем схему из макета
	СхемаКомпоновкиДанных = ПолучитьМакет("ОтчетПоСборнымЗаказам");

	//создадим компоновщик настроек и загрузим настройки по умолчанию, вместо настроек по умолчанию можно использовать восстановленные настройки
	КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных();
	КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));
	КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновкиДанных.НастройкиПоУмолчанию);
	Настройки = КомпоновщикНастроек.Настройки;
	
        //установка параметров отчета, без КомпоновщикНастроекКомпоновкиДанных делать это гораздо сложнее
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("СвойствоВодитель", 		мСвойствоВодитель);
	Настройки.ПараметрыВывода.УстановитьЗначениеПараметра("Заголовок",			Заголовок);
	
        //Помещаем в переменную данные о расшифровке данных - здесь ненужный пункт, но пусть будет.
	ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;

	//Формируем макет, с помощью компоновщика макета
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;

	//Передаем в макет компоновки схему, настройки и данные расшифровки
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);

	//Выполним компоновку с помощью процессора компоновки
	ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, , ДанныеРасшифровки);

	//Очищаем поле табличного документа
	Результат = Новый ТабличныйДокумент();
	//Выводим результат в табличный документ
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(Результат);

	ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
	
	Результат.ОтображатьЗаголовки = Ложь;
	Результат.ОтображатьСетку = Ложь;
	Результат.Показать();

 

А вот бонусом программное восстановление значений полей из настроек для управляемой формы

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Отбор = Новый Структура();
	Отбор.Вставить("КлючОбъекта", ИмяФормы);
	Отбор.Вставить("КлючНастройки", "Основная"); //тут имя настройки
	Отбор.Вставить("Пользователь", глЗначениеПеременной("глТекущийПользователь").Код);
	Настройки = ХранилищеНастроекДанныхФорм.Выбрать(Отбор);
	Если Настройки.Следующий() Тогда
		Для Каждого стр из Настройки.Настройки Цикл
			Выполнить(стр.Ключ + " = стр.Значение");
		КонецЦикла;
	КонецЕсли;
КонецПроцедуры

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр Лыткин (TrinitronOTV) 30.01.14 05:50
Спасибо, почерпнул для себя....
2. Роман Осадченко (cleaner_it) 30.01.14 09:30
Какие-то мне неправильные примеры попадались)

PS:
Шрифт кода сделать побольше нужно.
Ну и показать, в чем недостаток того метода, который "неправильный"
3. Александр Медведев (anig99) 30.01.14 10:21
(2) вот например по гуглу первые ссылки (касается только кода, которые годится для обработок, т.к. в если брать отчет, но компоновщик настроек там уже есть)

http://help1c.com/faq/view/719.html
http://1cskd.ru/2010/07/programmnyj-vyvod-otcheta/

Шрифт кода предоставлен порталом infostart (:
Недостаток один, но очень существенный - отсутствие компоновщика настроек. Без этого нормальной работы с настройками не получится.



4. Алексей Опарихин (Al-X) 05.02.14 10:26
Плюсанул. А статья может и пригодиться, когда будет лень самому код писать. )))))))
5. Елена Ситникова (lesenoklenok) 07.02.14 09:45
Спасибо, возможно когда нить пригодиться!
6. Яков Коган (Yashazz) 09.02.14 17:15
Хм. Не знаю, о каких примерах речь... Сам всегда делал именно как описывает автор.
Что мне особо нравится, компоновщик можно использовать в значительном "отрыве" от его СКД, а иногда и вовсе без.
7. oleg kaminskiy (leshiy26) 20.02.14 10:59
Почему не подойдет для отчета?
8. Александр Медведев (anig99) 20.02.14 11:14
(7) почему же. Подойдет. Только в отчете уже есть компоновщик настроек и отдельно его создавать не надо.
9. poyson (poyson) 24.03.14 13:50
Пасибо. В избранное.... Надо бывает иногда.
10. Татьяна (svetanik) 02.04.14 15:12
Статья хорошая, польза несомненная! Раньше бы увидела, меньше времени на обработку потратила http://infostart.ru/public/267609/ А то пришлось самой СКД программно ковырять...
11. for_sale for_sale (for_sale) 30.05.14 13:42
а женщина с гитарой каким боком сюда? или это автор7 :)
12. Александр Медведев (anig99) 30.05.14 13:54
(11) for_sale, это картинка для привлечения внимания. Такие картинки существенно повышают количество просмотров.
13. zhuravlik (unichkin) 17.07.14 18:03
Спасибо, два часа мозг рвал СКД. И еще неизвестно сколько рвал бы без строчки КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновкиДанных.НастройкиПоУмолчанию);
Я-то простая душа, думал: раз инициализируем используя схему, то настройки схемы и так должны быть. Блин. В СП по СКД все свалено в кучу, 100500 советов, не знаешь уже куда бежать.
14. Андрей Блохин (Razlagutt) 05.11.14 11:54
Спасибо за статью! Возник вопрос: как вывести скд с группировками в дерево значений? Вывод в дерево сделал, а вторые и третьи уровни "неопределено"?
15. Игорь Исхаков (Ish_2) 15.02.16 15:48
Спасибо ,Саша.
Лень было ковырять .Нашел в гугле первую ссылку. Оказался ты.
16. Иннокентий (Innuil) 17.05.16 17:54
Гигантская благодарность автору!!!
17. Евгений Пургин (sheffchik) 20.06.16 11:26
18. Игорь Герман (German_Tagil) 26.09.16 14:35
19. Римма Герасименко (WhiteOwl) 26.10.16 16:20
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа