gifts2017

Внешняя печатная форма УПД для документа Реализация товаров и услуг (1С БП 3.0.27.10, 1С БП 3.0.30.17 и 1С БП 3.0.37.41)

Опубликовал idw idw (idw) в раздел Печать - Печатные формы документов

Внешняя печатная форма для документа Реализация товаров и услуг позволяет печатать "Универсальный передаточный документ".
Проверена на релизах 1С БП 3.0.27.10, 1С БП 3.0.30.17 и 1С БП 3.0.37.41. Будет полезна тем, кто не хочет изменять конфигурацию.

Внешняя печатная форма для документа Реализация товаров и услуг позволяет печатать "Универсальный передаточный документ".  Будет полезна тем, кто не хочет изменять конфигурацию.

"Универсальный передаточный документ" для документа "Реализация товаров услуг". 
ФНС РФ в своем письме № ММВ-20-3/96@ от 21.10.2013 напоминает, что начиная с 2013 года любой хозяйствующий субъект, не нарушая законодательство, может объединить информацию ранее обязательных для применения форм по передаче материальных ценностей (ТОРГ-12, М-15, ОС-1, товарный раздел ТТН) с дублирующими по большинству позиций реквизитами с информацией счетов-фактур, выписываемых в целях исполнения законодательства по налогам и сборам.
Такое объединение при соблюдении требований Закона № 402-ФЗ от 06.12.2011 и главы 21 НК РФ не может лишить хозяйствующего субъекта ни возможности учитывать оформленный факт хозяйственной жизни в целях бухгалтерского учета, ни возможности использовать право на налоговый вычет по НДС и возможности использовать право подтверждения затрат в целях исчисления налога на прибыль организаций (и других налогов).
В этой связи ФНС РФ предлагает к применению форму универсального передаточного документа на основе формы счета-фактуры.
Форма носит рекомендательный характер и ее неприменение не может быть основанием для отказа в учете этих фактов хозяйственной жизни в целях налогообложения.
Кроме того, предложение ФНС России формы универсального передаточного документа не ограничивает права хозяйствующих субъектов на использование иных соответствующих условиям статьи 9 Закона № 402-ФЗ форм первичных учетных документов (из действовавших ранее альбомов или самостоятельно разработанных) и формы счета-фактуры, установленной непосредственно постановлением Правительства РФ № 1137.
Работает на релизах 1С БП 3.0.27.10, 1С БП 3.0.30.17 и 1С БП 3.0.37.41. На других не проверял.

Инструкция по подключению внешней печатной формы к документу.
1. Скачать файл ВПФ_УПД.epf
2. Выбирать меню "Сервис" пункт "Дополнительные внешние отчеты и обработки", подпункт "Печатные формы".
3. В появившемся окне отразится список зарегистрированных внешних печатных форм.
4. Для регистрации печатной формы создаем новый элемент ("Добавить").
5. В табличной части можно заполнить реквизит "Заменяемая печатная форма". Заполнять в случае если необходимо заменить типовую печатную форму, если не заполнено, то новая обработка появится в списке печатных форм под названием указанным в реквизите "Наименование".

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
УПД (1С БП 3.0.27.10)
.epf 22,17Kb
11.04.14
38
.epf 22,17Kb 38 Скачать
УПД (1С БП 3.0.37.41)
.epf 23,85Kb
18.05.15
104
.epf 23,85Kb 104 Скачать
УПД (1С БП 3.0.30.17)
.epf 23,95Kb
14.04.14
76
.epf 23,95Kb 76 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей (konsserj) 07.04.14 10:48
Релиз 3.30.17. При подключении после выбора файла обработки появляется ошибка {ВнешняяОбработка.ВПФ_УПД.МодульОбъекта(407,23)}:Переменная не определена (ФизическиеЛица)
2. Сергей (konsserj) 11.04.14 15:32
У кого-нибудь на этом релизе работает?
3. idw idw (idw) 11.04.14 21:44
Подтверждаю на релизе 3.30.17 печатная форма не работает.
4. tisa tisas (tisas77) 12.04.14 18:48
У меня тоже на этом релизе не работает
5. idw idw (idw) 13.04.14 09:47
Выложил версию под 1С БП 3.0.30.17
6. Александр (Креатив) 27.11.14 20:13
У меня не работает БП 3.0.37.26
{ВнешняяОбработка.ВПФ_УПД.МодульОбъекта(708)}: Поле объекта не обнаружено (Организация)
ДанныеФизЛица = УчетЗарплаты.ДанныеФизическихЛиц(ВыборкаСФ.Организация, ВыборкаСФ.Руководитель, ВыборкаСФ.Дата, Истина);
7. djdiamond (djdiamond) 27.01.15 16:52
У меня не работает БП 3.0.38.34
{ВнешняяОбработка.ВПФ_УПД.МодульОбъекта(708)}: Поле объекта не обнаружено (Организация)
ДанныеФизЛица = УчетЗарплаты.ДанныеФизическихЛиц(ВыборкаСФ.Организация, ВыборкаСФ.Руководитель, ВыборкаСФ.Дата, Истина);
8. idw idw (idw) 28.01.15 15:53
(7) проверенно только на релизах 1С БП 3.0.27.10 и 1С БП 3.0.30.17
Под другие не делал.
9. djdiamond (djdiamond) 29.01.15 13:27
Есть в планах сделать под свежий релиз?
10. idw idw (idw) 29.01.15 15:53
(9) если очень надо, то сделаю.
11. djdiamond (djdiamond) 29.01.15 22:12
Надо)) А то нигде нет больше. Я скачал, но не могу понять куда копать по этой ошибке.
12. Николай Гончаров (JohnConnor) 17.04.15 04:20
номер неправильно берет, не от счет фактуры
13. Ник (nicknick) 05.05.15 21:30
Данные из счет-фактуры вообще не подставляет, не корректно столбцы НДС
14. idw idw (idw) 18.05.15 14:47
(12) (13) конечно, читайте описание - это печатная форма для документа РЕАЛИЗАЦИЯ, из него берет данные и номера.
15. KeyMaster 24.06.15 21:46
Почему не указано, что не использует БСП?
16. Al Polos75 (polos75) 28.07.15 20:18
Не выводятся фио руководителя и гл.бухгалтера, исправил сам.
Печатается не номер фактуры, а номер реализации. Сделать такую же внешнюю форму с нуля получилось быстрей, чем исправить все ошибки в этой - ещё и не знаю как сделать отладку внешней формы.
A7758735; +1 Ответить
17. Al Polos75 (polos75) 28.07.15 20:19
(14) idw, хоть и печатная форма документа реализация - в ней написано счет-фактура №.
18. Алексей П (mefisto) 31.07.15 09:19
idw, халтура.
Сравните результат формирования встроенной печ. формы и Вашей ВПФ по документу "РеализацияТоваровУслуг" с введенной на основании счетом-фактурой.
Номер и дата счета фактуры, из Вашей ВПФ не соответствует встроенной (+ книге продаж и покупок), т.е. выставлять покупателю нельзя.
Исправьте пожалуйста, или верните 1$m :)
juvv873; A7758735; max_zhilin; +3 Ответить
19. Юлия Волошина (juvv873) 08.06.16 08:56
И всё-таки, как сделать, чтобы выводились правильные Номер/Дата и прочее?
чтобы бралось из счет-фактуры, а не из документа реализации
20. Данила Галеев (synelf) 17.11.16 18:54
Не правильно сделана обработка. Должна браться процедура

Если ЕстьСчетаФактуры И УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "УПДСтатус1") Тогда
		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "УПДСтатус1", "УПД (статус 1)",
			УчетНДС.ПечатьУниверсальныхПередаточныхДокументов(МассивОбъектов, ОбъектыПечати, 
			Документы.СчетФактураВыданный.ТекстЗапросаПечатьСчетовФактур(Истина, Истина)),,
			"Обработка.ПечатьУПД.ПФ_MXL_УниверсальныйПередаточныйДокумент");
			
	КонецЕсли;
...Показать Скрыть

в которой подставляется статус 1 (вверху слева в УПД)

а берется процедура
Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "УПДСтатус2") Тогда
		ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов = "";
		Для каждого Объект Из МассивОбъектов Цикл
			Если ТипЗнч(Объект) <> Тип("ДокументСсылка.СчетФактураВыданный") Тогда
				ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов = 
					Документы[Объект.Метаданные().Имя].ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов();
				Прервать;
			КонецЕсли;
		КонецЦикла;
		Если НЕ ПустаяСтрока(ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов) Тогда
			УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "УПДСтатус2", "УПД (статус 2)",
				УчетНДС.ПечатьУниверсальныхПередаточныхДокументов(МассивОбъектов, ОбъектыПечати, 
				ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов, Истина),,
				"Обработка.ПечатьУПД.ПФ_MXL_УниверсальныйПередаточныйДокумент");
		КонецЕсли;
	КонецЕсли;
...Показать Скрыть

и соответственно ставится статус 2. В типовой же выводится всегда статус 1.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа