gifts2017

Акт сверки для Бухгалтерии предприятия 3.0

Опубликовал Dimyla Dimyla (Dimyla) в раздел Отчеты - Бухгалтерские

Акт сверки взаиморасчетов на управляемых формах. Красивый бланк.

Tongue OutАкт сверки взаимных расчетов, в разрезе договоров и контрагентов. Управляемые формы. Нужная вещь для любой организации.

Акт сверки взаиморасчетов представляет собой документ, отображающий расчеты двух организаций за определенный срок. Т.к. действующим законодательством не предусмотрена официальная форма акта сверки взаиморасчетов субъектов хозяйствования, то организация имеет право самостоятельно разработать удобную для нее форму акта сверки. Для нашей организации подошла такая форма.

Акт сверки составляется в разрезе договоров и контрагентов.

Разработан на Управляемыех формах.

Скачать файлы

Наименование Файл Версия Размер
Акт сверки 78
.erf 22,20Kb
01.04.14
78
.erf 22,20Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Владимир Клименко (KliMich) 08.02.14 14:48
Спасибо! Скоро этот отчет должен пригодиться.
2. Артем Артеменко (dock) 12.02.14 07:54
Описание порадовало - "красивый бланк" ;)
3. Stas Bor (stas1976) 04.03.14 13:21
поле объекта не обнаружено (АктСверкиБАЛАНС)
Прикрепленные файлы:
4. Alexei Rakhmanov (al4271) 14.03.14 15:44
Не работает форма. даже в программу добавляться не хочет.
Вот эту ошибку выдает.
Метод объекта не обрнаружен(СведенияОВнешнейОбработке)
stas1976; gges; +2 Ответить 1
5. veqrin veqrin (veqrin) 28.03.14 10:02
6. Dimyla Dimyla (Dimyla) 01.04.14 07:27
(4) al4271, загрузила обработку новее
7. Stas Bor (stas1976) 03.04.14 08:52
я может что-то не понимаю ?? его не через файл -> открыть надо включать ??? у меня после нажатия кнопки сформировать пишет "поле объекта не обнаружено (АктСверкиБАЛАНС)"
8. Stas Bor (stas1976) 03.04.14 10:06
пытаюсь добавить как внешнюю Метод объекта не обнаружен(СведенияОВнешнейОбработке), это на вновь скачанной обработке
9. Stas Bor (stas1976) 03.04.14 10:41
это была первоапрельская шутка новая обработка от старой не отличается
10. Stas Bor (stas1976) 03.04.14 12:17
в модуль объекта добавил следующее:
Функция СведенияОВнешнейОбработке()Экспорт
ПараметрыРегистрации = Новый Структура;
ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
ПараметрыРегистрации.Вставить("Наименование", "АктСверкиБАЛАНС");
ПараметрыРегистрации.Вставить("Версия", "1");
ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
ПараметрыРегистрации.Вставить("Информация", "акт сверки");

ТаблицаКоманд = ПолучитьТаблицуКоманд();

ДобавитьКоманду(ТаблицаКоманд,"АктСверкиБАЛАНС","АктСверкиБАЛАНС","ОткрытиеФормы", Ложь,"");

ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()

Команды = Новый ТаблицаЗначений;
Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

Возврат Команды;
КонецФункции


Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

НоваяКоманда = ТаблицаКоманд.Добавить();
НоваяКоманда.Представление = Представление;
НоваяКоманда.Идентификатор = Идентификатор;
НоваяКоманда.Использование = Использование;
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры

после этого удалось прилепить ее в дополнительные отчеты, она прекрасно включается и очень радостно заполняется реквизитами, нажимаю кнопку сформировать и ... оппа <поле объекта не обнаружено (АктСверкиБАЛАНС)>
11. Тагир Кузбеков (TIGER1991) 12.02.15 10:24
Отчет рабочий, но надо немного подправить:

1. В модуле объекта добавляем:

Функция СведенияОВнешнейОбработке() Экспорт
РегистрационныеДанные = Новый Структура;
РегистрационныеДанные.Вставить("Наименование", "АктСверки");
РегистрационныеДанные.Вставить("БезопасныйРежим", Истина);
РегистрационныеДанные.Вставить("Версия", "1.0");
РегистрационныеДанные.Вставить("Вид", "ДополнительныйОтчет");
РегистрационныеДанные.Вставить("Информация", "АктСверки "" ");
тзКоманд = Новый ТаблицаЗначений;
тзКоманд.Колонки.Добавить("Идентификатор");
тзКоманд.Колонки.Добавить("Представление");
тзКоманд.Колонки.Добавить("Модификатор");
тзКоманд.Колонки.Добавить("ПоказыватьОповещение");
тзКоманд.Колонки.Добавить("Использование");
строкаКоманды = тзКоманд.Добавить();
строкаКоманды.Идентификатор = "1";
строкаКоманды.Представление = "АктСверки";
строкаКоманды.ПоказыватьОповещение = Истина;
строкаКоманды.Использование = "ОткрытиеФормы";
РегистрационныеДанные.Вставить("Команды", тзКоманд);
Возврат РегистрационныеДанные;
КонецФункции


2. В модуле формы "ФормаОтчета" в "Функция СформироватьЗаголовок()" меняем строку

Макет = Отчеты.АктСверкиБАЛАНС.ПолучитьМакет("АктСверки");
на строку Макет = ТекДок.ПолучитьМакет("АктСверки");
И перед ней добавляем строку:
ТекДок =РеквизитФормыВЗначение("Отчет");

Тоже самое делаем в "Процедура Сформировать()"
Только там в двух местах меняем строку на Макет = ТекДок.ПолучитьМакет("АктСверки");

Сохраняем, запускаем
12. Sergey S (stagov) 12.02.15 11:07
Картинки с оборотами в периоде можно было бы добавить. А то сальдо нач. - сальдо кон. Сейчас народ уже просит текущее сальдо по каждой строке акта.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа