gifts2017

Элементарное шифрование

Опубликовал Дмитрий Шиндориков (sdn-1) в раздел Программирование - Защита и шифрование

Алгоритм шифрования - простая перестановка

Представленная внешняя обработка демонстрирует один из самых простых методов шифрования:

Сообщение записывается в таблицу по столбцам. После того, как открытый текст записан колонками, для образования шифровки он считывается по строкам посимвольно в обратном порядке. Для использования этого шифра отправителю и получателю нужно договориться об общем ключе в виде длины колонки таблицы. 

Удобство и простота данного алгоритма заключаются в том, что и шифрование и дешифрование осуществляются одной и тойже процедурой

&НаКлиенте
Процедура ШифрацияДешифрация(Команда)
	
	Если Поле = "" Тогда 
		Предупреждение ("Задайте текст для шифрования");
		Возврат;
	КонецЕсли;
	
	// исходный массив
	Массив = Новый Массив();
	Строка = Поле;
	Пока ЗначениеЗаполнено(Строка) Цикл
		сСтрока = Лев(Строка, ДлинаКлюча);
		Строка = Прав(Строка, СтрДлина(Строка)-ДлинаКлюча);
		
		Массив.Добавить(сСтрока);
	КонецЦикла;

	// преобразованный массив
	пМассив = Новый Массив;
	Текст = "";
	Для стр = 0 ПО Массив.Количество()-1 Цикл
		Строка = ""; Символ = ""; 
		сСтрока = Массив[стр];
		Для тСимвол = 1 ПО СтрДлина(сСтрока) Цикл
			Символ = Сред(сСтрока, (СтрДлина(сСтрока)-тСимвол+1), 1);
			Строка = Строка + Символ;
		КонецЦикла;
		
		пМассив.Добавить(Строка);
		Текст = Текст + Строка;
	КонецЦикла;	
	
	Поле = Текст;
КонецПроцедуры


Скачать файлы

Наименование Файл Версия Размер
Алгоритм шифрования: простая перестановка 5
.epf 6,95Kb
12.02.14
5
.epf 1.0.1 6,95Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Alexander Speshilov (speshuric) 11.02.14 15:56
А МенеджерКриптографии чем не угодил?
2. Дмитрий Шиндориков (sdn-1) 11.02.14 16:35
он не то чтобы не угодил - я о нем от вас впервые улышал )
спасибо за подсказку - посмотрю обязательно
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа