gifts2017

Простая обработка для выгрузки списков на зачисление з/п из документов "Зарплата к выплате организаций". Реализована возможность выгрузки списка документов (закомментировать 1 строчку)

Опубликовал Yauhen Makei (mrDSide) в раздел Обмен - Обмен с интернет-банком

Простая обработка для выгрузки списков на зачисление з/п из документов "Зарплата к выплате организаций". Реализована возможность выгрузки списка документов (закоментировать 1 строчку)

Простая обработка для выгрузки списков на зачисление з/п из документов "Зарплата к выплате организаций". Реализована возможность выгрузки списка документов (закоментировать 1 строчку) . Распространяется "как есть".

1. Заполняем шапку: путь выгрузки, организацию (для подбора документа/документов), банк (для выгрузки лиц. счетов), счет (счет организации), банк/режим (есть несколько готовых протоколов выгрузки, остальные добавляете сами; ничего сложного, скелет есть);
2. На закладке "Ведомости" выбираете ведомость/ведомости для выгрузки;
3. На закладке "Список" формируется список сотрудников/лиц.счетов/сумм для выгрузки;
4. На закладке "Отв." можно указать ответственных (испльзуется при выгрузке);
5. Жмем "Выгрузить".

П.С. кодировки текста "забиты" в код (просто никогда не меняются, так удобнее), но этож 1с, так что кому надо можно вынести на форму.

Включение возможности выгрузки списка документов:
закомментировать текст в процедуре формы:

Процедура ВедомостиПередНачаломДобавления(Элемент, Отказ, Копирование)
	
	Если Организация.Пустая() Тогда
		Отказ=Истина;
		Сообщить("Не выбрана организация",СтатусСообщения.Важное);
	КонецЕсли;
	// закомментируй меня [+]
	Если Ведомости.Количество()=1 Тогда
		Сообщить("Ведомость уже добавлена, измените/удалите ведомость из т.ч.",СтатусСообщения.Важное);
		Отказ=Истина;
	КонецЕсли;
	// закомментируй меня [-]
	
КонецПроцедуры
 

 

Скачать файлы

Наименование Файл Версия Размер
Обработка 4
.epf 17,39Kb
14.03.14
4
.epf 17,39Kb Скачать

См. также

Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа