gifts2017

Поиск и замена значений - Заполнение заменяемых значений из запроса

Опубликовал Sergey (manserg) в раздел Программирование - Практика программирования

Простая доработка типовой обработки "Поиск и замена значений" позволяющая использовать произвольный запрос для заполнения таблицы заменяемых значений.

В повседневной работе достаточно часто возникает необходимость проведения массовых замен значений.

Как правило, для этих работ используется типовая обработка "Поиск и замена значений", однако при массовости замен достаточно трудоемок процесс ручного заполнения таблицы замен.

Для упрощения заполнения таблицы замен предлагается внести небольшие изменения исключительно в код самой обработки, благодаря чему, обработка приобретает возможность автоматизированного заполнения таблицы замен непосредственно из произвольного запроса, который строится при помощи привычного конструктора запроса либо вручную.

Основным условием выполнения заполнения являются условия наименования синонимов результирующих полей запроса "ЧтоЗаменять" и "НаЧтоЗаменять" - они должны быть одноименны наименованиям полей таблицы заменяемых значений.

Код доработки предоставляется как есть - разработчик не несет ответственности за некорректное его использование.

 

Просто добавьте данный код в модуль основной формы обработки:

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ - РАСШИРЕНИЯ ФУНКЦИОНАЛА ОБРАБОТКИ


Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
	
	ДобавляемоеДействие 	= Новый Действие("ЗаполнитьИзЗапроса");
	ТипДобавляемойКнопки	= ТипКнопкиКоманднойПанели.Действие;
	
	кЗаполнитьИзЗапроса = ЭлементыФормы.КоманднаяПанельЗаменяемыеЗначения.Кнопки.Добавить("Заполнить из запроса", ТипДобавляемойКнопки, , 

ДобавляемоеДействие);
	
КонецПроцедуры

Процедура ЗаполнитьИзЗапроса()
	
	КонструкторЗапроса = Новый КонструкторЗапроса;
	КонструкторЗапроса.ОткрытьМодально();
	
	Если ПустаяСтрока(КонструкторЗапроса.Текст) тогда
		Предупреждение("Отсутсвует текст запроса!");
		Возврат;
	КонецЕсли;
	
	ПостроительЗапроса = Новый ПостроительЗапроса;
	ПостроительЗапроса.Текст = КонструкторЗапроса.Текст;
	ПостроительЗапроса.Выполнить();
	
	РезультатЗапроса = ПостроительЗапроса.Результат;
	
	Если РезультатЗапроса.Пустой() тогда
		Предупреждение("Отсутсвует результат запроса!");
		Возврат;
	КонецЕсли;
	
	ВыборкаРезультата = РезультатЗапроса.Выбрать();
	
	ЗаменяемыеЗначения.Очистить();
	
	Пока ВыборкаРезультата.Следующий() цикл
		
		НоваяСтрока = ЗаменяемыеЗначения.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрока, ВыборкаРезультата, "ЧтоЗаменять,НаЧтоЗаменять");
		НоваяСтрока.Пометка = Истина;
		
	КонецЦикла;
	
	Предупреждение("Заполнение произведено!");
	
КонецПроцедуры

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Вера Белевич (integragirl) 12.03.14 06:45
хммм, тоже интересно! Мелочь, а приятно!
2. Алексей Орлов (_also) 12.03.14 09:17
3. Иван Иванов (Famza) 12.03.14 09:58
(0) Однако, кнопка на форме не создалась.
Ось XP SP3, 1С:Предприятие 8.3.4.408
4. Sergey (manserg) 13.03.14 17:43
(3) Famza,
это не для управляемых форм - сорри
5. Sergey (manserg) 13.03.14 17:43
(2) _also,
если вы внимательно посмотрите, то найдете "10" отличий...
6. Змей Змеевич (Zmey_72) 14.09.14 10:49
Отличная статья. За 5 минут избавился от всей номенклатуры, помеченной на удаление. В ручную ушло бы много времени. Спасибо.
7. Сергей Кенжин (Kesak) 15.03.15 17:40
Отличная статья! Добавил функционал к типовой за несколько секунд. Автору +.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа