gifts2017

Прогресс бар в статус строке для неуправляемых форм

Опубликовал Роман Даньшин (endryu) в раздел Программирование - Работа с интерфейсом

Мой вариант реализации прогресс бара в статусной строке для неуправляемых форм 1С 8.х

 

Привожу код тестовой обработки, содержащей функции реализации прогресс бара:

Пример, как работает GIF 

Перем СтатусИтерация, СтатусМаксимум, СтатусРасшифровка;

Процедура ПересчетКонтрагентовНажатие(Элемент)
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Контрагенты.Ссылка
		|ИЗ
		|	Справочник.Контрагенты КАК Контрагенты
		|ГДЕ
		|	Контрагенты.Покупатель = ИСТИНА";
	Результат = Запрос.Выполнить();
	ПрогрессБарСброс("Обход контрагентов"); //Сброс и установка текста статуса.
	ПрогрессБар(0,Результат.Выгрузить().Количество()); //Установка максимального значения прогресс бара.
	
	ВыборкаДетальныеЗаписи = Результат.Выбрать();
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ПрогрессБар(); //Увеличение шага итерации и отрисовка прогресс бара в статус строке.
		
		ЭлементыФормы.Надпись1.Заголовок = ВыборкаДетальныеЗаписи.Ссылка.Наименование;
		ОбработкаПрерыванияПользователя();
	КонецЦикла;
КонецПроцедуры

//------------------------------------------------------------------------------
// Статус строка
//------------------------------------------------------------------------------
Процедура СтатусСтрока() //Отрисовка прогресбара в статус строке
	Процент = ?(СтатусМаксимум>0,Окр(СтатусИтерация/СтатусМаксимум*100),0);	
	сс="----------------------------------------------------------------------------------------------------";
	ссл=Лев(сс,Процент);сср=Прав(сс,100-Процент);
	ссл=СтрЗаменить(ссл,"-","]");
	сс=ссл+сср;
	Состояние(""+СтатусРасшифровка+": "+сс+" "+Процент+"%");	
КонецПроцедуры
Процедура ПрогрессБарСброс(СтТекст="") //Сбрасывает прогресбар с статус строке
//При указании параметра - устанавливаем текстовое значение прогресс бара
	СтатусРасшифровка = СтТекст;
	СтатусИтерация=0;
	СтатусМаксимум=0;
	Состояние("");	
КонецПроцедуры
Процедура ПрогрессБар(ДобавитьИтерацию=1,ДобавитьМаксимум=0) //шаг итерации
// ПрогрессБар() - увеличивает шаг на 1
// ПрогрессБар(0,Максимальное значение) - устанавливает максимум для значения прогресс бара
	СтатусИтерация=СтатусИтерация+ДобавитьИтерацию;
	СтатусМаксимум=СтатусМаксимум+ДобавитьМаксимум;
	СтатусСтрока();
КонецПроцедуры

ПыСы: в коде пришлось вставить другие, упрощенные символы формирования полосы прогрессбара. В фото и гифке использовал символы из стандартной таблицы символов Windows. А вообще можете подобрать на свое усмотрение. symbols

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Пример использования на форме
.epf 6,76Kb
03.04.14
4
.epf 6,76Kb 4 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Александр Медведев (anig99) 03.04.14 17:58
Честно говоря, боян, но симпатишный
2. Denis Michaylov (denis_aka_wolf) 03.04.14 19:05
Производительность будет минимальной...
Не имеет смысла использовать данный метод при обработке больших объемов данных
3. EfiopReal (Созинов) 03.04.14 20:08
Плюс за оригинальность отображения, возьму на заметку. С производительностью - да плохо. Но индикацию попробую прикрутить к своей индикации. (кстати когда-то брал здесь же Эффективная индикация в 8.2 и Правильная индикация прогресса цикла)
4. Александр Медведев (anig99) 04.04.14 09:04
(3) идея не оригинальна. Тут уже было несколько таких, правда давно.
(2)(3) и да... давно уже доказано, что индикация процесса ОЧЕНЬ тормозит работу. Чтобы сократить этот эффект статус надо выводить раз в сколько-то тактов или раз в минуту.
5. Роман Даньшин (endryu) 04.04.14 10:34
Согласен с тем, что отображать каждый шаг - не рационально.
Перем СтатусВремя;
...
...
...
Процедура ПрогрессБарСброс(СтТекст="") //Сбрасывает прогресбар с статус строке
//При указании параметра - устанавливаем текстовое значение прогресс бара
	СтатусРасшифровка = СтТекст;
	СтатусИтерация=0;
	СтатусМаксимум=0;
	СтатусВремя = ТекущаяДата();
	Состояние("");	
КонецПроцедуры
Процедура ПрогрессБар(ДобавитьИтерацию=1,ДобавитьМаксимум=0) //шаг итерации
// ПрогрессБар() - увеличивает шаг на 1
// ПрогрессБар(0,Максимальное значение) - устанавливает максимум для значения прогресс бара
	СтатусИтерация=СтатусИтерация+ДобавитьИтерацию;
	СтатусМаксимум=СтатусМаксимум+ДобавитьМаксимум;
	Если (ТекущаяДата()-СтатусВремя)>1 тогда
		СтатусВремя = ТекущаяДата();
		СтатусСтрока();		
	КонецЕсли;
КонецПроцедуры
...Показать Скрыть


Вот так будет выводить раз в секунду. А выводить каждую N-нную итерацию считаю не верным, ибо цикл может работать по 10-20 секунд один обход, а может и долю секунды.
6. Андрей Старченко (dr.death) 09.04.14 11:31
А зачем это нужно? на крайний случай в форме можно разместить стандартный объект "индикатор", а в статус баре выводить основные этапы исполнения кода:
Выполняется Запрос....
Формирование табличного документа...
и т.д.
7. Андрей Старченко (dr.death) 09.04.14 12:02
Или вообще, можно сделать общую форму с индикатором, передавать в нее все необходимые данные и открыть в любом месте окна, хоть вертикально.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа