gifts2017

Скачивание обновлений 1C 8, 7.7, Айлант ЖКХ

Опубликовал Павел Алексеенко (qwinter) в раздел Администрирование - Системное

Конфигурация для скачивания и установки обновлений 1С 8. Также может скачивать обновления для 1С 7.7, Айлант ЖКХ.

Данная конфигурация скачивает все доступные обновления с сайтов:

  • https://releases.1c.ru/ (Обновления 1С предприятие 8)
  • http://techsupp.1c.ru/ (Обновления 1С предприятие 7.7)
  • http://ujkh.ru/ (Айлант ЖКХ)
  • http://1c-osa.ru/ (Отраслевая сервисная автоматизация)
Версии начинают скачиваться с даты, указанной в настройке (для каждой конфигурации можно указать свою дату).
По умолчанию конфигурации подцепляются к предопределенным папкам (можно переименовывать, перемещать).
Есть возможность искать в файле Reedme информацию по требуемой платформе (касается только https://releases.1c.ru ).
При данной настройке в путь сохранения скачанного файла добавляется редакция платформы (8.2, 8.3). Для каждой конфигурации редакцию платформы можно указать вручную. 

UPD 1.0.3.8 от 17.11.2016:

  1. Добавлена поддержка сайта http://1c-osa.ru/.

UPD 1.0.3.7 от 28.10.2016:

  1. Поддержка обновления сайта https://releases.1c.ru/.
  2. Отказ от поддержки сайта ВДГБ.
  3. Отказ от поддержки расширения для БП 3.0.

UPD 22.09.2016
  1. Исправление ошибок.
 
UPD 1.0.3.6 от 15.10.2015:
  1. Добавлена обработка: "Обновление типовых конфигураций".
  2. В справочник "Конфигурации 1С" добавлен реквизит "Каталог поставщика".

UPD 1.0.3.5 от 23.09.2015:
  1. Добавлены функции для работы с раширение к конфигурации "Бухгалтерия предприятия. Редакция 3.0".
UPD 1.0.3.4 от 20.09.2015:
  1. В конфигурацию добавлена обработка: "Построение цепочки обновлений". Обработка строит цепочку обновлений по принципу максимального релиза. Также в ней отображается какие релизы уже скачаны, и какие уже установлены на компьютер пользователя. В ней можно сразу установить скачанные, но еще не установленные релизы.  http://infostart.ru/upload/iblock/43d/0.jpg

UPD 1.0.3.2 от 15.09.2015:
  1. Для упрощения встраивания в конфигурации добавлена подсистема "UPD_ЗагрузкаОбновлений". При сравнение-объединение требуется снять все крыжи, и отметить по данной подсистеме файла. Затем отметить саму подсистему. В пользовательском режиме требуется зайти в настройке и нажать кнопку: "Выполнить обновление".
  2. Добавлен интерфейс "UPD_ЗагрузкаОбновлений", добавлены роли пользователя и администратора.
  3. Добавлена проверка на отозванность релизов. Если релиз отозван, то папка с ним переименовывается.
  4. Реализовано паралельное считываение версий конфигураций. Количество паралельных процессов выставляется в настройках.
  5. Доработан поиск требуемой версии платформы для конфигурации.
  6. В начальное заполнение включен полностью спарсенные конфигурации и релизы сайта https://releases.1c.ru
  7. Исправление ошибок.

UPD 1.0.2.2 от 04.09.2015:
  1. Исправление в связи с обновлением сайта 1С (https://releases.1c.ru).

UPD 1.0.2.1 от 04.08.2015:
  1. Исправление в связи с обновлением сайта 1С (https://releases.1c.ru).
UPD 1.0.1.1 от 15.05.2015:
  1. В форме элемента справочника Программы выводится текст описания изменений в версии (при наличии файлов news.htm или "Новое в версии.htm".
  2. https://users.v8.1c.ru/ (Обновления 1С предприятие 8)
    • Добавлена возможность скачивать тестовые версии.
    • Именна файлов присваиваются согласно ссылкам (т.е. "Дистрибутив обновления.exe", "Полный дистрибутив.exe", "Технологическая платформа 1С Предприятия для Windows.rar" и т.д.).
  3. Режим совместимости выставлен в "Версия 8.3.5".
  4. Исправление ошибок.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Загрузка обновлений v1.0.3.7
.cf 1,12Mb
29.10.16
23
.cf 1.0.3.6 1,12Mb 23 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Алексей Коробов (olesha) 08.07.14 19:45
https://users.v8.1c.ru/ (Обновления 1С предприятие 8) не работает
2. Павел Алексеенко (qwinter) 08.07.14 20:41
(1) olesha, очередное обновление сайта от 1с)) обновите процедуру в общем модуле UPD_ЗагрузкаКонфигураций:
Процедура РекурсивныйПарсингСпискаКонфигураций(ДокументHTML)

	ТекИмяГруппы = "";
	
	Для Каждого ЭлДок Из ДокументHTML.ДочерниеУзлы Цикл
		
		Если СокрЛП(ЭлДок.ТекстовоеСодержимое) = "Название" Тогда
			
			//количество строк в таблице дистрибутивов
			СписокУзловHTML = ЭлДок.РодительскийУзел.РодительскийУзел.РодительскийУзел.ДочерниеУзлы[1].ДочерниеУзлы;
			КолЭлементов = СписокУзловHTML.Количество();
			
			Для А=0 По КолЭлементов-1 Цикл
					
				Если СписокУзловHTML[А].ДочерниеУзлы.Количество() = 1 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0].ТекстовоеСодержимое);	
					Группа = НайтиСоздатьГруппу(ТекИмяГруппы, Справочники.UPD_Программы.v8, Истина);
				ИначеЕсли СписокУзловHTML[А].ДочерниеУзлы.Количество() = 2 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0].ТекстовоеСодержимое);	
					Группа = НайтиСоздатьГруппу(ТекИмяГруппы, Справочники.UPD_Программы.v8, Истина);	
				КонецЕсли;
				
				Если СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы.Количество() > 1 Тогда
					ТекЯчейка = СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[1];
					Если ТипЗнч(ТекЯчейка) = Тип("ЭлементЯкорьHTML") Тогда
						
						Название = СокрЛП(ТекЯчейка.ТекстовоеСодержимое);
						ГиперСсылка = НайтиИмяФайлаПоСсылке(ТекЯчейка.ГиперСсылка);
						
						НайтиСоздатьПрограмму(Название, Группа, ГиперСсылка, ,Перечисления.UPD_СайтОбновлений.UsersV81C, ТекИмяГруппы);
						
					КонецЕсли;
				КонецЕсли;
			КонецЦикла;
			Возврат;
		КонецЕсли;
			
		Если ЭлДок.ЕстьДочерниеУзлы() Тогда
			
			РекурсивныйПарсингСпискаКонфигураций(ЭлДок);
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры
...Показать Скрыть
olesha; BigB; +2 Ответить 1
3. Алексей Коробов (olesha) 09.07.14 16:57
4. Максим Литвинов (maksa2005) 10.12.14 19:03
А бесплатно можно скачать обновление или нужен логин и пароль?
5. Павел Алексеенко (qwinter) 10.12.14 19:36
(4) maksa2005, нужен логин и пароль.
6. Сергей (Che) Коцюра (CheBurator) 10.12.14 20:46
а обработка скачивает только минимально необходимый набор обновлений от текущей конфигурации (как задать версию?) до актуальной? - например - купил я коробку БП3 корп - в ней диск с весрийе аж в районе февраля - ручками пришлось скачивать все (миниамльно необходимые) обновления - 10 штук (обновлений же гораздо больше...).
???
7. Павел Алексеенко (qwinter) 10.12.14 21:10
(6) CheBurator,
программа скачивает с указанной в настройках даты. Для каждой конфигурации можно указать свою дату начала скачивания. Соответственно скачиваться будут только релизы, которые вышли позже указанных дат.

P.S. Данное касается естественно только релизов с users.v8.1c.ru, т.к. на остальных сайтах или нет полного списка релизов.
8. pallid *** (white_sochi) 16.12.14 11:17
Как работает скачивание 7.70 конфигураций?
Их нет в списке...
9. Павел Алексеенко (qwinter) 16.12.14 12:07
(8) white_sochi, вводите пароль от http://techsupp.1c.ru в настройках. Затем обновляете список программ. После можно установить, что будет загружаться.
10. Александр (zato1c) 04.08.15 14:21
11. Павел Алексеенко (qwinter) 04.08.15 14:33
(10) zato1c, обрадовало нас 1С обновленным сайтом)) Обновление будет сегодня-завтра.
12. Павел Алексеенко (qwinter) 04.08.15 17:42
13. Александр (zato1c) 05.08.15 11:04
(12) qwinter, эх только $ потратил, все равно не пашет, https://releases.1c.ru/ да же не показывает Релизы 8x втабл части, хотя выбор в настройках сайт появился!
14. Павел Алексеенко (qwinter) 05.08.15 11:21
(13) zato1c, действительно ошибка в получение конфигураций.

В общем модуле: "UPD_ЗагрузкаКонфигураций" в процедуре "РекурсивныйПарсингСпискаКонфигураций"

Если СокрЛП(ЭлДок.ТекстовоеСодержимое) = "Название" Тогда
			
			//количество строк в таблице дистрибутивов
			СписокУзловHTML = ЭлДок.РодительскийУзел.РодительскийУзел.РодительскийУзел.ДочерниеУзлы[1].ДочерниеУзлы;
			КолЭлементов = СписокУзловHTML.Количество();
			
			Для А=0 По КолЭлементов-1 Цикл
					
				Если СписокУзловHTML[А].ДочерниеУзлы.Количество()=1 ИЛИ СписокУзловHTML[А].ДочерниеУзлы.Количество()=2 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0].ТекстовоеСодержимое);	
					Группа = НайтиСоздатьГруппу(ТекИмяГруппы, Справочники.UPD_Программы.v8, Истина);
...Показать Скрыть

Замените на:
Если СокрЛП(ЭлДок.ТекстовоеСодержимое) = "Название" Тогда
			
			//количество строк в таблице дистрибутивов
			СписокУзловHTML = ЭлДок.РодительскийУзел.РодительскийУзел.РодительскийУзел.ДочерниеУзлы[2].ДочерниеУзлы;
			КолЭлементов = СписокУзловHTML.Количество();
			
			Для А=0 По КолЭлементов-1 Цикл
					
				Если СписокУзловHTML[А].ДочерниеУзлы.Количество() = 1 ИЛИ СписокУзловHTML[А].ДочерниеУзлы.Количество() = 2 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ТекстовоеСодержимое);	
					Группа = НайтиСоздатьГруппу(ТекИмяГруппы, Справочники.UPD_Программы.v8, Истина);
...Показать Скрыть
15. Александр (zato1c) 05.08.15 12:03
{Справочник.UPD_Программы.Форма.ФормаЭлемента.Форма(37)}: Значение не является значением объектного типа (Ссылка)
СтруктураВозвращаемыхДанных = ПолучитьТекстНовогоВВерсии(Элементы.Версии.ТекущиеДанные.Ссылка);
там так и потянется. ладно не замарачивайся, а вот если бы вот это подшаманил (если смог бы), было бы респект http://infostart.ru/public/287082/ видно хозяин пропал, а весЧ не плоха
16. Павел Алексеенко (qwinter) 05.08.15 12:12
(15) zato1c, замените процедуру.
&НаКлиенте
Процедура ВерсииПриАктивизацииСтроки(Элемент)
	
	ТекДанные = Элементы.Версии.ТекущиеДанные;
	Если ТекДанные <> Неопределено Тогда
		СтруктураВозвращаемыхДанных = ПолучитьТекстНовогоВВерсии(.Ссылка);
		Если СтруктураВозвращаемыхДанных.ФайлНайден Тогда
			Элементы.НовоеВВерсии.Видимость = Истина;
			НовоеВВерсии = СтруктураВозвращаемыхДанных.ТекстНовоеВВерсии;
		Иначе
			Элементы.НовоеВВерсии.Видимость = Ложь;
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть
17. Павел Алексеенко (qwinter) 05.08.15 12:16
(15) zato1c, моя конфа значительно превосходит эту обработку.
18. Павел Алексеенко (qwinter) 05.08.15 12:19
блин в предыдущем посте ошибка. Вот правильный код.
&НаКлиенте
Процедура ВерсииПриАктивизацииСтроки(Элемент)
    
    ТекДанные = Элементы.Версии.ТекущиеДанные;
    Если ТекДанные <> Неопределено Тогда
        СтруктураВозвращаемыхДанных = ПолучитьТекстНовогоВВерсии(ТекДанные.Ссылка);
        Если СтруктураВозвращаемыхДанных.ФайлНайден Тогда
            Элементы.НовоеВВерсии.Видимость = Истина;
            НовоеВВерсии = СтруктураВозвращаемыхДанных.ТекстНовоеВВерсии;
        Иначе
            Элементы.НовоеВВерсии.Видимость = Ложь;
        КонецЕсли;
    КонецЕсли;
    
КонецПроцедуры
...Показать Скрыть
19. Александр (zato1c) 05.08.15 13:00
Вроде начал крутится, по наблюдаем, спасибо за ранее!
20. Александр (zato1c) 05.08.15 15:00
Скачал пару релизов и сказал, что все задания выполнены, так что увы!
21. Павел Алексеенко (qwinter) 05.08.15 15:14
(20) zato1c, а Вы точно все настроили?))) Проверьте даты начала загрузок.
22. Александр (zato1c) 06.08.15 13:43
Сутки крутил. Итог бухгалтерия и зуп нет! как 8,2 так 8,3 все перебрал. Было бо не плохо прописывать пути кача релизов. Люди привыкли к определенному порядку. ну и для гурманов) оповещение на @ хотя бы, что вышло и с качалось(это так на всякий))
23. Павел Алексеенко (qwinter) 06.08.15 14:43
(22) zato1c, я не понимаю, что именно у вас вызывает такие проблемы с настройкой. У меня все прекрасно скачивается. Да и пути тоже можете прописывать какие хотите.
Прикрепленные файлы:
24. Александр (zato1c) 07.08.15 14:19
молодец конечно, что написал. Но как то все живет отдельной жизнью, что качает, сколько качает, ХЗ
25. AvtoBuhgalter ООО (AvtoBuhgalter) 24.09.15 06:31
Возник такой вопрос:
Я не Франч и общего доступа к сайту обновлений нет.
Есть доступ у различных клиентов к разным конфигурациям. Т.е. к одному и тому же сайту обновлений нужна привязка какую конфигурацию под каким пользователем нужно качать.
Есть такая возможность? Или возможно ли её реализовать?
26. Павел Алексеенко (qwinter) 24.09.15 07:46
(25) AvtoBuhgalter, есть возможность ввести несколько пользователей. Для каждого пользователя будут качаться доступные ему обновления.
27. pallid *** (white_sochi) 14.10.15 17:34
Обработка UPD_ПостроениеЦепочкиОбновлений

СТР 77

ПутьКФайлу = ЭлементСписка.Значение + "\1c\" + ИмяПапкиШаблона + "\" + ИмяВерсии + "\1cv8.cfu";


строка "\1с\" не во всех случаях такая, например у отраслевой БСО, должно быть "\IMPULS-IVC\"
28. Павел Алексеенко (qwinter) 14.10.15 18:59
(27) white_sochi, если подскажите, где это можно в автоматическом режиме взять с сайта релизов 1с буду благодарен.
29. pallid *** (white_sochi) 15.10.15 10:21
(28) qwinter, а вот нигде к сожалению.
Давайте в справочнике просто всем типовым проставим директорию "1С", а остальным, чтобы пользователь сам указывал где искать
30. Павел Алексеенко (qwinter) 15.10.15 20:24
(29) white_sochi, так и сделаем) напишите почту свою, я вам обновленную версию вышлю.
31. Павел - (Snork) 21.07.16 13:51
Можно добавить еще скачивание релизов КАМИН?
Сайт:
http://www.kaminsoft.ru/component/kaminsupport/?Itemid=50
32. Павел - (Snork) 22.07.16 12:25
В отчете по последним версиям не хватает режима, когда выводит только измененные за последние Х дней конфигурации
33. Павел Алексеенко (qwinter) 23.07.16 11:31
(31) Snork, у меня нет ни одной учетной записи камина, что бы даже посмотреть как там устроено.
34. Павел Алексеенко (qwinter) 23.07.16 11:31
(32) Snork, так можно поставить отбор))
35. Евгений Ульянов (EvgenURNN) 31.08.16 14:39
при попытке развернуть с пустой базы 1.0.3.6. пытается вполнить обновление (похоже на то, что там начальное заполнение) выдает ошибку
{ОбщийМодуль.UPD_ОбновлениеБазыДанных.Модуль(209)}: Ошибка при вызове метода контекста (ПрочитатьXML)
ЗаписанноеЗначение = ПрочитатьXML(ЧтениеXML);
по причине:
Ошибка преобразования данных XML: [sfile://C:/Users/Evgenu/AppData/Local/Temp/UPD_КонфигурацииИВерсииV8.txt][202566,3]

Версия платформы 1С:Предприятие 8.3 (8.3.8.1933)
36. Павел Алексеенко (qwinter) 31.08.16 22:43
(35) EvgenURNN, странно. Попробуйте на 8.3.5 развернуть начальный вариант.
37. Евгений Ульянов (EvgenURNN) 07.09.16 17:54
(36) qwinter, Поразбирался маленько, ошибка из-за того, что в конфигурации больше реквизитов: ПорядокГруппы, ВыводитьВОтчет и КаталогПоставщика. В макете нет таких реквизитов. Сериализатор валится с ошибкой из-за этого.
Сейчас все работает.
38. Алексей Ермилов (Alex_E) 22.09.16 08:32
(35) EvgenURNN, Та же ошибка, скачал и установил сегодня.... Автор, исправлять бум?
39. Павел Алексеенко (qwinter) 22.09.16 10:09
(38) Alex_E, будем). просто хотел и все версии обновить в начальном заполнении, но все руки не доходят. Если срочно лечится очень просто. У справочника UPD_Программы удаляете реквизит КаталогПоставщика. И в общем модуле UPD_ОбновлениеБазыДанных в функции ВерсияКонфигурации устанавливаете версию 1.0.3.5. Запускаете 1С. Как прошло начальное заполнение накатываете конфигурацию.
40. Алексей Ермилов (Alex_E) 22.09.16 10:14
41. Павел Алексеенко (qwinter) 22.09.16 14:24
(40) Alex_E, все поправил) если еще сами не делали напишите почту, я вам вышлю конфигурацию.
42. Юлия Коломенская (Апрель-С) 14.11.16 13:01
Есть две проблемы в версии 1.0.3.7:
1. У нас не работает обновление справочника версий. Проблема насколько я понял таиться в модуле "UPD_ЗагрузкаОбновленийV8"
Функция ЗагрузитьКонфигурации(ПользовательСайта) Экспорт
	
	ИдентификаторСессии = UPD_ЗагрузкаОбновленийПовтИсп.НайтиИдентификаторСессииV8(ПользовательСайта);
	
	Попытка
		
		Загружено = 0;
		Запрос = Новый HTTPЗапрос;
		Запрос.Заголовки.Вставить("Cookie", ИдентификаторСессии.JSESSIONID);
		Запрос.АдресРесурса = "/total";
		
		Соединение2 = Новый HTTPСоединение("releases.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
		
		ОтветHTTP = Соединение2.Получить(Запрос);
		
		ЧтениеHTML = Новый ЧтениеHTML;
		ЧтениеHTML.УстановитьСтроку(ОтветHTTP.ПолучитьТелоКакСтроку());
		
		Построитель = Новый ПостроительDOM;
		ДокументHTML = Построитель.Прочитать(ЧтениеHTML);
		
		ИскатьВерсиюПлатформы = Константы.UPD_ИскатьТребуемуюВерсиюПлатформы.Получить();
		
		Если ИскатьВерсиюПлатформы Тогда
			РекурсивныйПарсингСпискаКонфигураций(ДокументHTML, ИскатьВерсиюПлатформы, ПользовательСайта);
		Иначе
			РекурсивныйПарсингСпискаКонфигураций(ДокументHTML); //АС: Здесь наверное не хватает параметра "ПользовательСайта" 
		КонецЕсли;

		ЗагрузитьВерсииV8(ПользовательСайта);
		
	Исключение
		
		UPD_РегламентныеЗадания.ЗаписатьОшибку(ОписаниеОшибки());
		Возврат Ложь;
		
	КонецПопытки;
	
	Возврат Истина;
	
КонецФункции
...Показать Скрыть


2. Если используется несколько пользователей для загрузки с сайта "releases.1c.ru", то выполнение кода падает с ошибкой неуникальности ключа фоновых заданий. Поэтому ключ нужно или генерировать случайный, или в разрезе пользователей сайта. А вообще лучше сначала построить список доступных ПП по разным пользователям, а уже потом парсить версии. У разных пользователей могут быть одинаковые ПП в списке. Проблемы начинаются при параллельной записи в базу новых ПП, доступ к которым есть у двух пользователей.
43. Сергей Сергеев (SERJ_1CC) 17.11.16 08:33
(41) qwinter, Павел, Ваша конфигурация сейчас работает или нет, а то что-то не понятно по отзывам, вроде опять что-то поменялось на сайте 1С?
44. Павел Алексеенко (qwinter) 17.11.16 20:21
(43) SERJ_1CC, работает, проблемы только у тех, кто использует несколько логинов к сайту релизов.
45. Сергей Сергеев (SERJ_1CC) 18.11.16 07:29
(44) qwinter, Понял, спасибо, сегодня скачаю посмотрю, а вообще я имел ввиду то что сайт releases.1c.ru сейчас переделали и что теперь скачивание обновлений идет с https://dl03.1c.ru
46. Сергей Сергеев (SERJ_1CC) 18.11.16 07:37
(45) я же Вас правильно понимаю, конфигурация парсит сайт и вытягивает файлы обновлений updsetup.exe без сторонних исполняемых компонент?
47. Павел Алексеенко (qwinter) 18.11.16 13:55
(46) SERJ_1CC,
а вообще я имел ввиду то что сайт releases.1c.ru сейчас переделали и что теперь скачивание обновлений идет с https://dl03.1c.ru
все работает.
я же Вас правильно понимаю, конфигурация парсит сайт и вытягивает файлы обновлений updsetup.exe без сторонних исполняемых компонент?
исключительно код 1С
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа