gifts2017

1С 8.2-8.3. Создать на основании новый документ или открыть существующий.

Опубликовал e401 (e401) в раздел Программирование - Практика программирования

1С 8.2-8.3 Ввод документа на основании. Если такой документ уже создан, то открыть существующий.

Условие задачи: В конфигурацию добавлен документ , который должен заполняться на основании другого документа, например, "Реализация товаров и услуг". Причем, создан на основании может быть только один документ.

Собственно задача: Используя типовой "Ввод на основании" создать новый документ. Если таковой уже создан, то открыть существующий. Как вариант, открыть не сам документ, а форму списка с позиционированием на нем.

Готового решения не сумел найти. Может плохо искал. В типовой Бухгалтерии 3.0, например, при попытке ввести "Счет-фактуру выданный" на основании РТиУ при уже существующем, вызывается исключение и просто выдается сообщение о том, что таковой уже есть.

Немного помучался и сделал так:

В модуле формы заполняемого документа (СборкаПродукции) использую событие формы документа "ПриОткрытии":

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ДокСсылка = ПриОткрытииНаСервере();
    Если ДокСсылка <> 0 Тогда
        Отказ = Истина;
        ОткрытьЗначение(ДокСсылка);
        //Если нужно открыть не сам документ, а список с позиционированием на документе, то пред. строку заменить на:
        //ДопПараметры = Новый Структура("ТекущаяСтрока", ДокСсылка);
        //ОткрытьФорму("Документ.СборкаПродукции.ФормаСписка", ДопПараметры);        
    КонецЕсли;
КонецПроцедуры

&НаСервере
Функция ПриОткрытииНаСервере()
    Если  НЕ РеквизитФормыВЗначение("Объект").ЭтоНовый() Тогда
        Возврат 0; //открывается уже существующий док
    Иначе    
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
        |    СборкаПродукции.Ссылка
        |ИЗ
        |    Документ.СборкаПродукции КАК СборкаПродукции
        |ГДЕ
        |    СборкаПродукции.ДокументОснование.Ссылка = &ТекДокОснСсылка";
        Запрос.УстановитьПараметр("ТекДокОснСсылка", Объект.ДокументОснование);
        Результат = Запрос.Выполнить();
        Если Результат.Пустой() Тогда
            Возврат 0; // документа нет
        Иначе
            Выборка = Результат.Выбрать();
            Выборка.Следующий();
            Возврат Выборка.Ссылка; //Возвращаем ссылку на существующий док
        КонецЕсли;
    КонецЕсли;
КонецФункции

Собственно все.

Прошу сильно не ругать - это моя первая публикация. За поправки и подсказки буду благодарен.

 

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Марченко (MarSeN) 15.05.14 23:37
Для первого опыта пойдет. Но только не для рабочих баз:
1. У Вас не предусмотрен ввод на основании программным способом. Т.е программно получится ввести дубли. Надо добавить проверку и генерировать исключение (у Вас проверки, скорее всего, нет, раз срабатывает проц. ПриОткрытии)
2. В Вашем случае ввод на основании все-равно выполняется, но не сохраняется, если есть дубль
3. ИМХО Так как Вы делаете на УФ, то правильнее выполнить данную задачу, подменив команду ввода на основании. Т.е. Стандартную команду ввода на основании скрываете и создаете свою. В модуле команды на сервере осуществляете поиск, если нет документа - создаете ч.з открытьФорму с параметром Основание, Если есть документ то тоже чз открыть форму с параметром Ключ
mevgenym; softcreator; e401; +3 Ответить 1
2. e401 (e401) 16.05.14 12:06
(1) MarSeN,
Понял, спасибо, учту, сделаю. Не совсем понял, как скрыть-подменить команду ввода на основании
3. Сергей Марченко (MarSeN) 17.05.14 12:06
(2) e401,
Если команда ввода на основании создается автоматически, тогда надо в объекте Ввод на основании убрать документ, для которого хотите подменить команду на свою.
далее добавляете свою команду и реализуете то что писал выше
4. Aleksandr Filonov (AleksSF) 23.09.15 16:47
Если использовать БСП, то можно еще проще.
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	// СтандартныеПодсистемы.ВерсионированиеОбъектов
	ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтаФорма);
	// Конец СтандартныеПодсистемы.ВерсионированиеОбъектов	
	Если Объект.Номер = "" Тогда
		Запрос = Новый Запрос;
		Запрос.Текст = 
			"ВЫБРАТЬ
			|	СвязанныеДокументы.Ссылка
			|ИЗ
			|	КритерийОтбора.СвязанныеДокументы(&ТекущийДокумент) КАК СвязанныеДокументы";

		Запрос.УстановитьПараметр("ТекущийДокумент", Объект.Основание);
		РезультатЗапроса = Запрос.Выполнить();
		Если Не РезультатЗапроса.Пустой() Тогда
			ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
			Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
				Сообщение = Новый СообщениеПользователю;
				Сообщение.Текст = "Это выполнение ЗАКРЫТО " + ВыборкаДетальныеЗаписи.Ссылка;
				Сообщение.Поле = "";
				Сообщение.УстановитьДанные(ВыборкаДетальныеЗаписи.Ссылка.ПолучитьОбъект());
				Сообщение.Сообщить();
				Отказ = Истина;
			КонецЦикла;
			Возврат;
		КонецЕсли; 
		Если Объект.Основание.ДатаВыполнения <> '00010101' Тогда
			Сообщение = Новый СообщениеПользователю;
			Сообщение.Текст = "Закрывать можно только выполненную заявку";
			Сообщение.Сообщить();
			Отказ = Истина;
			Возврат;
		КонецЕсли; 
	КонецЕсли; 
	// Если документ введен на основании, то запретим редактировать основание
	Если Не Объект.Основание.Пустая() И Объект.Проведен Тогда
		Элементы.Основание.ТолькоПросмотр = Истина;
	Иначе
		Элементы.Основание.ТолькоПросмотр = Ложь;
	КонецЕсли; 
	Если Объект.Ответственный = Справочники.Пользователи.ПустаяСсылка() Тогда
		Объект.Ответственный = ПараметрыСеанса.ТекущийПользователь;
	КонецЕсли; 
КонецПроцедуры
...Показать Скрыть
WellMaster; +1 Ответить
5. Артем Артем (artik1994) 15.07.16 14:43
зачем все эти заморочки из бочки???
для нас упростили жизнь и создали конструктор ввода на основании...
смиритесь и пользуйтесь с удовольствием
6. e401 (e401) 18.07.16 07:45
(5) artik1994,
Вы не поняли суть: Используя типовой "Ввод на основании" создать новый документ. Если таковой уже создан, то открыть существующий, а не выводить сообщение о том, что такой документ уже создан.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа