Поиск и замена значений 8.3

Опубликовал Валентин Губин (Goobin) в раздел Обработки - Универсальные обработки

Обработка с диска ИТС, изменена для работы в управляемом приложении.

Обработка с диска ИТС, изменена для работы в управляемом приложении.

Скачать файлы

Наименование Файл Версия Размер
ПоискИЗаменаЗначений83.epf
.epf 11,04Kb
16.09.14
1360
.epf 11,04Kb 1360 Скачать

См. также

PowerTools от 1 000
Комментарии
1. Наталья (kisson) 13.06.14 00:30 Сейчас в теме
эхх, а она так нужна сейчас...

{Форма.Форма.Форма(168)}: Итератор для значения не определен
Для Каждого Реквизит Из ТекущиеМетаданные Цикл
2. Айрат (Craig) 177 15.06.14 19:55 Сейчас в теме
Ой как не хватает автопоиска
3. Vladimir (Boroda) 90 19.07.14 13:48 Сейчас в теме
Два отзыва - и те с критикой.... Ладно, попробую скачать и протестировать на корректность работы - вещь-то нужная, как-никак. Странно, что 1С до сих пор не выложила её на ITS-ке.
4. Ivan B (wolverine87) 04.08.14 16:38 Сейчас в теме
Да, давно пора перейти на 3.0. Обработка явно хорошая. Как перейду - по-тестирую обязательно. +1
5. Константин Купрюхин (BlackStar) 09.09.14 19:24 Сейчас в теме
В БП 3.0 все работает, не хватает только возможности отметить\снять отметку для всех объектов. И по результатам замены никакого информационного окна нет
6. Алексей Патюков (apatyukov) 829 16.12.14 14:05 Сейчас в теме
В интерфейсе такси не дает выбрать объекты.
7. Валентин Губин (Goobin) 35 17.12.14 07:23 Сейчас в теме
Запустил в "Такси"

1С:Предприятие 8.3 (8.3.5.1248)
Бухгалтерия предприятия, редакция 3.0 (3.0.35.26)

Вроде работает...
Прикрепленные файлы:
8. Тимофей (eruil) 09.01.15 16:14 Сейчас в теме
Процесс запуска не происходит. В чем может быть дело?
9. Валентин Губин (Goobin) 35 12.01.15 06:52 Сейчас в теме
(8) eruil,

Толстый клиент, например.
11. Татьяна (Душечка) 70 02.02.15 23:23 Сейчас в теме
Огромное спасибо. Выручили. Под рукой не было диска ИТС, но инфостарт всегда придет на выручку. Я совершала синхронизацию между БП 3.0 и ЗУП 3.0 . Может не правильно настроила синхронизацию, но помоему в ЗУПе проще простого, но задвоились ИФНС. Вы спасли.
12. Дмитрий Глеков (glek) 111 27.02.15 17:35 Сейчас в теме
Все хорошо, только надо бы добавить установку привелегированного режима. Потому как есть объекты (например последовательности), для которых в типовых вообще не установлен признак изменения. Только чтение и просмотр. На таких объектах валится.
А вообще - обработка классная. Разумеется, хотелось бы большую кнопку "СДЕЛАТЬ ЗАШИБИСЬ" )))
13. Мария Соколова (Мириам) 05.03.15 16:47 Сейчас в теме
Добрый день! Спасибо за обработку. Она действительно супер.
Но подскажите пож-та в выборе типа данных нет справочника номенклатура?, т.е. с помощью этой обработки нельзя заменить дублеры номенклатуры в документах? Спасибо!
14. Валентин Губин (Goobin) 35 13.03.15 14:26 Сейчас в теме
Такое может быть если в метаданных нет справочника номенклатура.
15. Валентин Губин (Goobin) 35 13.03.15 14:27 Сейчас в теме
(13) Мириам, Такое может быть если в метаданных нет справочника номенклатура.
16. kotenok2710 16.03.15 18:13 Сейчас в теме
Спасибо, все работает)))
baracuda; +1 Ответить
17. Вячеслав (ivnik) 372 24.03.15 22:52 Сейчас в теме
Очень не плохая обработка, но одно замечание есть: при выборе "На что заменить" снова открывается выбор типа данных, что является неудобным (для 8.2 сразу открывался тот же самый справочник, который был выбран в поле "Что заменить").
18. Вадим Арсёнкин (::Green::) 41 16.04.15 08:06 Сейчас в теме
(17) ivnik, там такого не было, там тоже открываются метаданные
19. Айрат Саттаров (kwazi) 175 22.09.15 23:25 Сейчас в теме
А с регистрами бухгалтерии она также плохо отрабатывает как и та что на диске ИТС?
там в измерения валюта и подразделение попадает пустая ссылка вместо неопределено после замены значений для счетов с отключенным учетом по валютам (подразделениям)
20. Валентин Губин (Goobin) 35 23.09.15 05:51 Сейчас в теме
(19) kwazi, эта обработка функционально ничем от ИТС-овской не отличается
21. Николай Сенаторов (Mortal) 80 11.10.15 16:49 Сейчас в теме
На УНФ 1.6.1.44, платф.8.3.6.2332 работает. Плюс.
23. Юрий Чертоляс (juricher) 4 12.04.16 23:51 Сейчас в теме
(15) Goobin, и что делать, если надо исправить номенклатуру в УТ 11? Как это в объектах метаданных нет справочника "Номенклатура"? Открываем конфигуратор - есть, открываем "все функции" - есть, в обработке - нет. Странно
24. Валентин Губин (Goobin) 35 13.04.16 06:18 Сейчас в теме
Если Вы про поля «Что заменять» и «На что заменять», то оба поля содержат тип «Любая ссылка» и игнорировать ссылку на справочник (любой) не должны, а обработка не вмешивается в процесс выбора типа ссылки.

Хотелось бы увидеть это явление, но УТ 11 у меня нет.
25. Валентин Губин (Goobin) 35 13.04.16 07:50 Сейчас в теме
(23) juricher,
Если Вы про поля «Что заменять» и «На что заменять», то оба поля содержат тип «Любая ссылка» и игнорировать ссылку на справочник (любой) не должны, а обработка не вмешивается в процесс выбора типа ссылки.

Хотелось бы увидеть это явление, но УТ 11 у меня нет.
26. Андрей Асанов (victorree) 25.04.16 07:59 Сейчас в теме
(13) Мириам, вероятно УТ? (23) juricher Там номенклатура называется "Позиция номенклатуры", а вообще в конфигураторе смотрите как называется позиция справочника номенклатура.
27. Insanity Coming (Insanity) 69 02.06.16 11:51 Сейчас в теме
Вроде взлетело, бухи довольны что увидели знакомую картинку. Единственное, чтобы зарегистрировать обработку во внешних, в модуль объекта нужно вставить код:
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");
	ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    //ПараметрыРегистрации.Вставить("Назначение", …);  //только для назначаемых обработок, для глобальных – не используется
    ПараметрыРегистрации.Вставить("Наименование", "Поиск и замена значений");
    ПараметрыРегистрации.Вставить("Версия", "v 1.0");
    ПараметрыРегистрации.Вставить("Информация", "Обработка переделана из стандартной для 8.2");
    //ПараметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4"); 
    Команды = ТаблицаКоманд();
    ДобавитьКоманду(Команды,
                    "Поиск и замена значений",
                    "ОткрытьОбработку",
                    "ОткрытиеФормы",
                    Ложь,
                    "");
    ПараметрыРегистрации.Вставить("Команды", Команды);
    Возврат ПараметрыРегистрации; 
КонецФункции
Функция ТаблицаКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры
...Показать Скрыть
28. Игорь Зуйков (quares) 20 03.03.17 12:12 Сейчас в теме
А на каком диске вы её нашли, смотрел на январском 2017, нет его....
29. Айрат Саттаров (kwazi) 175 04.03.17 20:10 Сейчас в теме
(28) search and change есть на любом диске только для обычного приложения.
Its\exe\extreps\unireps82