gifts2017

Поиск и замена значений 8.3

Опубликовал Валентин Губин (Goobin) в раздел Обработки - Универсальные обработки

Обработка с диска ИТС, изменена для работы в управляемом приложении.

Обработка с диска ИТС, изменена для работы в управляемом приложении.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ПоискИЗаменаЗначений83.epf
.epf 11,04Kb
16.09.14
1269
.epf 11,04Kb 1269 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Наталья (kisson) 13.06.14 00:30
эхх, а она так нужна сейчас...

{Форма.Форма.Форма(168)}: Итератор для значения не определен
Для Каждого Реквизит Из ТекущиеМетаданные Цикл
2. Айрат (Craig) 15.06.14 19:55
Ой как не хватает автопоиска
3. Vladimir (Boroda) 19.07.14 13:48
Два отзыва - и те с критикой.... Ладно, попробую скачать и протестировать на корректность работы - вещь-то нужная, как-никак. Странно, что 1С до сих пор не выложила её на ITS-ке.
4. Ivan B (wolverine87) 04.08.14 16:38
Да, давно пора перейти на 3.0. Обработка явно хорошая. Как перейду - по-тестирую обязательно. +1
5. Константин Купрюхин (BlackStar) 09.09.14 19:24
В БП 3.0 все работает, не хватает только возможности отметить\снять отметку для всех объектов. И по результатам замены никакого информационного окна нет
6. Алексей Патюков (apatyukov) 16.12.14 14:05
В интерфейсе такси не дает выбрать объекты.
7. Валентин Губин (Goobin) 17.12.14 07:23
Запустил в "Такси"

1С:Предприятие 8.3 (8.3.5.1248)
Бухгалтерия предприятия, редакция 3.0 (3.0.35.26)

Вроде работает...
Прикрепленные файлы:
8. Тимофей (eruil) 09.01.15 16:14
Процесс запуска не происходит. В чем может быть дело?
9. Валентин Губин (Goobin) 12.01.15 06:52
(8) eruil,

Толстый клиент, например.
11. Татьяна (Душечка) 02.02.15 23:23
Огромное спасибо. Выручили. Под рукой не было диска ИТС, но инфостарт всегда придет на выручку. Я совершала синхронизацию между БП 3.0 и ЗУП 3.0 . Может не правильно настроила синхронизацию, но помоему в ЗУПе проще простого, но задвоились ИФНС. Вы спасли.
12. Дмитрий Глеков (glek) 27.02.15 17:35
Все хорошо, только надо бы добавить установку привелегированного режима. Потому как есть объекты (например последовательности), для которых в типовых вообще не установлен признак изменения. Только чтение и просмотр. На таких объектах валится.
А вообще - обработка классная. Разумеется, хотелось бы большую кнопку "СДЕЛАТЬ ЗАШИБИСЬ" )))
13. Мария Соколова (Мириам) 05.03.15 16:47
Добрый день! Спасибо за обработку. Она действительно супер.
Но подскажите пож-та в выборе типа данных нет справочника номенклатура?, т.е. с помощью этой обработки нельзя заменить дублеры номенклатуры в документах? Спасибо!
14. Валентин Губин (Goobin) 13.03.15 14:26
Такое может быть если в метаданных нет справочника номенклатура.
15. Валентин Губин (Goobin) 13.03.15 14:27
(13) Мириам, Такое может быть если в метаданных нет справочника номенклатура.
16. kotenok2710 16.03.15 18:13
Спасибо, все работает)))
baracuda; +1 Ответить
17. Вячеслав (ivnik) 24.03.15 22:52
Очень не плохая обработка, но одно замечание есть: при выборе "На что заменить" снова открывается выбор типа данных, что является неудобным (для 8.2 сразу открывался тот же самый справочник, который был выбран в поле "Что заменить").
18. Вадим Арсёнкин (::Green::) 16.04.15 08:06
(17) ivnik, там такого не было, там тоже открываются метаданные
19. Айрат Саттаров (kwazi) 22.09.15 23:25
А с регистрами бухгалтерии она также плохо отрабатывает как и та что на диске ИТС?
там в измерения валюта и подразделение попадает пустая ссылка вместо неопределено после замены значений для счетов с отключенным учетом по валютам (подразделениям)
20. Валентин Губин (Goobin) 23.09.15 05:51
(19) kwazi, эта обработка функционально ничем от ИТС-овской не отличается
21. Николай Сенаторов (Mortal) 11.10.15 16:49
На УНФ 1.6.1.44, платф.8.3.6.2332 работает. Плюс.
23. Юрий Чертоляс (juricher) 12.04.16 23:51
(15) Goobin, и что делать, если надо исправить номенклатуру в УТ 11? Как это в объектах метаданных нет справочника "Номенклатура"? Открываем конфигуратор - есть, открываем "все функции" - есть, в обработке - нет. Странно
24. Валентин Губин (Goobin) 13.04.16 06:18
Если Вы про поля «Что заменять» и «На что заменять», то оба поля содержат тип «Любая ссылка» и игнорировать ссылку на справочник (любой) не должны, а обработка не вмешивается в процесс выбора типа ссылки.

Хотелось бы увидеть это явление, но УТ 11 у меня нет.
25. Валентин Губин (Goobin) 13.04.16 07:50
(23) juricher,
Если Вы про поля «Что заменять» и «На что заменять», то оба поля содержат тип «Любая ссылка» и игнорировать ссылку на справочник (любой) не должны, а обработка не вмешивается в процесс выбора типа ссылки.

Хотелось бы увидеть это явление, но УТ 11 у меня нет.
26. Андрей Асанов (victorree) 25.04.16 07:59
(13) Мириам, вероятно УТ? (23) juricher Там номенклатура называется "Позиция номенклатуры", а вообще в конфигураторе смотрите как называется позиция справочника номенклатура.
27. Insanity Coming (Insanity) 02.06.16 11:51
Вроде взлетело, бухи довольны что увидели знакомую картинку. Единственное, чтобы зарегистрировать обработку во внешних, в модуль объекта нужно вставить код:
Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");
	ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    //ПараметрыРегистрации.Вставить("Назначение", …);  //только для назначаемых обработок, для глобальных – не используется
    ПараметрыРегистрации.Вставить("Наименование", "Поиск и замена значений");
    ПараметрыРегистрации.Вставить("Версия", "v 1.0");
    ПараметрыРегистрации.Вставить("Информация", "Обработка переделана из стандартной для 8.2");
    //ПараметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4"); 
    Команды = ТаблицаКоманд();
    ДобавитьКоманду(Команды,
                    "Поиск и замена значений",
                    "ОткрытьОбработку",
                    "ОткрытиеФормы",
                    Ложь,
                    "");
    ПараметрыРегистрации.Вставить("Команды", Команды);
    Возврат ПараметрыРегистрации; 
КонецФункции
Функция ТаблицаКоманд()
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;
КонецФункции
Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры
...Показать Скрыть
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа