IE2017

Открытие формы документа на клиенте.

Программирование - Практика программирования

Открытие формы документа на клиенте из другого объекта конфигурации с заполненными реквизитами.

Необходимо прописать в объекте, из которого нужно открыть документ:

&НаКлиенте
Процедура Команда1(Команда)    
    ПараметрыДок = Новый Структура;
    ПараметрыДок.Вставить("КлиентОбъект",Объект.КлиентОбъект);
    ПараметрыДок.Вставить("ТипОбъекта",Объект.ТипОбъекта);
    ОткрытьФорму("Документ.Заявка.Форма.ФормаДокумента",ПараметрыДок);
КонецПроцедуры

Прописывается в самом документе:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Параметры.Свойство("КлиентОбъект") Тогда
        Объект.КлиентОбъект = Параметры.КлиентОбъект;
    КонецЕсли;
    Если Параметры.Свойство("ТипОбъекта") Тогда
        Объект.ТипОбъекта = Параметры.ТипОбъекта;
    КонецЕсли;   
КонецПроцедуры





См. также

Комментарии
1. BigB (BigB) 162 20.06.14 08:58 Сейчас в теме
(0), проще сделать так
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Если Объект.Ссылка.Пустая() Тогда
		ЗаполнитьЗначенияСвойств(Объект,Параметры);
	КонецЕсли;
КонецПроцедуры
...Показать Скрыть
Marija-08; CratosX; andogskiy; +3 Ответить
2. Александр Большаков (BACbKA666) 35 08.07.14 14:01 Сейчас в теме
Можно поставить у реквизитов объекта "Заполнять из данных заполнения"
При открытии формы передавать в параметры структуру ЗначенияЗаполнения, где
Ключ - имя реквизита
Значение - значение реквизита
И не надо ломать код в форме. Особенно важно это в типовых решениях
Kaavan; Marija-08; +2 Ответить
Оставьте свое сообщение