gifts2017

Универсальный поиск и замена дублирующихся элементов справочников (управляемое и обычное приложение) с учетом общих реквизитов

Опубликовал Евгений ' (WanGoff) в раздел Обработки - Универсальные обработки

Короче, обработка взята в http://infostart.ru/public/204468/
Добавлена замена в общих реквизитах справочников и документов. Выкладываю, ибо может кому нужно будет срочно. В описании есть код, который можно вставить в исходную обработку.
З.Ы. Для всех, кто скажет, что поиск и замену можно использовать типовую, в обычном приложении: если у вас есть подписки, методы которых лежат в модулях, в которых запрещен вызов сервера - у вас скорее всего возникнет необходимость использовать обработку в управляемом приложении.

Возникла необходимость удалить дубли в справочнике. Взял обработку http://infostart.ru/public/204468/


Однако, в конфигурации есть общие реквизиты, в которых так же нужно произвести замену. Пришлось добавить в код небольшие изменения: в процедуре, по сути, изменена одна процедура. Вот ее код. Может, кому пригодится.

 

&НаСервере
Функция ВыполнитьЗаменуЭлементовНаСервере(ПравильныйЭлемент, МассивСсылокПоиска = Неопределено)

Если МассивСсылокПоиска = Неопределено Тогда
ТаблицаСсылок = Неопределено;
ВыполнитьПоискСсылок(Ложь, ТаблицаСсылок);
Иначе
ТаблицаСсылок = НайтиПоСсылкам(МассивСсылокПоиска);
КонецЕсли;

БылиИсключения = Ложь;
Если ВыполнятьВТранзакции Тогда
НачатьТранзакцию();
КонецЕсли;
ОбрабатываемаяСсылка = Неопределено;

ПараметрыЗамены = Новый Структура;

Для Каждого РегистрБухгалтерии ИЗ Метаданные.РегистрыБухгалтерии Цикл
ПараметрыЗамены.Вставить(РегистрБухгалтерии.Имя+"Субконто", РегистрБухгалтерии.ПланСчетов.МаксКоличествоСубконто);
ПараметрыЗамены.Вставить(РегистрБухгалтерии.Имя+"Корреспонденция", РегистрБухгалтерии.Корреспонденция); 
КонецЦикла;

ПараметрыЗамены.Вставить("Объект", Неопределено); 

//Поймем, какие общие реквизиты подходят по типу и сделаем из них массив
ОбщиеРеквизиты = Новый Массив;

Для Инд = 0 По Метаданные.ОбщиеРеквизиты.Количество() - 1 Цикл 

Если Не Метаданные.ОбщиеРеквизиты[Инд].Тип.СодержитТип(ТипЗнч(ПравильныйЭлемент)) Тогда 

Продолжить;
КонецЕсли;

ОбщиеРеквизиты.Добавить(Метаданные.ОбщиеРеквизиты[Инд]);
КонецЦикла;
//

Для Каждого СтрокаТаблицы Из ТаблицаСсылок Цикл

Ссылка = СтрокаТаблицы.Ссылка;

Если ОбрабатываемаяСсылка <> СтрокаТаблицы.Данные Тогда
Если ОбрабатываемаяСсылка <> Неопределено и ПараметрыЗамены.Объект <> Неопределено Тогда

Если ОтключатьКонтрольЗаписи Тогда
ПараметрыЗамены.Объект.ОбменДанными.Загрузка = Истина;
КонецЕсли;

Попытка
ПараметрыЗамены.Объект.Записать();
Исключение
БылиИсключения = Истина;
Если ВыполнятьВТранзакции Тогда
Возврат ВыполнитьОткат();
КонецЕсли;
КонецПопытки;
ПараметрыЗамены.Объект = Неопределено;
КонецЕсли;
ОбрабатываемаяСсылка = СтрокаТаблицы.Данные;

КонецЕсли;


Если Метаданные.Документы.Содержит(СтрокаТаблицы.Метаданные) Тогда

Если ПараметрыЗамены.Объект = Неопределено Тогда
ПараметрыЗамены.Объект = СтрокаТаблицы.Данные.ПолучитьОбъект();
КонецЕсли;

Для Каждого Реквизит Из СтрокаТаблицы.Метаданные.Реквизиты Цикл
Если Реквизит.Тип.СодержитТип(ТипЗнч(Ссылка)) И ПараметрыЗамены.Объект[Реквизит.Имя] = Ссылка Тогда
ПараметрыЗамены.Объект[Реквизит.Имя] = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;

//Поймем, нужно ли менять значение в общем реквизите
Для Инд = 0 По ОбщиеРеквизиты.Количество() - 1 Цикл 
ОРеквизит = ОбщиеРеквизиты[Инд];
ЭлементСостава = ОРеквизит.Состав.Найти(СтрокаТаблицы.Данные.Метаданные());
Если Не ЭлементСостава = Неопределено И ЭлементСостава.Использование = Метаданные.СвойстваОбъектов.ИспользованиеОбщегоРеквизита.Использовать Тогда 
ПараметрыЗамены.Объект[ОРеквизит.Имя] = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;

Для Каждого ТЧ ИЗ СтрокаТаблицы.Метаданные.ТабличныеЧасти Цикл
Для Каждого Реквизит Из ТЧ.Реквизиты Цикл
Если Реквизит.Тип.СодержитТип(ТипЗнч(Ссылка)) Тогда
СтрокаТабЧасти = ПараметрыЗамены.Объект[ТЧ.Имя].Найти(Ссылка, Реквизит.Имя);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Реквизит.Имя] = ПравильныйЭлемент;
СтрокаТабЧасти = ПараметрыЗамены.Объект[ТЧ.Имя].Найти(Ссылка, Реквизит.Имя);
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецЦикла;

Для Каждого Движение ИЗ СтрокаТаблицы.Метаданные.Движения Цикл

ЭтоДвижениеРегистраБухгалтерии = Метаданные.РегистрыБухгалтерии.Содержит(Движение);
ЕстьКорреспонденция = ЭтоДвижениеРегистраБухгалтерии и ПараметрыЗамены[Движение.Имя + "Корреспонденция"];

НаборЗаписей = ПараметрыЗамены.Объект.Движения[Движение.Имя];
НаборЗаписей.Прочитать();
НадоЗаписывать = Ложь;
ТаблицаНабора = НаборЗаписей.Выгрузить();
Для Каждого Измерение ИЗ Движение.Измерения Цикл
Если Измерение.Тип.СодержитТип(ТипЗнч(Ссылка)) Тогда
Если ЕстьКорреспонденция Тогда
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "ДТ");
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Измерение.Имя + "ДТ"] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "ДТ");
КонецЦикла;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "КТ");
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Измерение.Имя + "КТ"] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя + "КТ");
КонецЦикла;
Иначе

СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Измерение.Имя] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
КонецЦикла;
КонецЕсли;
КонецЕсли; 
КонецЦикла;

Если Метаданные.РегистрыСведений.Содержит(Движение) Тогда
Для Каждого Ресурс ИЗ Движение.Ресурсы Цикл
Если Ресурс.Тип.СодержитТип(ТипЗнч(Ссылка)) Тогда
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Ресурс.Имя);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Ресурс.Имя] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Ресурс.Имя);
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецЕсли;

Для Каждого Реквизит ИЗ Движение.Реквизиты Цикл
Если Реквизит.Тип.СодержитТип(ТипЗнч(Ссылка)) Тогда
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Реквизит.Имя);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Реквизит.Имя] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Реквизит.Имя);
КонецЦикла;
КонецЕсли;
КонецЦикла;

Если Метаданные.РегистрыБухгалтерии.Содержит(Движение) Тогда

Для ИндексСубконто = 1 по ПараметрыЗамены[Движение.Имя + "Субконто"] Цикл
Если ЕстьКорреспонденция Тогда
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, "СубконтоДт"+ИндексСубконто);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти["СубконтоДт"+ИндексСубконто] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, "СубконтоДт"+ИндексСубконто);
КонецЦикла;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, "СубконтоКт"+ИндексСубконто);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти["СубконтоКт"+ИндексСубконто] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, "СубконтоКт"+ИндексСубконто);
КонецЦикла; 
Иначе 
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, "Субконто"+ИндексСубконто);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти["Субконто"+ИндексСубконто] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, "Субконто"+ИндексСубконто);
КонецЦикла; 
КонецЕсли; 
КонецЦикла; 
КонецЕсли;


Если НадоЗаписывать Тогда
НаборЗаписей.Загрузить(ТаблицаНабора);
Если ОтключатьКонтрольЗаписи Тогда
НаборЗаписей.ОбменДанными.Загрузка = Истина;
КонецЕсли;
Попытка
НаборЗаписей.Записать();
Исключение
БылиИсключения = Истина;
Если ВыполнятьВТранзакции Тогда
Возврат ВыполнитьОткат();
КонецЕсли;
КонецПопытки;
КонецЕсли;
КонецЦикла;


Для Каждого Последовательность ИЗ Метаданные.Последовательности Цикл
Если Последовательность.Документы.Содержит(СтрокаТаблицы.Метаданные) Тогда
НадоЗаписывать = Ложь;
НаборЗаписи = Последовательности[Последовательность.Имя].СоздатьНаборЗаписей();
НаборЗаписи.Отбор.Регистратор.Установить(СтрокаТаблицы.Данные);
НаборЗаписи.Прочитать();

Для Каждого Измерение ИЗ Последовательность.Измерения Цикл
Если Измерение.Тип.СодержитТип(ТипЗнч(Ссылка)) И НаборЗаписи[0][Измерение.Имя]=Ссылка Тогда
НаборЗаписи[0][Измерение.Имя] = ПравильныйЭлемент;
НадоЗаписывать = Истина;
КонецЕсли;
КонецЦикла; 
Если НадоЗаписывать Тогда
Если ОтключатьКонтрольЗаписи Тогда
НаборЗаписи.ОбменДанными.Загрузка = Истина;
КонецЕсли;
Попытка
НаборЗаписи.Записать();
Исключение
БылиИсключения = Истина;
Если ВыполнятьВТранзакции Тогда
Возврат ВыполнитьОткат();
КонецЕсли;
КонецПопытки;
КонецЕсли;
КонецЕсли;
КонецЦикла;



ИначеЕсли Метаданные.Справочники.Содержит(СтрокаТаблицы.Метаданные) Тогда

Если ПараметрыЗамены.Объект = Неопределено Тогда
ПараметрыЗамены.Объект = СтрокаТаблицы.Данные.ПолучитьОбъект();
КонецЕсли;

Если СтрокаТаблицы.Метаданные.Владельцы.Содержит(Ссылка.Метаданные()) И ПараметрыЗамены.Объект.Владелец = Ссылка Тогда
ПараметрыЗамены.Объект.Владелец = ПравильныйЭлемент;
КонецЕсли;

Если СтрокаТаблицы.Метаданные.Иерархический И ПараметрыЗамены.Объект.Родитель = Ссылка Тогда
ПараметрыЗамены.Объект.Родитель = ПравильныйЭлемент;
КонецЕсли;

Для Каждого Реквизит Из СтрокаТаблицы.Метаданные.Реквизиты Цикл
Если Реквизит.Тип.СодержитТип(ТипЗнч(Ссылка)) И ПараметрыЗамены.Объект[Реквизит.Имя] = Ссылка Тогда
ПараметрыЗамены.Объект[Реквизит.Имя] = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;

//Поймем, нужно ли менять значение в общем реквизите
Для Инд = 0 По ОбщиеРеквизиты.Количество() - 1 Цикл 
ОРеквизит = ОбщиеРеквизиты[Инд];
ЭлементСостава = ОРеквизит.Состав.Найти(СтрокаТаблицы.Данные.Метаданные());
Если Не ЭлементСостава = Неопределено И ЭлементСостава.Использование = Метаданные.СвойстваОбъектов.ИспользованиеОбщегоРеквизита.Использовать Тогда 
ПараметрыЗамены.Объект[ОРеквизит.Имя] = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;

Для Каждого ТЧ ИЗ СтрокаТаблицы.Метаданные.ТабличныеЧасти Цикл
Для Каждого Реквизит Из ТЧ.Реквизиты Цикл
Если Реквизит.Тип.СодержитТип(ТипЗнч(Ссылка)) Тогда
СтрокаТабЧасти = ПараметрыЗамены.Объект[ТЧ.Имя].Найти(Ссылка, Реквизит.Имя);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Реквизит.Имя] = ПравильныйЭлемент;
СтрокаТабЧасти = ПараметрыЗамены.Объект[ТЧ.Имя].Найти(Ссылка, Реквизит.Имя);
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецЦикла;

ИначеЕсли Метаданные.ПланыВидовХарактеристик.Содержит(СтрокаТаблицы.Метаданные)
ИЛИ Метаданные.ПланыСчетов.Содержит(СтрокаТаблицы.Метаданные)
ИЛИ Метаданные.ПланыВидовРасчета.Содержит(СтрокаТаблицы.Метаданные)
ИЛИ Метаданные.Задачи.Содержит(СтрокаТаблицы.Метаданные)
ИЛИ Метаданные.БизнесПроцессы.Содержит(СтрокаТаблицы.Метаданные) Тогда

Если ПараметрыЗамены.Объект = Неопределено Тогда
ПараметрыЗамены.Объект = СтрокаТаблицы.Данные.ПолучитьОбъект();
КонецЕсли;

Для Каждого Реквизит Из СтрокаТаблицы.Метаданные.Реквизиты Цикл
Если Реквизит.Тип.СодержитТип(ТипЗнч(Ссылка)) И ПараметрыЗамены.Объект[Реквизит.Имя] = Ссылка Тогда
ПараметрыЗамены.Объект[Реквизит.Имя] = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;

Для Каждого ТЧ ИЗ СтрокаТаблицы.Метаданные.ТабличныеЧасти Цикл
Для Каждого Реквизит Из ТЧ.Реквизиты Цикл
Если Реквизит.Тип.СодержитТип(ТипЗнч(Ссылка)) Тогда
СтрокаТабЧасти = ПараметрыЗамены.Объект[ТЧ.Имя].Найти(Ссылка, Реквизит.Имя);
Пока СтрокаТабЧасти <> Неопределено Цикл
СтрокаТабЧасти[Реквизит.Имя] = ПравильныйЭлемент;
СтрокаТабЧасти = ПараметрыЗамены.Объект[ТЧ.Имя].Найти(Ссылка, Реквизит.Имя);
КонецЦикла; 
КонецЕсли;
КонецЦикла;
КонецЦикла; 

ИначеЕсли Метаданные.Константы.Содержит(СтрокаТаблицы.Метаданные) Тогда

Константы[СтрокаТаблицы.Метаданные.Имя].Установить(ПравильныйЭлемент);


ИначеЕсли Метаданные.РегистрыСведений.Содержит(СтрокаТаблицы.Метаданные) Тогда 

СтруктураИзмерений = Новый Структура;
НаборЗаписей = РегистрыСведений[СтрокаТаблицы.Метаданные.Имя].СоздатьНаборЗаписей();
Для Каждого Измерение ИЗ СтрокаТаблицы.Метаданные.Измерения Цикл
НаборЗаписей.Отбор[Измерение.Имя].Установить(СтрокаТаблицы.Данные[Измерение.Имя]);
СтруктураИзмерений.Вставить(Измерение.Имя);
КонецЦикла;
Если СтрокаТаблицы.Метаданные.ПериодичностьРегистраСведений <> Метаданные.СвойстваОбъектов.ПериодичностьРегистраСведений.Непериодический Тогда
НаборЗаписей.Отбор["Период"].Установить(СтрокаТаблицы.Данные.Период);
КонецЕсли;
НаборЗаписей.Прочитать();
ТаблицаНабора = НаборЗаписей.Выгрузить();
НаборЗаписей.Очистить();

Если ОтключатьКонтрольЗаписи Тогда
НаборЗаписей.ОбменДанными.Загрузка = Истина;
КонецЕсли;


Если Не ВыполнятьВТранзакции Тогда
НачатьТранзакцию();
КонецЕсли;

Попытка

НаборЗаписей.Записать();

Для Каждого Колонка ИЗ ТаблицаНабора.Колонки Цикл
Если ТаблицаНабора[0][Колонка.Имя] = Ссылка Тогда
ТаблицаНабора[0][Колонка.Имя] = ПравильныйЭлемент;
Если СтруктураИзмерений.Свойство(Колонка.Имя) Тогда
НаборЗаписей.Отбор[Колонка.Имя].Установить(ПравильныйЭлемент);
КонецЕсли;

КонецЕсли;
КонецЦикла;

НаборЗаписей.Загрузить(ТаблицаНабора);

НаборЗаписей.Записать();

Если Не ВыполнятьВТранзакции Тогда
ЗафиксироватьТранзакцию();
КонецЕсли; 

Исключение

Если ВыполнятьВТранзакции Тогда
БылиИсключения = Истина;
Возврат ВыполнитьОткат();
Иначе
ОтменитьТранзакцию();
КонецЕсли;

КонецПопытки;

Иначе
Сообщить("Ссылки типа "+СтрокаТаблицы.Метаданные+" не заменяются!!");
КонецЕсли;
КонецЦикла;

Если ПараметрыЗамены.Объект <> Неопределено Тогда
Если ОтключатьКонтрольЗаписи Тогда
ПараметрыЗамены.Объект.ОбменДанными.Загрузка = Истина;
КонецЕсли;
Попытка
ПараметрыЗамены.Объект.Записать();
Исключение
БылиИсключения = Истина;
Если ВыполнятьВТранзакции Тогда
Возврат ВыполнитьОткат();
КонецЕсли;
КонецПопытки;
КонецЕсли;

Если ВыполнятьВТранзакции Тогда
Если БылиИсключения Тогда
ОтменитьТранзакцию();
Иначе
ЗафиксироватьТранзакцию();
КонецЕсли; 
КонецЕсли;
Возврат Не БылиИсключения;

КонецФункции

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Поиск и замена дублирующихся элементов с учетом общих реквизитов
.epf 34,73Kb
26.06.14
215
.epf 1.0 34,73Kb 215 Скачать

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Павел Богачев (pvb2003) 05.02.15 00:41
Проблемка - 8.3.5.1383 и БП 3.0.37.35
Попытка обработать задвоившийся справочник "Организации" выдает "Неверное имя колонки" ... как бороться?
2. Юрий (AlgoritmS) 06.04.15 13:00
3. Ak Uji (Akuji) 03.11.15 12:44
По наименованию с учетом владельца как сделать замену?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа