gifts2017

Подготовка сведений для ПФР ЗиК Исправление ошибок

Опубликовал Светлана Иванова (Cvetic) в раздел Программирование - Ошибки в отраслевых решениях

Подготовка сведений для ПФР ЗиК Исправление ошибок. Для сотрудников, у которых во 2,3 или 4 квартале не было заработка, но есть стаж (например, декретницы) не заполняется «Сумма выплат с начала года».

В отчете ПодготовкаСведенийДляПФР2010 после 4996 строки


ЕстьДанные = 0;
Для СчМес = МесяцНачало ПО МесяцОкончания Цикл 
      НомСтр = "";
      Если ДанныеПоКатегории.НайтиЗначение(СчМес,НомСтр,"Месяц") = 1 Тогда
              ЕстьДанные = 1;
              Прервать;
      КонецЕсли;
КонецЦикла;

добавляем строки


Если ЕстьДанные = 0 тогда
        ТаблицаСтажиСотрудников = ТаблицаСотрудниковСДаннымиОСтаже(Сотрудник, ДатаНачала);
        Если ТаблицаСтажиСотрудников.КоличествоСтрок() > 0 тогда
                ЕстьДанные = 1;
        КонецЕсли;
КонецЕсли;

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Елена Люфт (Frosja) 31.07.14 05:25
Да, никогда не закончится работа у программистов обслуживающих 1с 7.7 :)
Сколько уже правим-правим этот Отчет в ПФР.
Хряк; rimma_n; +2 Ответить
2. Светлана Иванова (Cvetic) 31.07.14 08:22
3. Саша (Хряк) 27.08.14 16:00
Добавлю
При заполнении таблиц на закладке АДВ-1 данные не сохраняются, в следующий раз при выборе этой закладки видим пустые таблицы.

Исправление для ЗиК и для бух аналогичны
В процедуре ВосстановитьНастройки
ищем строки и исправляем
Для Счетчик = 1 По СписокДокументов.КоличествоСтрок() Цикл

НомерПачки = СписокДокументов.ПолучитьЗначение(Счетчик, "Пачка");
ФормаПачки = СписокДокументов.ПолучитьЗначение(Счетчик, "Форма");

Если (ФормироватьСЗВ64 = 1) и ((СОКРЛП(ФормаПачки)="СЗВ-6-1") или (СОКРЛП(ФормаПачки)="СЗВ-6-2")) Тогда
Возврат;
ИначеЕсли (ФормироватьРаздел6РСВ_1 = 1) и (СОКРЛП(ФормаПачки)<>"Раздел6РСВ_1") Тогда

//яИзменил 27.08.14
Если Форма.Закладки.ТекущаяСтрока()<>3 Тогда //это добавляем
Возврат;
КонецЕсли;//это добавляем
КонецЕсли;
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа