gifts2017

Загрузка в справочник из MS SQL и Excel

Опубликовал Максим Иванов (freud) в раздел Обработки - Обработка справочников

Обработка загружает данные с MS SQL сервера и из файлов xls

Обработка сделана для конфигурации Расчет стипендий (1.1.20.1007) добавляет в справочник студентов данные с MS SQL сервера  (SQL запрос прописан в окне его можно менять) или из файла Excel.

Для других конфигураций следует заменить процедуру

Процедура Кнопка2Нажатие(Элемент)
	
	Для Каждого ТекущаяСтрока Из ТаблицаДокумента Цикл 
		
		РезультатПоиска = Справочники.Студенты.НайтиПоНаименованию(ТекущаяСтрока.Фио1+" " +ТекущаяСтрока.Фио2+" " +ТекущаяСтрока.Фио3); 
		
		
		Если РезультатПоиска.Пустая() Тогда 
        // Выполнить действия, предусмотренные в случае, когда элемент не найден.  
  
					
		
		НовыйЭлемент = Справочники.Студенты.СоздатьЭлемент();	// Тут указывается в какой сапрвочник вносить	
		
		НовыйЭлемент.Наименование  = ТекущаяСтрока.Фио1+" " +ТекущаяСтрока.Фио2+" " +ТекущаяСтрока.Фио3;
		НовыйЭлемент.Адрес   = ТекущаяСтрока.Адр ;
		
		Если ЭтотОбъект.Да = Истина   Тогда 

		НовыйЭлемент.ДатаРождения =  ТекущаяСтрока.Др ;
		Иначе
		
		НовыйЭлемент.ДатаРождения =  ИзСтрокиВДату(ТекущаяСтрока.Др) ;
		КонецЕсли;

		Сообщить(НовыйЭлемент.Наименование) ;

                НовыйЭлемент.ИНН = ТекущаяСтрока.ИНН ;

		НовыйЭлемент.Записать(); 
		КонецЕсли; 
	КонецЦикла; 
	
КонецПроцедуры
 

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Загрузка в справочник из SQL и Excel
.epf 16,49Kb
28.08.14
1
.epf 16,49Kb 1 Скачать

См. также

Contragent+ 5.0 от 2 500
Подписаться Добавить вознаграждение
В этой теме еще нет сообщений.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа