gifts2017

Пометка на удаление всех документов в информационной базе

Опубликовал Vitaliy Oleksik (VintikComUa) в раздел Обработки - Обработка документов

Очень часто необходимо очистить базу от документов и оставить все справочники. Данная обработка помечает на удаление ВСЕ документы в информационной базе.
Вот так это выглядит внутри

Процедура КнопкаВыполнитьНажатие(Кнопка)

    Для каждого ДокументМ Из Метаданные.Документы Цикл

       ТипДокумента = ДокументМ.Имя;


       ВыбДок = Документы[ТипДокумента].Выбрать();

       Пока ВыбДок.Следующий() Цикл

            ВыбДокОбъект = ВыбДок.ПолучитьОбъект();

			ВыбДокОбъект.УстановитьПометкуУдаления(Истина);

			ВыбДокОбъект.Записать();

            Сообщить("Помечен на удаление документ: "+ ВыбДокОбъект);

       КонецЦикла; 

    КонецЦикла;

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
ПометкаНаУдалениеВсехДокументов.epf 13
.epf 5,99Kb
09.09.14
13
.epf 1.0 5,99Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Епрст (Ёпрст) 09.09.14 17:34
2. Артём Алтухов (Fannasankh) 10.09.14 09:31
создаешь чистую базу. Переносить через xml справочники. И быстрее и качественнее будет.
3. Артём Алтухов (Fannasankh) 10.09.14 09:37
К тому же что-то мне подсказывает, что на удаление то ты пометишь, а вот удалить вряд ли выйдет.
4. Алексей Орлов (safriduo73) 10.09.14 11:09
А чем же не устроила Групповая обработка справочников и документов (есть на обычной и управляемой форме)? В ней также можно пометить на удаление документы, и установить отбор, чтобы уже помеченные на удаление не обрабатывал, смысла нет их повторно "дёргать".
И если уже делать обработку, тогда пометку на удаление лучше выполнять в попытке, чтобы при ошибках продолжала работать, а проблемные документы потом отдельно разобрать.
5. ediks (ediks) 10.09.14 11:17
(1) Шикарная обработка по ссылке. Сначала искал в чем подвох, потом читал комменты. Посмеялся.
Stim213; Ёпрст; klinval; +3 Ответить
6. DAnry (DAnry) 10.09.14 15:56
Как раз пометить на удаление все документы в базе не проблема. Вот удалить... это ДА. Хотя и тут есть множество вариантов решения: специализированные обработки, создание новой базы и перенос по XML справочников и т.д. и т.п. Каждый вариант имеет свои плюсы и минусы. А сама представленная тут обработка, конечно, имеет право на жизнь, но если честно - есть гораздо лучшие
ves.Parnas; Fannasankh; +2 Ответить
7. Максим Кузнецов (MakcTLT63) 10.09.14 16:13
Очень помогло! А есть такая же для справочников?
8. Артём Алтухов (Fannasankh) 11.09.14 10:04
(7) MakcTLT63, есть для базы. Нужно?
9. Дмитрий Топчий (hakerxp) 11.09.14 13:33
Неужели модераторы такое пропускают!?
10. Руслан (lrs) 11.09.14 16:41
Помимо остальных претензий, это лишнее:
ВыбДокОбъект.Записать();

Вы второй раз записываете документ, после того как уже пометили его на удаление методом УстановитьПометкуУдаления(Истина)

PS. Пример в синтаксис-помощнике такой же кривой.
11. anry mc (AnryMc) 11.09.14 17:30
Надо на сайте объявить конкурсы:

1) Самая невостребованная обработка
2) Самая вредная обработка
3) Самая "тупая" обработка
4) Самый короткий функциональный код...

;-)
12. anry mc (AnryMc) 11.09.14 17:34
(7) MakcTLT63,
Очень помогло!


Интересно вы из числа 4 скачавших? Что то у вас надписи не видно - (файл скачал)

Или воспользовались кодом процедуры из "текста статьи"? Тогда должны, что-то понимать в программировании на 1С...

Так "..." писать?
13. anry mc (AnryMc) 11.09.14 17:38
(0) Автор

Из правил хорошего тона:
Это публикация только для Украины?

Сделайте интерфейс русским или укажите страну, а ещё лучше сделать на двух языках...
14. Максим Кузнецов (MakcTLT63) 12.09.14 08:18
(12) AnryMc,
Ничего не понял.. Какие надписи? Кто что скачал? При чем тут "..."? Кто на ком стоял? Зачем что-то понимать в программировании, если в тексте статьи выложен код?
Это какой то тонкий английский юмор? Очень тонкий..
15. Павел Колмаков (Stim213) 07.11.14 15:30
"Очень часто необходимо очистить базу от документов и оставить все справочники"

Часто! Я каждое утро этим занимаюсь. Прихожу на работу и первым делом очищаю все рабочие базы от документов
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа