Пометка на удаление всех документов в информационной базе

Опубликовал Vitaliy Oleksik (VintikComUa) в раздел Обработки - Обработка документов

Очень часто необходимо очистить базу от документов и оставить все справочники. Данная обработка помечает на удаление ВСЕ документы в информационной базе.
Вот так это выглядит внутри

Процедура КнопкаВыполнитьНажатие(Кнопка)

    Для каждого ДокументМ Из Метаданные.Документы Цикл

       ТипДокумента = ДокументМ.Имя;


       ВыбДок = Документы[ТипДокумента].Выбрать();

       Пока ВыбДок.Следующий() Цикл

            ВыбДокОбъект = ВыбДок.ПолучитьОбъект();

			ВыбДокОбъект.УстановитьПометкуУдаления(Истина);

			ВыбДокОбъект.Записать();

            Сообщить("Помечен на удаление документ: "+ ВыбДокОбъект);

       КонецЦикла; 

    КонецЦикла;

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
ПометкаНаУдалениеВсехДокументов.epf
.epf 5,99Kb
09.09.14
13
.epf 1.0 5,99Kb 13 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Ёпрст Биомать, а? Верните бесплатный доступ к файлам! (Ёпрст) 1010 09.09.14 17:34 Сейчас в теме
2. Артём Алтухов (Fannasankh) 11 10.09.14 09:31 Сейчас в теме
создаешь чистую базу. Переносить через xml справочники. И быстрее и качественнее будет.
3. Артём Алтухов (Fannasankh) 11 10.09.14 09:37 Сейчас в теме
К тому же что-то мне подсказывает, что на удаление то ты пометишь, а вот удалить вряд ли выйдет.
4. Алексей Орлов (safriduo73) 11 10.09.14 11:09 Сейчас в теме
А чем же не устроила Групповая обработка справочников и документов (есть на обычной и управляемой форме)? В ней также можно пометить на удаление документы, и установить отбор, чтобы уже помеченные на удаление не обрабатывал, смысла нет их повторно "дёргать".
И если уже делать обработку, тогда пометку на удаление лучше выполнять в попытке, чтобы при ошибках продолжала работать, а проблемные документы потом отдельно разобрать.
5. ediks (ediks) 317 10.09.14 11:17 Сейчас в теме
(1) Шикарная обработка по ссылке. Сначала искал в чем подвох, потом читал комменты. Посмеялся.
Stim213; Ёпрст; klinval; +3 Ответить
6. DAnry (DAnry) 3 10.09.14 15:56 Сейчас в теме
Как раз пометить на удаление все документы в базе не проблема. Вот удалить... это ДА. Хотя и тут есть множество вариантов решения: специализированные обработки, создание новой базы и перенос по XML справочников и т.д. и т.п. Каждый вариант имеет свои плюсы и минусы. А сама представленная тут обработка, конечно, имеет право на жизнь, но если честно - есть гораздо лучшие
ves.Parnas; Fannasankh; +2 Ответить
7. Имя Фамилия (MakcTLT63) 6 10.09.14 16:13 Сейчас в теме
Очень помогло! А есть такая же для справочников?
8. Артём Алтухов (Fannasankh) 11 11.09.14 10:04 Сейчас в теме
(7) MakcTLT63, есть для базы. Нужно?
9. Дмитрий Топчий (hakerxp) 701 11.09.14 13:33 Сейчас в теме
Неужели модераторы такое пропускают!?
10. Руслан (lrs) 26 11.09.14 16:41 Сейчас в теме
Помимо остальных претензий, это лишнее:
ВыбДокОбъект.Записать();

Вы второй раз записываете документ, после того как уже пометили его на удаление методом УстановитьПометкуУдаления(Истина)

PS. Пример в синтаксис-помощнике такой же кривой.
11. anry mc (AnryMc) 706 11.09.14 17:30 Сейчас в теме
Надо на сайте объявить конкурсы:

1) Самая невостребованная обработка
2) Самая вредная обработка
3) Самая "тупая" обработка
4) Самый короткий функциональный код...

;-)
12. anry mc (AnryMc) 706 11.09.14 17:34 Сейчас в теме
(7) MakcTLT63,
Очень помогло!


Интересно вы из числа 4 скачавших? Что то у вас надписи не видно - (файл скачал)

Или воспользовались кодом процедуры из "текста статьи"? Тогда должны, что-то понимать в программировании на 1С...

Так "..." писать?
13. anry mc (AnryMc) 706 11.09.14 17:38 Сейчас в теме
(0) Автор

Из правил хорошего тона:
Это публикация только для Украины?

Сделайте интерфейс русским или укажите страну, а ещё лучше сделать на двух языках...
14. Имя Фамилия (MakcTLT63) 6 12.09.14 08:18 Сейчас в теме
(12) AnryMc,
Ничего не понял.. Какие надписи? Кто что скачал? При чем тут "..."? Кто на ком стоял? Зачем что-то понимать в программировании, если в тексте статьи выложен код?
Это какой то тонкий английский юмор? Очень тонкий..
15. Павел Колмаков (Stim213) 260 07.11.14 15:30 Сейчас в теме
"Очень часто необходимо очистить базу от документов и оставить все справочники"

Часто! Я каждое утро этим занимаюсь. Прихожу на работу и первым делом очищаю все рабочие базы от документов