gifts2017

Автоматизированное рабочее место (АРМ) Оператора

Опубликовал cdr (phsin) в раздел Обработки - Рабочее место

Автоматизированное рабочее место оператора предназначено для работы с заявками и отгрузками на указанную дату для 1С Комплексная 7.7. Пример использования прямых запросов в 1С Предприятие 7.7

В отчете отображается основная информация, необходимая для работы оператора:

  • Остатки товаров на складе
  • Количество заказанного товара
  • Количество отгруженного товара
  • Количество зарезервированного товара

Отчет для 1С Предприятие Комплексная 7.7

Детализация по

  • заказам
  • отгрузкам
  • резервам

Добавлены возможности

  • округления товара до коробки
  • выборочное исправление количества товара в накладной

Алгоритм работы:

  1. Проводим все заказы покупателей на выбранную дату
  2. Формируем отчет АРМ Оператора
Красным цветом выделены товары с недостаточным количеством для отгрузки
  1. Исправляем количество (убираем красноту)
  2. Проводим все накладные
  3. Групповая печать документов

Высокая скорость формирования отчета достигается с помощью прямых запросов 1С++

Отчет для 1С Предприятие Комплексная 7.7

Для формирования отчета необходимо внести изменения в конфигурацию:

  1. Изменить регистр Заявки Добавить измерение ДатаОтгрузки

Регистр Заявки

  1. Добавить строки в Модуль документа Заявка Покупателя
Процедура ПроведениеПоРегистрам() 
...
	Регистр.Заявки.ДоговорПокупателя = Договор;
	Регистр.Заявки.ЗаявкаПокупателя  = ТекущийДокумент();

	// ресурсы
	Регистр.Заявки.КоличествоРасход = ТаблицаДокумента.Количество;
	Регистр.Заявки.СтоимостьРасход 	= ТаблицаДокумента.Сумма;

	Регистр.Заявки.ДатаОтгрузки 	= датаОтгрузки; //Добавить 

	// выполняем движение
	Регистр.Заявки.ДвижениеПриходВыполнить();
...
  1. Добавить строки в Модуль документа РеализацияТоваров
//Добавить
Процедура ДвижениеЗаявокПокупателяПростое()
	Если ПустоеЗначение(ДокОснование)=0 Тогда 
		Если ДокОснование.Вид()="ЗаявкаПокупателя" Тогда 
			ВыбратьСтроки();
			Пока ПолучитьСтроку()=1 Цикл
				Регистр.Заявки.Фирма = Фирма;
				Регистр.Заявки.Номенклатура = Номенклатура;			
				Регистр.Заявки.ДоговорПокупателя = Договор;
				Регистр.Заявки.ЗаявкаПокупателя = ДокОснование;
				Регистр.Заявки.КоличествоРасход = Количество;
				Регистр.Заявки.СтоимостьРасход = Сумма;
				Регистр.Заявки.ДатаОтгрузки 	= ДокОснование.ДатаОтгрузки; 
				Регистр.Заявки.ДвижениеРасходВыполнить();
			КонецЦикла;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры 
Процедура ПроведениеПоРегистрам()
...
	//ДвижениеЗаявокПокупателя(ТаблицаТМЦ, ВремЗаявки, ВремЗаказыЗаявки, ВремРезервыТМЦ); // по ТМЦ
	//ДвижениеЗаявокПокупателя(ТаблицаУслуг, ВремЗаявки, ВремЗаказыЗаявки, ВремРезервыТМЦ); // по услугам и работам
	ДвижениеЗаявокПокупателяПростое();
...
КонецПроцедуры

Изменения затрагивают стандартные механизмы формирования проводок документов 1С Предприятия. Поэтому, желательно, чтобы изменения вносил программист 1С.

Благодарности: Людям, создавшим и поддерживающим проект 1С++

 

http://kb99.pro

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
АРМоператора.ert
.ert 133,00Kb
01.10.14
7
.ert 133,00Kb 7 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. grey16 (grey16) 01.10.14 11:32
ТиС 979, не запускается

Цена=глПолучитьЦену(Док.Номенклатура, Док.ТипЦен, Док.ДатаДок, Док.Единица,,,,<<?>>);
{\\C028\DB2013\EXTFORMS\ERTS\АРМОПЕРАТОРА.ERT(103)}: Слишком много фактических параметров
2. cdr (phsin) 01.10.14 12:10
(1) grey16, спасибо, исправил
3. grey16 (grey16) 01.10.14 12:44
теперь запускается, но при попытке сформировать отчет пишет
RS = СоздатьОбъект("ODBCRecordset");
{\\C028\DB2013\EXTFORMS\ERTS\АРМОПЕРАТОРА.ERT(189)}: Неудачная попытка создания объекта (ODBCRecordset)

и на реестр заказов:

Если Док.РазрешитьОтгрузку=1 Тогда
{\\C028\DB2013\EXTFORMS\ERTS\АРМОПЕРАТОРА.ERT(1122)}: Поле агрегатного объекта не обнаружено (РазрешитьОтгрузку)

ну и еще три обработки встречаются, а не выложены -урезка, округление, замена
4. cdr (phsin) 02.10.14 17:14
(3) grey16, отчет для sql версии.
для dbf базы есть небольшие отличия.
5. grey16 (grey16) 03.10.14 13:16
6. cdr (phsin) 14.10.14 15:43
(5) grey16, тогда должно работать...
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа