gifts2017

Проверка наличия цены у номенклатуры

Опубликовал Denis Mir (prost_white_one) в раздел Программирование - Практика программирования

Проверка, есть цена у номенклатуры или нет

  Решил поделиться. Для чего это нужно, скажете вы. Это нужно для формирования отчета “Валовая прибыль”.  Данный код поможет реализовать проверку  "Установки цен номенклатуры" при “Реализации Товаров и Услуг” будет проверяться реализуемая номенклатура.

Если в Документе "Установка цен номенклатуры" не рассчитать цену по номенклатуре, при проведении документа выдаст Служебное сообщения вида “Товар не расценен” указав по какой имена номенклатуре не “Установлена цена номенклатуре” рассчитана. Кому-то может это пригодиться для решения данной задачи.

Конфигуратор - Документы - РеализацияТоваровУслуг - Модуль Обьекта - Процедура Перед Записью

 

 

Если РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда
        Для Каждого Стр Из Товары Цикл         
            Запрос = Новый Запрос ;
            Запрос.Текст = 
                "ВЫБРАТЬ
                |    ЦеныНоменклатурыСрезПоследних.Цена
                |ИЗ
                |    РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних
                |ГДЕ
                |    ЦеныНоменклатурыСрезПоследних.Номенклатура = &Номенклатура
                |    И ЦеныНоменклатурыСрезПоследних.ТипЦен = &ТипЦен";

            Запрос.УстановитьПараметр("Номенклатура", Стр.Номенклатура);
            Запрос.УстановитьПараметр ("ТипЦен", ТипЦен); 
            Результат = Запрос.Выполнить ();
            ВыборкаДетальныеЗаписи = Результат.Выбрать ();
                Количество = 0;
            Пока ВыборкаДетальныеЗаписи.Следующий () Цикл
                Количество = Количество + 1;
            КонецЦикла;
            Если Количество = 0 Тогда
                Отказ = Истина;
                Сообщить ("Товар "+ Стр.Номенклатура+" не ресценен ! ! ");
                Возврат; 
КонецЕсли; 
КонецЦикла; 
КонецЕсли;


См. также

Подписаться Добавить вознаграждение

Комментарии

1. sdf sdf (ruskiy1) 10.11.14 17:59
слабенькая попытка набить рейтинг.
2. sdf sdf (ruskiy1) 10.11.14 18:01
запрос в цикле особенно порадовал))
Voland36; +1 Ответить
3. Стас Агапов (TheBear) 10.11.14 18:45
при проведении документа выдаст Служебное сообщения вида “Товар не расценен”

Конфигуратор - Документы - РеализацияТоваровУслуг - Модуль Обьекта - Процедура Перед Записью

Так при проведении или перед записью?!
И неужели проведется документ с незаполненной ценой? (на скриншоте)
Какой смысл данной процедуры ? Неужели я не могу вводить цену вручную?
4. Denis Mir (prost_white_one) 11.11.14 08:55
(3) TheBear,
ПередЗаписью, можешь ввести цену вручную, но не даст провести документ.
5. Евгения Карук (ekaruk) 11.11.14 20:05
Решение плохое потому что:
1. Нельзя в таких проверках использовать отдельный запрос на каждую строчку. Должен быть один общий запрос.
2. Не поняла, зачем эти извраты с количеством. Достаточно проверки "Результат.Пустой()"
3. И вообще для этой проверки нафиг не нужна транзакция. Ее нужно выполнять до транзакции в "ОбработкеПроверкиЗаполнения", а не "ПередЗаписью"
4. Хотя бы номер строки вывел бы.
6. Стас Агапов (TheBear) 11.11.14 23:21
(4) prost_white_one,
ПередЗаписью, можешь ввести цену вручную, но не даст провести документ.

Конфигуратор - Документы - РеализацияТоваровУслуг - Модуль Обьекта - Процедура Перед Записью


Второй вопрос
Я шибко умный пользователь цена на товар есть, а я изменил ее руками - т.е. товар расценен, но цена другая - ломает необходимость вашей проверки !
7. Denis Mir (prost_white_one) 12.11.14 09:12
(5) ekaruk, Подскажите пожалуйста, как правильней выглядел бы мой текст. Я только учусь программированию не судите сильно меня.
8. Denis Mir (prost_white_one) 12.11.14 09:14
(6) TheBear, Если я правильно вас понял, вы хотели бы чтобы была проверка Тип цен контроля. Если вам это нужно могу поделиться кодам для конфигурации.
9. Evgeniy Faizullin (nazik) 12.11.14 09:31
(8) проблема в том, что ваш велосипед не нужен в принципе. Т.к. механизм контроля 0 цены в документах продажи в системах УТ10.3, КА, УПП - существует, как и контроль продаж ниже определенного типа цен
10. Кирилл Бондаренко (karapuzzzz) 12.11.14 15:58
(7) prost_white_one, в данном случае код должен выглядеть так:
Конфигуратор - Документы - РеализацияТоваровУслуг - Модуль Обьекта - Процедура Перед Записью
// Типовой код. Ничего не трогать.

Если при проверке необходимо проверять на наличие цены в табличной части, то вообще ничего делать не надо. Типовой механизм уже не дает продавать товар по нулевой стоимости (если там не было шаловливых рук).
В случае валовой прибыли данные берутся из регистра "ПродажиОбороты" и "ПродажиСебестоимость". В первый данные передаются из табличной части. Т.е. какая стоимость будет, такая и занесется. Во вторую таблицу данные заносятся при проведении по данным партий товаров на складах. И проверять на установленную цену нет необходимости вообще. Ваш код не решает поставленной задачи.
11. Артано Майаров (Артано) 13.11.14 09:54
Солидарен с предыдущими ораторами. На статью не тянет, сам метод написан весьма слабо
12. Артано Майаров (Артано) 27.11.14 10:55
Решил сделать доброе дело и показать пример как можно было бы оптимизировать процедуру приведенную в топике. Конечно абстрагируемся от наличия типовых механизмов, просто возьмем существующую проблему в чистом виде.

Взамен прошу соблюдать принцип lurk moar

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("табТовары",Товары.Выгрузить(,"НомерСтроки,Номенклатура,ХарактеристикаНоменклатуры"));
Запрос.УстановитьПараметр("Склад",Склад));
Запрос.УстановитьПараметр("ДатаЦен",Дата));

Запрос.Текст =

"ВЫБРАТЬ
|	ВЫРАЗИТЬ(табТовары.НомерСтроки КАК ЧИСЛО) КАК НомерСтроки,
|	ВЫРАЗИТЬ(табТовары.Номенклатура КАК Справочник.Номенклатура) КАК Номенклатура,
|	ВЫРАЗИТЬ(табТовары.ХарактеристикаНоменклатуры КАК Справочник.ХарактеристикиНоменклатуры) КАК ХарактеристикаНоменклатуры
|ПОМЕСТИТЬ втТовары
|ИЗ
|	&табТовары КАК табТовары
|;
|
|////////////////////////////////////////////////////////////­////////////////////
|ВЫБРАТЬ
|	втТовары.НомерСтроки КАК НомерСтроки,
|	втТовары.Номенклатура,
|	втТовары.ХарактеристикаНоменклатуры
|ИЗ
|	втТовары КАК втТовары
|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныАТТ.СрезПоследних(
|				&ДатаЦен,
|				Склад = Склад
|					И номенклатура В
|						(ВЫБРАТЬ
|							втТовары.Номенклатура
|						ИЗ
|							втТовары КАК втТовары)) КАК Цены
|		ПО втТовары.Номенклатура = Цены.Номенклатура
|			И втТовары.ХарактеристикаНоменклатуры = Цены.ХарактеристикаНоменклатуры
|ГДЕ
|	Цены.Номенклатура ЕСТЬ NULL 
|
|УПОРЯДОЧИТЬ ПО
|	НомерСтроки
|;
|
|////////////////////////////////////////////////////////////­////////////////////
|УНИЧТОЖИТЬ втТовары"
;

Если Не РезультатЗапроса.Пустой() Тогда
	Отказ = Истина;
	Выборка = РезультатЗапроса.Выбрать();
	Пока Выборка.Следующий() Цикл
		Сообщить("В строке " + Строка(Выборка.НомерСтроки) + " не задана цена номенклатуры");
	КонецЦикла;
КонецЕсли;
...Показать Скрыть
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа