gifts2017

Мелкие полезные функции

Опубликовал Трактор Трактор (Трактор) в раздел Программирование - Практика программирования

На Инфостарте некоторое время назад существовали блоги. Я записывал заметки туда. Сейчас обнаружил, что блоги кончились. Решил перенести некоторые заметки из бога в отдельную публикацию.
Вот заметки:
1. Поиск объекта по идентификатору.
2. Разрешение пользолваателям редактировать отдельные реквизиты документа без перепроведения.

1. Получение объекта по идентификатору.

Синхронизация справочников и документов с сайтом я предпочитаю выполнять по уникальным идентификаторам. Поэтому часто необходимо получать ссылку по идентификатору. Написал для этого универсальную функцию.

// Возвращает ссылку на найденный справочник или документ или Неопределено, если объекта нет.
// Параметры
// ИД - строковое представления уникального идентификатора
// Тип - наименование вида справочника или документа. Благо их наименования не пересекаются.
Функция ПолучитьСсылкуПоИД(ИД, Тип = Неопределено)
	Если ИД = "" и Тип <> Неопределено Тогда
		// Тип известен, элемент явно пустой, значит нужно вернуть пустую ссылку
		спр = Метаданные.Справочники.Найти(Тип);
		Если спр <> Неопределено Тогда
			Возврат Справочники[Тип].ПустаяСсылка();
		КонецЕсли;
		
		док = Метаданные.Документы.Найти(Тип);
		Если док <> Неопределено Тогда
			Возврат Документы[Тип].ПустаяСсылка();
		КонецЕсли;
		Возврат Неопределено
	КонецЕсли;
	
	Попытка
		УИД = Новый УникальныйИдентификатор(ИД);
	Исключение
		Возврат Неопределено
	КонецПопытки;
	
	// Если тип известен, то ищем только в одной таблице
	Если Тип <> Неопределено Тогда
		спр = Метаданные.Справочники.Найти(Тип);
		Если спр <> Неопределено Тогда
			Ссылка = Справочники[Тип].ПолучитьСсылку(УИД);
			Если Не Ссылка.Пустая() и Ссылка.ПолучитьОбъект() <> Неопределено Тогда
				Возврат Ссылка
			КонецЕсли;
			Возврат Неопределено
		КонецЕсли;
		
		док = Метаданные.Документы.Найти(Тип);
		Если док <> Неопределено Тогда
			Ссылка = Документы[Тип].ПолучитьСсылку(УИД);
			Если Не Ссылка.Пустая() и Ссылка.ПолучитьОбъект() <> Неопределено Тогда
				Возврат Ссылка
			КонецЕсли;
		КонецЕсли;
		Возврат Неопределено
	КонецЕсли;
	
	// Если тип неизвестен, то перебираем все справочники и документы.
	// Это долго. Поэтому тип очень хочется получить.
	Для Каждого спр из Метаданные.Справочники Цикл
		Ссылка = Справочники[спр.Имя].ПолучитьСсылку(УИД);
		Если Ссылка.ПолучитьОбъект() <> Неопределено Тогда
			Возврат Ссылка
		КонецЕсли;
	КонецЦикла;
	
	Для Каждого док из Метаданные.Документы Цикл
		Ссылка = Документы[док.Имя].ПолучитьСсылку(УИД);
		Если Ссылка.ПолучитьОбъект() <> Неопределено Тогда
			Возврат Ссылка
		КонецЕсли;
	КонецЦикла;
	
	Возврат Неопределено
КонецФункции

 

2. Разрешение пользователям редактировать отдельные реквизиты документа без перепроведения или просто одни реквизиты разрешать, а другие запрещать.

Иногда необходимо разрешить редактирование некоторых реквизитов документа без перепроведения. Например: Комментарий, АдресКонтрагента, КонтактноеЛицо. Ещё бывает необходимым разрешить изменение отдельных реквизитов в закрытых документах. Например, поставить отметку о состоянии доставки и написать комментарий.

В модуле менеджера документа пишем функцию, которая определяет массив допустимых к редактированию реквизитов

// Возвращает массив имён реквизитов, разрешённых для изменнения без перепроведения.
// Если получен параметр типа Массив, то имена реквизитов добавляются в него
Функция ПолучитьМассивРеквизитовИзменяемыхБезПерепроведения(МассивРеквизитовДопустимыхКИзменению =  Неопределено) Экспорт
	Если Не ТипЗнч(МассивРеквизитовДопустимыхКИзменению) = Тип("Массив") Тогда
		МассивРеквизитовДопустимыхКИзменению = Новый Массив;
	КонецЕсли;
	//Типовые реквизиты
	МассивРеквизитовДопустимыхКИзменению.Добавить("Грузополучатель");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьНомер");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьДата");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьНомер");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьВыдана");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьЧерезКого");
	МассивРеквизитовДопустимыхКИзменению.Добавить("Комментарий");
	МассивРеквизитовДопустимыхКИзменению.Добавить("АдресДоставки");
	//Добавленные реквизиты
	
	Возврат МассивРеквизитовДопустимыхКИзменению;
КонецФункции

В модуле ОбщегоНазначения пишем функции общие для всех документов.

// сравниваем реквизиты документа из базы данных с записываемым объектом
// имена изменённых реквизитов запихываем в массив
Функция ПолучитьСписокИзменённыхРеквизитов(ДокОбъект) Экспорт
	СписокИзменённыхРеквизитов = Новый Массив;
	
	Ссылка = ДокОбъект.Ссылка;
	мдОбъекта = ДокОбъект.Метаданные();
	// сравниваем стандартные реквизиты
	Для Каждого Реквизит из мдОбъекта.СтандартныеРеквизиты Цикл
		Если ДокОбъект[Реквизит.Имя] <> Ссылка[Реквизит.Имя] Тогда
			СписокИзменённыхРеквизитов.Добавить(Реквизит.Имя);
		КонецЕсли;
	КонецЦикла;
	
	// сравниваем реквизиты шапки
	Для Каждого Реквизит из мдОбъекта.Реквизиты Цикл
		Если ДокОбъект[Реквизит.Имя] <> Ссылка[Реквизит.Имя] Тогда
			СписокИзменённыхРеквизитов.Добавить(Реквизит.Имя);
		КонецЕсли;
	КонецЦикла;
	
	// сравниваем табличные части
	Для Каждого тч из мдОбъекта.ТабличныеЧасти Цикл
		Если ДокОбъект[тч.Имя].Количество() = Ссылка[тч.Имя].Количество() Тогда // Не добавляли и не убирали строки в тч
			Для Каждого строкаОбъекта Из ДокОбъект[тч.Имя] Цикл
				СтрокаСсылки = Ссылка[тч.Имя].Получить(строкаОбъекта.НомерСтроки - 1);
				Для Каждого Реквизит из тч.Реквизиты Цикл
					Если СтрокаСсылки[Реквизит.Имя] <> строкаОбъекта[Реквизит.Имя] Тогда
						СписокИзменённыхРеквизитов.Добавить(тч.Имя + "." + Реквизит.Имя);
					КонецЕсли;
				КонецЦикла;
			КонецЦикла;
		Иначе
			СписокИзменённыхРеквизитов.Добавить(тч.Имя);
		КонецЕсли;
	КонецЦикла;
	
	Возврат СписокИзменённыхРеквизитов;
КонецФункции

// Сравниваем массив изменённых реквизитов с массивом реквизитов, разрешённых к изменению
// возвращает пустую строку, если документ можно записывать или список изменённых реквизитов из-за которых документ нельзя записать
Функция МожноЗаписыватьБезПерепроведения(ДокОбъект, МассивРеквизитовДопустимыхКИзменению, СписокИзменённыхРеквизитов = Неопределено) Экспорт
	стр = "";
	Если СписокИзменённыхРеквизитов = Неопределено Тогда
		СписокИзменённыхРеквизитов = ПолучитьСписокИзменённыхРеквизитов(ДокОбъект);
	КонецЕсли;
	Для Каждого зн из СписокИзменённыхРеквизитов Цикл
		Если МассивРеквизитовДопустимыхКИзменению.Найти(зн) = Неопределено Тогда
			стр = стр + "
			|" + зн;
		КонецЕсли;
	КонецЦикла;
	Возврат стр;
КонецФункции

В модуле документа ПредЗаписью разрешаем запись без пререпроведения в случае, если были изменены только реквизиты, не вызывающие перепроведение.

РедактированиеЗаднимЧислом = Ложь;
МассивРеквизитовДопустимыхКИзменению = Документы.РеализацияТоваровУслуг.ПолучитьМассивРеквизитовИзменяемыхБезПерепроведения();
СписокИзменённыхРеквизитов = ОбщегоНазначения.ПолучитьСписокИзменённыхРеквизитов(ЭтотОбъект);
СписокИзменённыхРеквизитовВызывающихПерепроведение = ОбщегоНазначения.МожноЗаписыватьБезПерепроведения(ЭтотОбъект, МассивРеквизитовДопустимыхКИзменению, СписокИзменённыхРеквизитов);
Если СписокИзменённыхРеквизитовВызывающихПерепроведение = "" И Проведен И СписокИзменённыхРеквизитов.Количество() > 0 Тогда
	РежимЗаписи = РежимЗаписиДокумента.Запись;
ИначеЕсли НЕ РедактированиеЗаднимЧислом и Дата < НачалоДня(ТекущаяДата()) И Не РольДоступна("ПравоАдминистрирования") Тогда
	Сообщить("Недостаточно прав для проведения реализации " + Номер + " " + Строка(Дата) +
			" задним числом. Изменены реквизиты: " + СписокИзменённыхРеквизитовВызывающихПерепроведение);
	Отказ = Истина;
КонецЕсли;

В этой заметке не рассмотрена установка флага ТолькоПросмотр для реквизитов формы, которые нельзя редактить. Это делается сосем несложно.

Не знаю, может быть подобное решение уже есть в БСП. Не смотрел.

газета Суть Времени

См. также

PowerTools от 1 000
Подписаться Добавить вознаграждение

Комментарии

1. Князь (Князь) 19.11.14 13:45
С выбором режима проведения в зависимости от того, какие реквизиты были изменены, получилось очень необычно. Возьму на карандаш/клавиатуру. Ещё можно додумать идею и в несколько строк дополнить сию процедуру регистрацией события изменения реквизита, для детального журнала, кто когда и что именно изменил в документе.
2. Трактор Трактор (Трактор) 19.11.14 13:49
(1) Обрати внимание, что режим записи не меняется, если нет изменений. Это надо на случай перепроведения. А то как-то раз стукнулся, об то, что перепроведение не выполняется.
3. Евгений Шабалин (xzorkiix) 19.11.14 16:57
Из статьи узнал, что блогов нет. Зря они это. не пользовался, но в целом ветка была уместной (статьи и публикации для основательного труда, блог для мелких пометок на полях для себя и заинтересованных)
4. Евгений Шабалин (xzorkiix) 19.11.14 17:04
Функция А()
Возврат Неопределено;
КонецФункции

Эффект этого равносилен

Функция А()
КонецФункции
5. Трактор Трактор (Трактор) 19.11.14 17:06
(4) Читаемость кода тоже важна.
6. Armando Armando (Armando) 19.11.14 21:58
Буква ё не раскрашивается))
Ее кстати нельзя использовать в модулях.
7. Трактор Трактор (Трактор) 19.11.14 23:32
Ее кстати нельзя использовать в модулях.

(6) Armando, не знал. Использую. Работпет.
8. Armando Armando (Armando) 20.11.14 00:00
(7) Трактор, нашел:

"4. В именах, синонимах и комментариях не допускается использовать букву "ё"."
http://its.1c.ru/db/v8std#content:2149184123:hdoc

"В текстах модулях не допускается использовать букву "ё"."
http://its.1c.ru/db/v8std#content:2149184105:hdoc
Трактор; +1 Ответить 1
9. Ю М (mtv:)) 20.11.14 08:44
Хочу обратить Ваше внимание, что на Инфостарте есть еще одна публикация о редактировании реквизитов в закрытом периоде - "Есть ли жизнь в закрытом периоде? Или способ заставить работать "Обработку заполнения табличных частей" в закрытом периоде".
В этой публикации рассматриваются два способа:
1. С минимальными изменениями кофигурации (добавляется всего ОДНА строка!);
2. Без внесения изменений в конфигурацию.
rozer; endru; +2 Ответить 1
10. Трактор Трактор (Трактор) 20.11.14 10:39
(8) Armando, проверил на типовой БП3. В ней есть функции ЗаменитьБуквуЁ ПодготовитьКПоискуПоФИОСБуквамиЕЁ, СтруктураПараметровДляРасчётаАпдекса. Так и называются. А в комментариях Ё встречается в полный рост. И это правильно. Незаслуженно букву обидели. 1С сама не придерживается своих рекомендаций. Но мы учтём.

(9) mtv:), хорошее решение. Замечание только одно. Объект.ОбменДанными.Загрузка = Истина возможно использовать не всегда. Если его не использовать то количество строк кода растёт.

Посмотрел на твою обработку. Редактирование с помощью функций ВвестиЧисло, ВвестиСтроку, ВвестиЗначение удобным никак никак не назовёшь. Это решение для очень редкого редактирования. Моё решение для случаев, когда вчерашние документы перепроводить нельзя, но вспомогательные данные вносить требуется.
11. Сергей (ildarovich) 20.11.14 11:07
(6)(10) А я вот как использовал букву ё, так и буду дальше использовать. Мне она нравится своей "нарядностью". Думаю, это ошибочная рекомендация.
SeiOkami; and-blag; FrLenok; wolfsoft; Puk2; Светлый ум; Патриот; shootnik; Трактор; +9 Ответить 1
12. Leonid T (OdinAss) 20.11.14 15:52
Реализовывал вторую задачу внешней обработкой без изменения конфы (но новые значения реквизита пользователь выбирал в форме обработки, а не в документах) в БП 3.0. Не очень читабельно, но оставлю здесь ключевой кусок, может пригодиться кому =)

&НаСервере
Процедура УстановитьНаСервере()
	
	УстановитьПривилегированныйРежим(Истина);

// для отмены проверки даты запрета изменения можно использовать
// Док.ДополнительныеСвойства.Вставить("ПропуститьПроверкуЗапретаИзменения",
// Истина); 
// но т.к. вслед за РТУ/ПТУ перезаписываются связанные с/ф, для которых 
// доп. свойство не передать, то использовал следующее 
// (устанавливает параметр сеанса ПропуститьПроверкуЗапретаИзменения)

	ДатыЗапретаИзмененияСлужебный.ПропуститьПроверкуЗапретаИзменения(Истина);

//заполняю нужный реквизит в документах

	Для Каждого Строка Из Объект.СписокДокументов Цикл
		Если Строка.Статус <> Строка.НовСтатус 
			И Строка.НовСтатус <> Перечисления.СтатусыДокументов.ПустаяСсылка() Тогда
			Док = Строка.Документ.ПолучитьОбъект();
			Док.Статус = Строка.НовСтатус;
			Попытка
				Док.Записать(РежимЗаписиДокумента.Запись);
				Строка.Статус = Строка.НовСтатус;

// документ записан, но если период закрыт, то необходимо восстановить его 
// в последовательности проведения документов

				Если ДатыЗапретаИзмененияСлужебный.ИзменениеИлиЗагрузкаЗапрещена(Док,Док.Ссылка,Ложь) Тогда 
					ВернутьВПоследовательность(Док.Ссылка);
				КонецЕсли;

// тоже самое для счетов-фактур

				Если ТипЗнч(Док) <> Тип("ДокументОбъект.АктСверкиВзаиморасчетов") Тогда
					СчетФактура = УчетНДСПереопределяемый.НайтиПодчиненныйСчетФактуруВыданныйНаРеализацию(Док.Ссылка);
					Если СчетФактура <> Неопределено И Не СчетФактура.Пустая() Тогда
						Если ДатыЗапретаИзмененияСлужебный.ИзменениеИлиЗагрузкаЗапрещена(СчетФактура.ПолучитьОбъект(),СчетФактура,Ложь) Тогда
							ВернутьВПоследовательность(СчетФактура);
						КонецЕсли;
					КонецЕсли;
				КонецЕсли;				
			Исключение
				Сообщить("Не удалось изменить статус: " + Строка.Документ);
			КонецПопытки;
		КонецЕсли;
	КонецЦикла;

//возвращаем параметр сеанса

	ДатыЗапретаИзмененияСлужебный.ПропуститьПроверкуЗапретаИзменения(Ложь);
	УстановитьПривилегированныйРежим(Ложь);
	
КонецПроцедуры

&НаСервере
Процедура ВернутьВПоследовательность(ДокСсылка)

	НаборЗаписей = Последовательности.ДокументыОрганизаций.СоздатьНаборЗаписей();
		
	НаборЗаписей.Отбор.Регистратор.Значение = ДокСсылка;
	НаборЗаписей.Отбор.Регистратор.Использование = Истина;
	НаборЗаписей.Прочитать();
	НаборЗаписей.Очистить();
		
	Запись = НаборЗаписей.Добавить();
	//Запись.Период = Новый МоментВремени(ДокСсылка.Дата,ДокСсылка);
	Запись.Период = ДокСсылка.Дата;	
	Запись.Регистратор = ДокСсылка;
	Запись.Организация = ДокСсылка.Организация;
	Запись.СостояниеПроведения = Перечисления.СостоянияПроведенияВПоследовательности.ПроведенВПоследовательности;
	
	НаборЗаписей.Записать(Истина);
	
КонецПроцедуры
...Показать Скрыть
kostyaomsk; Трактор; +2 Ответить
13. Алексей Молодов (Allexe8.1) 21.11.14 17:39
Проверку на наличие ссылки в базе, думаю, лучше запросом делать:
//1) объектный способ, получаются все реквизиты, все ТЧ объекта:
НетСсылки = СсылкаНаОбъект.ПолучитьОбъект() = Неопределено

//2) метод запроса, только проверка:
Запрос = Новый Запрос("ВЫБРАТЬ ПЕРВЫЕ 1 1 ИЗ " + ИмяКласса+ "." + ИмяВида + " ГДЕ Ссылка = &Ссылка");
Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
РезультатЗапроса = Запрос.Выполнить();
НетСсылки = РезультатЗапроса.Пустой();
...Показать Скрыть
u_n_k_n_o_w_n; +1 Ответить 1
14. Трактор Трактор (Трактор) 21.11.14 17:56
(13) Allexe8.1,
1. СсылкаНаОбъект.ПолучитьОбъект() у меня используется. Это, кстати, довольно тяжёлый метод. Я всё думал как обойтись без него, но не придумал. Метод тяжёл так как при получении объекта происходит инициализация модуля объекта, а что там понаписал программист мы не знаем.

2. Читать запросом реквизиты ссылки, конечно прикольно, но в этом случае число запросов будет на один больше числа табличных частей объекта. А если читать реквизиты как Ссылка (точка) Имя реквизита, то значения реквизитов кэшируются и/или подтягиваются при чтении, точно не помню. Важно что число запросов к базе примерно такое же как и при чтении запросом. Только эти запросы выполняются в фоне. По сути разницы нет как читать реквизиты ссылки.
15. Князь (Князь) 24.11.14 05:10
(11) ildarovich, поддерживаю. С детства всем прививали, что в русском языке 33 (тридцать три) буквы. А сейчас принуждают самих себя ограничивать и незаслуженно дискредитиировать бедную букву.
И вообще, мало кто значет, что бёквё ё с лёгкёстьё мёжёт зёмёнёть всё ёстёльнёё бёквё.
BorisBelov; Светлый ум; Allexe8.1; Трактор; +4 Ответить
17. Сергей Рудаков (fishca) 24.11.14 15:59
1. Тексты модулей должны быть написаны на русском языке. В текстах модулях не допускается использовать букву "ё".

Они вообще сами-то с русским языком дружат !!!???
18. Александр Макаров (DarLord) 26.11.14 11:18
(17) А какой оператор ты хочешь с буквой Ё написать???
19. DAnry (DAnry) 26.11.14 14:30
Всё понимаю, вот только зачем мертвеца реанимировать (имею ввиду илюстрацию к статье)!?
20. DAnry (DAnry) 26.11.14 14:51
Насчёт буквы ё. Конечно нельзя ёё так "опускать". Это изюминка русского языка, не дайте ей исчезнуть. Сам я не русский, но думаю имею право высказать своё мнение, потому что у нас, украинцев, тоже есть похожая ситуация, даже две - "ї" и "ґ". Берегите родной язык.
BorisBelov; Allexe8.1; Трактор; +3 Ответить
21. Михаил Максимов (МихаилМ) 26.11.14 14:52
"// Тип - наименование вида справочника или документа. Благо их наименования не пересекаются."

враньё. можно запросто создать документ и справочник с одинаковыми названиями.
те будут "пересекаться"
так что код условно рабочий.
Прикрепленные файлы:
22. Трактор Трактор (Трактор) 26.11.14 15:33
вот только зачем мертвеца реанимировать

(19) DAnry, капитализм принёс уже две мировые войны. Боюсь, что сейчас мы живём в начальный период третьей мировой войны. Капитализм смог развалить СССР. Но СССР жив пока жив, например, я и другие, разделяющие мои убеждения. Я надеюсь возродить СССР, исправив ошибки.

враньё. можно запросто создать документ и справочник с одинаковыми названиями.

(21) МихаилМ, это кусок кода и комментарий из работающей конфы. В ней имена справочников и документов не пересекаются.
Как-нибудь поправлю, уберу это замечание или напишу, что нежелательно пересекать названия.
23. Константин Юрин (kostyaomsk) 26.11.14 18:57
Про доступ к сайту по ГУИД не понял. Наверное Вы говорили про доступ к базе 1С 8?
Про "перепроведение" тоже приемы могут пригодиться. Жаль что не всегда.
Вопрос как быть если конфигурация в желтых кубах "за замке" и трогать ее нельзя. Пишите что и нижеприведенный прием не помогает.

ДокОбъект.ОбменДанными.Записать = Истина;
ДокОбъект.Записать(РежимЗаписиДокумента.Запись);

Я спросил про задачи, когда нужно программно перезаполнить документы в прошлом закрытом периоде или установить значение нового реквизита.
Не всегда ведь даже признак в свойствах у документа может быть "записывать модифицированные при проведении" и прочие свойства формы документа "при записи перепроводить".
Когда все закрыто тут как быть то?
Прикрепленные файлы:
24. Трактор Трактор (Трактор) 26.11.14 22:51
Вопрос как быть если конфигурация в желтых кубах "за замке" и трогать ее нельзя

(23) kostyaomsk, тогда остаются только внешние обработки. О них написано выше. Можно хоть печатную форму, обработку заполнения табличной части использовать для этого. Открывать свою форму и из неё редактить что угодно.

Я не говорил, что нельзя использовать конструкцию
ОбменДанными.Записать = Истина; 

Можно. Но надо помнить о последствиях. Для распределённой базы, для логики, связанной с изменяемыми реквизитами. Короче говоря если осторожно, то можно всё.
kostyaomsk; +1 Ответить 1
25. Константин Юрин (kostyaomsk) 28.11.14 07:21
(24) Трактор, спасибо, видел что можно внешними обработками реализовать такие функции записи без проведения. Возможно, в отраслевых конфигурациях опять что-то попалось из обработчиков. Проверю на типовых.
26. gad sas (sas95) 09.12.14 14:20
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа