Выбор в таблице значений

Опубликовал Игорь Пашутин (Alien_job) в раздел Программирование - Работа с интерфейсом

Удобная форма для организации множественного выбора из таблицы значений

Часто необходимо, чтобы пользователь выбрал несколько значений из ТЗ. Чтобы вновь и вновь не рисовать формы и не изобретать велосипед, сделал шаблон для выбора строк таблицы значений.

Результат выбора возвращается через оповещение, поэтому на время выбора не блокируются другие окна пользователя. При необходимости можно открыть форму модально и получить результат "в той же строке". Еще бантик - пометить все/снять пометки.

Скачать файлы

Наименование Файл Версия Размер
Выбрать из таблицы значений
.epf 11,16Kb
20.11.14
22
.epf 11,16Kb 22 Скачать

См. также

Добавить вознаграждение
Комментарии
1. Марина Семёнова (SemenovaMarinaV) 02.12.14 11:33 Сейчас в теме
2. Игорь Пашутин (Alien_job) 108 02.12.14 12:05 Сейчас в теме
(1) SemenovaMarinaV, именно пометка и сделана. Достаточно написать:
	
        ФормаВыбора = ПолучитьФорму("ФормаВыбораИзТЗ");
	ФормаВыбора.ТЗ = РезультатЗапроса.Выгрузить();
	ФормаВыбора.ВладелецФормы = ЭтаФорма;
	ФормаВыбора.Открыть();
...Показать Скрыть


автоматически добавится колонка пометки и откроется форма редактирования ТЗ
остается только получить результат выбора пользователя

Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

	// Параметр - результат выбора.

	Если ИмяСобытия = "Выбор из ТЗ" Тогда
		Если Источник = ЭтаФорма Тогда
			
			ТаблицаДляТеста.Загрузить( Параметр);
			
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть